Wheezy totem/minitube no mp4 playback

Everything about X, Gnome, KDE, ... and everything running on it

Wheezy totem/minitube no mp4 playback

Postby Hate029 » 2012-03-08 08:36

Just installed yesterday fresh Wheezy and noticed that mp4 videos don't play. And of course 90 % of my videos are mp4:s. Also minitube won't play videos from youtube that are in mp4 format.

I've tried to install every package that has name 'gstreamer' in it but it didn't help. More googling after that and somebody got help by removing ~/.gstreamer0.10 - this wasn't the case with me. Also looked up gstreamer-properties but everything seems to be fine there. Also totem --debug didn't give me anything. Vlc and mplayer plays mp4:s fine. But I'd like to use minitube and working totem would be nice too. Also there's no thumbnails for mp4:s at the moment.
Last edited by Hate029 on 2012-03-09 05:54, edited 1 time in total.
Hate029
 
Posts: 37
Joined: 2011-08-04 12:27

Re: Whezy totem/minitube no mp4 playback

Postby vbrummond » 2012-03-08 11:04

Mp4 as in mpeg4 or mp4 with h264? Either way they should play, as Debian has support for both. You said you installed all of gstreamer I know, but double check to make sure you installed:
Code: Select all
apt-get install gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-ugly


I will double check to make sure it is not just a bug in gstreamer.
System: Retina 5K iMac, 27-inch, Late 2015 - Intel i5-6600 3.3ghz, 8gb RAM, AMD Radeon R9 M395 2048 MB
OS: Mac OS 10.12
vbrummond
 
Posts: 4417
Joined: 2010-03-02 01:42

Re: Whezy totem/minitube no mp4 playback

Postby Hate029 » 2012-03-08 11:17

0 new packages installed. with apt-get so no help with that.

Funny thing is that I've installed wheezy few weeks ago to another computer and it works fine. I'm not sure though have I installed all updates in time to that.
Hate029
 
Posts: 37
Joined: 2011-08-04 12:27

Re: Whezy totem/minitube no mp4 playback

Postby vbrummond » 2012-03-08 11:21

With phonon-gstreamer I can play both mpeg4 and h264 in dragon-player.
System: Retina 5K iMac, 27-inch, Late 2015 - Intel i5-6600 3.3ghz, 8gb RAM, AMD Radeon R9 M395 2048 MB
OS: Mac OS 10.12
vbrummond
 
Posts: 4417
Joined: 2010-03-02 01:42

Re: Whezy totem/minitube no mp4 playback

Postby Hate029 » 2012-03-08 11:52

Yes. Dragonplayer plays everything fine.

Few notes to add. Some mp4:s seems to play fine. Noticed that thumbnails worked with some files and tried to play them with totem which worked flawlessy. Also if I try to open properties of non-working mp4, it just stalls to a situation where it tries to open the properties but nothing happens. Files are not corrupted, that is for sure.

I confirmed this with minitube. If minitube played video fine, totem did too. If it didn't work in minitube, it didn't work with totem either.
Hate029
 
Posts: 37
Joined: 2011-08-04 12:27

Re: Whezy totem/minitube no mp4 playback

Postby vbrummond » 2012-03-08 11:55

Yes, it is certainly a gstreamer problem then. Also, if you have ffmpeg installed could you post the output of a corrupted file with this command:
Code: Select all
ffmpeg -i /path/to/corrupted/file.mp4


This won't damage the file, it just prints information about it.
System: Retina 5K iMac, 27-inch, Late 2015 - Intel i5-6600 3.3ghz, 8gb RAM, AMD Radeon R9 M395 2048 MB
OS: Mac OS 10.12
vbrummond
 
Posts: 4417
Joined: 2010-03-02 01:42

Re: Whezy totem/minitube no mp4 playback

Postby Hate029 » 2012-03-08 12:09

Output:
Code: Select all
ffmpeg -i yt01.mp4
ffmpeg version 0.10 Copyright (c) 2000-2012 the FFmpeg developers
  built on Feb 14 2012 14:57:55 with gcc 4.6.2
  configuration: --prefix=/usr --extra-cflags='-Wall -g ' --cc='ccache cc' --enable-shared --enable-libmp3lame --enable-gpl --enable-nonfree --enable-libdirac --disable-decoder=libdirac --enable-libvorbis --enable-pthreads --enable-libfaac --enable-libxvid --enable-postproc --enable-x11grab --enable-libgsm --enable-libtheora --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libx264 --enable-libspeex --enable-nonfree --disable-stripping --enable-libschroedinger --disable-encoder=libschroedinger --enable-version3 --enable-libopenjpeg --enable-libvpx --enable-librtmp --enable-avfilter --enable-libfreetype --enable-libvo-aacenc --disable-decoder=amrnb --enable-libvo-amrwbenc --enable-libaacplus --libdir=/usr/lib/x86_64-linux-gnu --disable-vda --enable-libdc1394 --disable-altivec --disable-armv5te --disable-armv6 --disable-vis --shlibdir=/usr/lib/x86_64-linux-gnu
  libavutil      51. 34.101 / 51. 34.101
  libavcodec     53. 60.100 / 53. 60.100
  libavformat    53. 31.100 / 53. 31.100
  libavdevice    53.  4.100 / 53.  4.100
  libavfilter     2. 60.100 /  2. 60.100
  libswscale      2.  1.100 /  2.  1.100
  libswresample   0.  6.100 /  0.  6.100
  libpostproc    52.  0.100 / 52.  0.100
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'yt01.mp4':
  Metadata:
    major_brand     : mp42
    minor_version   : 0
    compatible_brands: isomavc1mp42
    creation_time   : 2008-10-16 10:42:56
  Duration: 00:04:08.75, start: 0.000000, bitrate: 631 kb/s
    Stream #0:0(und): Audio: aac (mp4a / 0x6134706D), 44100 Hz, stereo, s16, 127 kb/s
    Metadata:
      creation_time   : 2008-10-16 10:42:56
      handler_name    : (C) 2007 Google Inc. v08.13.2007.
    Stream #0:1(und): Video: h264 (Baseline) (avc1 / 0x31637661), yuv420p, 480x360 [SAR 1:1 DAR 4:3], 501 kb/s, 24.99 fps, 24.99 tbr, 24992 tbn, 49984 tbc
    Metadata:
      creation_time   : 2008-10-16 10:42:56
      handler_name    :
At least one output file must be specified


I have backups of everything atm as I'm upgrading pc and op. It should've been an easy process but no. Many problems lie unsolved..
Hate029
 
Posts: 37
Joined: 2011-08-04 12:27

Re: Whezy totem/minitube no mp4 playback

Postby vbrummond » 2012-03-08 12:15

I am stumped about this it seems that ffmpeg can use it fine; Which means gstreamer should also be able to... It does not show any frame rate shenanigans which was what I expected. I guess the old fashioned wait for an update? :(

Hopefully someone else on Wheezy Gnome will chime in as I am on KDE.
System: Retina 5K iMac, 27-inch, Late 2015 - Intel i5-6600 3.3ghz, 8gb RAM, AMD Radeon R9 M395 2048 MB
OS: Mac OS 10.12
vbrummond
 
Posts: 4417
Joined: 2010-03-02 01:42

Re: Whezy totem/minitube no mp4 playback

Postby craigevil » 2012-03-08 18:04

No issues here. But like vbrummond, I am on KDE.

Code: Select all
$ dpkg -l|grep gstreamer
ii  gstreamer0.10-alsa                   0.10.36-1                      GStreamer plugin for ALSA
ii  gstreamer0.10-ffmpeg                 1:0.10.13-0.2                  FFmpeg plugin for GStreamer
ii  gstreamer0.10-gconf                  0.10.31-1                      GStreamer plugin for getting the sink/source information from GConf
ii  gstreamer0.10-plugins-bad            0.10.23-1                      GStreamer plugins from the "bad" set
ii  gstreamer0.10-plugins-base           0.10.36-1                      GStreamer plugins from the "base" set
ii  gstreamer0.10-plugins-good           0.10.31-1                      GStreamer plugins from the "good" set
ii  gstreamer0.10-plugins-ugly           0.10.19-1                      GStreamer plugins from the "ugly" set
ii  libgstreamer-plugins-bad0.10-0       0.10.23-1                      GStreamer development files for libraries from the "bad" set
ii  libgstreamer-plugins-base0.10-0      0.10.36-1                      GStreamer libraries from the "base" set
ii  libgstreamer0.10-0                   0.10.36-1                      Core GStreamer libraries and elements
ii  phonon-backend-gstreamer             4:4.6.0.0-1                    Phonon GStreamer 0.10.x backend


Code: Select all
$ dpkg -l|grep ffmpeg
ii  ffmpeg                               5:0.10-0.1                     audio/video encoder, streaming server & audio/video file converter.
ii  gstreamer0.10-ffmpeg                 1:0.10.13-0.2                  FFmpeg plugin for GStreamer
ii  libsox-fmt-ffmpeg                    14.3.2-3                       SoX ffmpeg format library
ii  libxine1-ffmpeg                      1:1.1.20.1-0.1                 MPEG-related plugins for libxine1
ii  moc-ffmpeg-plugin                    1:2.5.0~alpha4+svn20120224-1   ncurses based console audio player - ffmpeg plugin
Debian Sid KDE Kernel 3.17 Thinkpad R40 Intel M 1.3 CPU 2GB RAM Radeon Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Debian upgrade script smxi | sysinfo script inxi
User avatar
craigevil
 
Posts: 5192
Joined: 2006-09-17 03:17
Location: Oz

Re: Whezy totem/minitube no mp4 playback

Postby Hate029 » 2012-03-09 05:51

Well, this will be a mystery for some time but I hope that updates will fix this. I found other more worse problems, so I decided to "downgrade" to Squeeze for now. I thought Wheezy would be stable enough for this computer but not yet.

What can I say to this problem? Use mplayer/smplayer/vlc/dragonplayer etc. they'll work just fine. Until update will fix this.
Hate029
 
Posts: 37
Joined: 2011-08-04 12:27

Re: Wheezy totem/minitube no mp4 playback

Postby Xylock » 2012-03-14 05:47

Just chiming in to say I have had the same problem; didn't notice it at first since I haven't played vids for a while. I run a Sid desktop and a Wheezy laptop (both using GNOME). Both these systems played MP4's fine back in November. I noticed a big change in Totem when I next updated, and it's been since then that some of my MP4's haven't played, for both systems. Mplayer is still fine, as you noted. Like you I figured I'd just wait for updates (dpkg gives me very similar output to Craigevil).
Using rm -rvf * to remove old backups... lazy.
Realising you were in / as root ... priceless.
Xylock
 
Posts: 43
Joined: 2007-04-11 13:28


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable