weird problem with keyboard and mouse (disabled devices)

Everything about X, Gnome, KDE, ... and everything running on it

weird problem with keyboard and mouse (disabled devices)

Postby kerem » 2012-10-14 16:21

Hi

I am having an issue with my laptops keyboard and mouse under Squeeze. My debian works fine, however it seems like during the gnome login screen, the laptop`s keyboard and the mouse are disabled. But if i attach an external mouse and keyboard they work in the gnome session. Here is the twist. If the external keyboard and the mouse are also attachedduring the login they do not work as well. So for some reason only hot plug peripherals work as far as I can see. The problem is that I do not know how or why :(

I can use the internal keyboard during grub boot or in an alternate shell (via alt+ctrl+f2 etc). But they just do not work in the gdm3 session as far as I can tell.

Does anyone know any possiblity that can produce such weird issue? I use this as a server and I normally do not interact with it so much. I have been duing upgrades regularly so I am really not sure at what point this issue might have been introduced.

thanks
kerem
 
Posts: 190
Joined: 2010-06-16 16:29

Re: weird problem with keyboard and mouse (disabled devices)

Postby verahill » 2012-10-15 03:15

Sounds very, very familiar: http://verahill.blogspot.com.au/2011/05 ... rk-on.html

i.e. keyboard works up until gdm starts and plugging in a usb keyboard after boot works.
Try:
Code: Select all
sudo mv /run /xrun

and reboot. Hopefully this will work. Make sure to read the post above first -- in particular regarding /var/run
--------------------------------------------------
http://verahill.blogspot.com
OPs: don't forget to mark your (first) post as solved when the issue has been resolved.
User avatar
verahill
 
Posts: 327
Joined: 2012-05-29 07:03
Location: Australia

Re: weird problem with keyboard and mouse (disabled devices)

Postby kerem » 2012-10-19 02:16

Hi

Thanks for the verahill. However I do not have any /run folder to be honest. So I actually looked at similar solutions which none of them worked.The only solution that worked for me to add this option to xorg.conf under ServerLayout

Code: Select all
 Option "AllowEmptyInput" "false"
kerem
 
Posts: 190
Joined: 2010-06-16 16:29


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable