Popping noise on reboot from Debian

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Popping noise on reboot from Debian

Postby amcc1996 » 2017-06-15 20:08

Hello Debian community!

I am having a big trouble with a popping noise from my speakers whenever I reboot from Debian. This does not happen when I reboot from Windows, or when i turn on my pc for the first time, only when I am using Debian and I decide to turn off or reboot my pc. Then, I hear 2 popping noises coming from my sepakers, anda the second one is stronger than the first one.

I'v already tried:

https://forums.linuxmint.com/viewtopic.php?t=184635 - but it seems that the directory /etc/init/alsa-store.conf does not exists

https://bbs.archlinux.org/viewtopic.php?id=103152 - but the directory /etc/rc.d/alsa does not exists either, but I have the following in /etc: rc0.d rc1.d rc2.d rc3.d rc4.d rc5.d rc6.d and in rc0.d and rc6.d I have K01alsa-utils

I don't know what other information would bu useful, so if you could tell me what kinda of information you would need, i'll be glad .

My computer is an Acer Aspire 5742G.

Thank you for your help!

[EDIT] I will move this question to Hardware section.
amcc1996
 
Posts: 4
Joined: 2017-06-15 19:49

Re: Popping noise on reboot from Debian

Postby sunrat » 2017-06-16 00:06

Sorry I can't be more helpful but I work in sound for concerts and a general rule is turn off amplifiers/speakers before turning off anything that feeds signal to them. Most times you will get away with it, but sometimes it will cause damage. I recently damaged my ADAM studio monitor by forgetting this.
Sound cards and sound drivers are not all created equal. Some will handle switch off fine and mute the output, but some will allow a pop or spike to occur, which is what happened to mine.
I hope you find a better solution but don't hold your breath.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2019
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Popping noise on reboot from Debian

Postby amcc1996 » 2017-06-16 05:19

Actually that is what I was trying to do! I tried to rmmod snd-hda-intel in a certain file that those 2 previous posts advised, but i can't manage to find those files.
amcc1996
 
Posts: 4
Joined: 2017-06-15 19:49

Re: Popping noise on reboot from Debian

Postby orythem27 » 2017-06-16 06:07

amcc1996 wrote:Actually that is what I was trying to do! I tried to rmmod snd-hda-intel in a certain file that those 2 previous posts advised, but i can't manage to find those files.

The second post is from the sysvinit era, which is too old. You probably would like to research on "How to execute something before shutdown with systemd". e.g. https://unix.stackexchange.com/questions/39226/how-to-run-a-script-with-systemd-right-before-shutdown
https://bbs.archlinux.org/viewtopic.php?id=188858

Disclaimer: I myself havn't tested.
User avatar
orythem27
 
Posts: 252
Joined: 2017-05-11 07:59
Location: P.R. China

Re: Popping noise on reboot from Debian

Postby debiman » 2017-06-16 20:25

amcc1996, both forum threads from your original post suggest a lot of stuff. have you tried all? please report.

i once created a popping noise by setting power_save=1, so i suggest you try by setting power_save=0, maybe edit /etc/default/grub to that effect.
maybe that will fix it already.

if not, and you want to try what was suggested on the (old) archlinux thread, start with
Code: Select all
grep -R 'alsactl store' /etc 2>/dev/null
to find the appropriate file(s).
User avatar
debiman
 
Posts: 1341
Joined: 2013-03-12 07:18

Re: Popping noise on reboot from Debian

Postby amcc1996 » 2017-06-19 16:39

Setting power_save=0 in /etc/default/grub had no effect.
The ouput of the command you suggested is:

Code: Select all
/etc/init.d/alsa-utils:      log_action_cont_msg "warning: 'alsactl store${CARD:+ $CARD}' failed with error message '$MSG'"
/etc/rcS.d/S19alsa-utils:      log_action_cont_msg "warning: 'alsactl store${CARD:+ $CARD}' failed with error message '$MSG'"
/etc/rc1.d/K01alsa-utils:      log_action_cont_msg "warning: 'alsactl store${CARD:+ $CARD}' failed with error message '$MSG'"
/etc/rc6.d/K01alsa-utils:      log_action_cont_msg "warning: 'alsactl store${CARD:+ $CARD}' failed with error message '$MSG'"
/etc/rc0.d/K01alsa-utils:      log_action_cont_msg "warning: 'alsactl store${CARD:+ $CARD}' failed with error message '$MSG'"


What I understand of that output, is that 'alsactl store' exists in my pc only in warning messages, it seems that it doesn't exist as an operation.
amcc1996
 
Posts: 4
Joined: 2017-06-15 19:49

Re: Popping noise on reboot from Debian

Postby phenest » 2017-06-19 17:25

Some different ways to implement pawer_save other than kernel line:
https://askubuntu.com/questions/160882/popping-noise-from-laptop-speakers
And an alternative if you're using PulseAudio (OP gives the resolution at the end of their first post):
https://forums.linuxmint.com/viewtopic.php?t=184635
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS Sabertooth P67 i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1571
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Popping noise on reboot from Debian

Postby amcc1996 » 2017-06-20 14:56

I think I solved my problem, based on this post https://forums.linuxmint.com/viewtopic.php?t=184635 but with some changes.

1 - I edited the file /etc/pulse/client.conf and uncmomented (removed the ;'s) the lines:
Code: Select all
autospawn = yes
daemon-binary = /usr/bin/pulseaudio

and changed the first one to autospawn = no so they look like:

Code: Select all
autospawn = no
daemon-binary = /usr/bin/pulseaudio


2 - Then, I edited the file /lib/systemd/system/alsa-store.service add added the following lines at the end, after ExecStart=/usr/sbin/alsactl -E HOME=/var/run/alsa store
:

Code: Select all
ExecStart=/usr/bin/amixer set Master mute >/dev/null
ExecStart=/sbin/modprobe -r snd-hda-intel


3 - Saved, rebooted, [b][u]the sound happened again, but in the following reboots, it didn't happen.

4 - The sound keeps happening when shuting down my pc, but not when rebooting.
amcc1996
 
Posts: 4
Joined: 2017-06-15 19:49


Return to Hardware

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable