Drivers for Brother printer: dependencies

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Drivers for Brother printer: dependencies

Postby davidss » 2018-03-12 11:15

Hi,

I have recently installed Debian buster (64 bit architecture), and the time has come to get my printer to work (Brother MFC-7320). I have tried what I did previously in jessie (viewtopic.php?f=7&t=124989; briefly, installed two .debs with dpkg --force-all), and it does work (I can print), but I do have another problem: when I try for example

Code: Select all
sudo aptitude upgrade

the system says:

Code: Select all
The following packages have unmet dependencies:
 brmfc7320lpr:i386 : Depends: libc6:i386 (>= 2.3.4-1) which is a virtual package and is not provided by any available package

 cupswrappermfc7320:i386 : Depends: libc6:i386 (>= 2.3.4-1) which is a virtual package and is not provided by any available package

The following actions will resolve these dependencies:

     Remove the following packages:           
1)     brmfc7320lpr:i386 [2.0.2-1 (now)]     
2)     cupswrappermfc7320:i386 [2.0.2-1 (now)]



Accept this solution? [Y/n/q/?]

I didn't have that problem the previous time (I have been using aptitude in that Debian all the time), but I can't recall anything I did for that. It is possible that I allowed another architecture. My questions are:

1. Can I do anything to appease aptitude, other than installing the i386 version of libc6? Another set of drivers, perhaps ("aptitude search brother" gave nothing).
2. Do you advise against mixing two architectures?

Thanks
davidss
 
Posts: 15
Joined: 2013-11-03 14:21

Re: Drivers for Brother printer: dependencies

Postby Ardouos » 2018-03-12 13:21

You can add 32 bit libs as a foreign architecture on a 64 bit system without problems.

https://wiki.debian.org/Multiarch
User avatar
Ardouos
 
Posts: 1007
Joined: 2013-11-03 00:30
Location: Elicoor II

Re: Drivers for Brother printer: dependencies

Postby Dai_trying » 2018-03-12 13:31

When I installed my Brother HL2340DW I used the installation script provided by the Brother support site, it installed everything I needed (including i386 packages) and everything worked very smoothly, although after this I did have an issue when trying to install some upgrades as the system didn't like having these i386 packages without the architecture being available. I added the i386 arch using dpkg and everything has been running correctly since.
Dai_trying
 
Posts: 532
Joined: 2016-01-07 12:25

Re: Drivers for Brother printer: dependencies

Postby davidss » 2018-03-13 08:28

Thanks a lot. I did

Code: Select all
sudo dpkg --add-architecture i386

and everything went well from there.
davidss
 
Posts: 15
Joined: 2013-11-03 14:21


Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable