My internal microphone is not working properly

Getting your soundcard to work, using Debian on non-i386 hardware, etc

My internal microphone is not working properly

Postby clovisbsantoss » 2021-03-03 13:57

I have a Lenovo Ideapad 330 notebook, I have been using Debian Buster for at least a year. However I am having problems with the internal microphone, it is not working in applications such as Skype, Zoom and Meet (Google). However, when I use the sound recorder, the microphone works perfectly. When using a headset, the headset microphone works in all the applications mentioned above. I searched the net for a solution, I found several that did not work, including some suggest removing Pulseaudio, but I saw several warnings in relation to this, so I didn't do it, given that various parts of the system depend on Pulseaudio.

Below are my settings:

lspci -nnk | grep -A2 Audio
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21)
Subsystem: Lenovo Sunrise Point-LP HD Audio [17aa:3837]
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel, snd_soc_skl

clovis@clovis:/etc/modprobe.d$ lspci -nnk | grep -A7 Audio
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21)
Subsystem: Lenovo Sunrise Point-LP HD Audio [17aa:3837]
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel, snd_soc_skl
00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-LP SMBus [8086:9d23] (rev 21)
Subsystem: Lenovo Sunrise Point-LP SMBus [17aa:386f]
Kernel driver in use: i801_smbus
Kernel modules: i2c_i801
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)

clovis@clovis:/etc/modprobe.d$ lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point LPC Controller/eSPI Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
02:00.0 Network controller: Intel Corporation Intel Dual Band Wireless-AC 3165 Plus Bluetooth (rev 99)


clovis@clovis:/etc/modprobe.d$ systemctl --user status pulseaudio
● pulseaudio.service - Sound Service
Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: enabled)
Active: active (running) since Tue 2021-03-02 21:51:45 -03; 13h ago
Main PID: 2350 (pulseaudio)
Memory: 11.8M
CGroup: /user.slice/user-1000.slice/user@1000.service/pulseaudio.service
└─2350 /usr/bin/pulseaudio --daemonize=no

clovis@clovis:/etc/modprobe.d$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: Generic Analog [Generic Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0

Another problem I noticed is that when I try to use the alsamixer or alsactl store as a super user (sudo) I get an error message as shown below:

clovis @ clovis: /etc/modprobe.d$ sudo alsamixer
[sudo] password for clovis:
No protocol specified
xcb_connection_has_error () returned true

I also did not find a solution in the forums I searched for.

From now on, I thank those who can help me.
clovisbsantoss
 
Posts: 3
Joined: 2020-09-22 13:02

Re: My internal microphone is not working properly

Postby Loci.Cantos » 2021-03-03 21:24

Sometimes the microphone selection can affect this; you may have a non-working microphone selected. For example, I have 2x motherboard microphones, one back panel, one front panel. I also have a webcam with a built-in microphone. I have to select the one I want to use.
Also, sometimes if I have muted a device but forgotten I've muted it, it will not work while muted (of course).
You may want to verify which microphone(s) the working application(s) are using, and see if you can select that microphone(s) for the non-working apps.

good luck,

lc
User avatar
Loci.Cantos
 
Posts: 49
Joined: 2018-08-03 15:39

Re: My internal microphone is not working properly

Postby clovisbsantoss » 2021-03-04 00:06

Thank you very much for your contribution. I had already really thought about it, but I have no idea how to do it. Would you have anything to indicate to me? For example, where can I find some tutorial to turn off the default option that appears in AlsaMixer, because I suppose that must be it. As the default option, the indicated device is Pulseaudio, I suppose it is a virtualization of the sound card.
clovisbsantoss
 
Posts: 3
Joined: 2020-09-22 13:02

Re: My internal microphone is not working properly

Postby FreewheelinFrank » 2021-03-04 06:59

Pulseaudio is a proxy for Alsamixer

The fact that one application works with the mic but others don't suggests it's an application issue. Google Meetings settings has a option to choose the microphone, which goes through Pulseaudio. Make sure the microphone you want to use is set as fallback in Pulseaudio.

Have a look in the settings for the application that does record from the microphone. Which microphone does it use? Does it use Pulseaudio or Alsamixer? Audacity can use both - that might be a way to test whether it's a Pulseaudio issue or an Alsamixer one.

Code: Select all
arerecord -l


Will tell you the Alsamixer names for the microphone(s): hw:0,1 or similar.

The space bar mutes inputs and outputs in Alsamixer, but as the microphone works in one application, it probably isn't muted.

For me in the past it was just a question of making the microphone fallback in pulseaudio. If that doesn't work, try the application settings and see if you need to select the microphone. That would be my best guess.
User avatar
FreewheelinFrank
 
Posts: 330
Joined: 2010-06-07 16:59


Return to Hardware

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable