[Solved] Intel Centrino Advanced-N 6235 and RF_KILL

Getting your soundcard to work, using Debian on non-i386 hardware, etc

[Solved] Intel Centrino Advanced-N 6235 and RF_KILL

Postby nbpf » 2014-02-13 17:48

Problem: every day, at about 23:57, the network connection becomes unavailable:

Code: Select all
Feb 11 23:57:11 fitpc3 kernel: [ 7149.120675] iwlwifi 0000:05:00.0: RF_KILL bit toggled to disable radio.
Feb 10 23:57:00 fitpc3 kernel: [12071.847421] iwlwifi 0000:05:00.0: RF_KILL bit toggled to disable radio.

Workaround: it appears (only one test passed by the time) that loading the iwlwifi module with the option bt_coex_active=N solves the problem. Unfortunately, this also degrades wireless bandwidth (as measured by iperf) by about 50% (2,4GHz) and 12% (5GHz).

Question: Any idea how to avoid the problem without sacrificing wireless performance ?

System information:

Code: Select all
root@fitpc3:/var/log# uname -a
Linux fitpc3 3.2.0-4-amd64 #1 SMP Debian 3.2.54-2 x86_64 GNU/Linux

Code: Select all
root@fitpc3:/var/log# lspci | grep -i network
05:00.0 Network controller: Intel Corporation Centrino Advanced-N 6235 (rev 24)

Code: Select all
root@fitpc3:~# rfkill list
0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no

Thanks,
nbpf
Last edited by nbpf on 2014-02-16 10:50, edited 1 time in total.
nbpf
 
Posts: 23
Joined: 2013-12-17 21:48

[Solved] Intel Centrino Advanced-N 6235 and RF_KILL

Postby nbpf » 2014-02-16 10:50

The output of "rfkill list" suggested that bluetooth was not working; on a similar machine running the same OS and with a Centrino nework card "rfkill list" yields:

Code: Select all
0: tpacpi_bluetooth_sw: Bluetooth
   Soft blocked: no
   Hard blocked: no
1: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
48: hci0: Bluetooth
   Soft blocked: no
   Hard blocked: no

"lsmod | grep btusb" confirmed that no bluetooth modules were loaded. At this point I realized that I had a "/etc/modprobe.d/tuning-blacklist.conf" with the single entry

Code: Select all
blacklist btusb

from a previous installation ! After removing the entry the bluetooth modules loaded fine and there have been no RF_KILL around 23:57 for the past two days (and transfer rates have further improved). The lesson learned is:

    * iwlwifi loaded with default options, btusb blacklisted => RF_KILL problem
    * iwlwifi loaded with bt_coex_active=N, btusb blacklisted => no RF_KILL problem but significant performance degradation
    * iwlwifi loaded with default options, btusb loaded => no RF_KILL problem, no performance degradation
nbpf
 
Posts: 23
Joined: 2013-12-17 21:48


Return to Hardware

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable