Can't get OpenGL to work on Radeon free drivers (Jessie)

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Can't get OpenGL to work on Radeon free drivers (Jessie)

Postby mashen » 2014-04-01 09:27

Hi. I'm using Debian Jessie. All the firmware packages are properly installed, and so are the radeon free driver packages.
However, Gallium falls back to llvmpipe, which from what I understand is a software rasterizer and not actually hardware rendering.
Everything works fine except some specific things like KDE's cube animation, which says it can't be enabled because it requires OpenGL.
How do I get Debian to run Gallium properly?

I attached some relevant info, if you need anything else to diagnose the issue, please ask.
glxinfo | grep -i opengl

Code: Select all
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 256 bits)
OpenGL version string: 2.1 Mesa 10.1.0
OpenGL shading language version string: 1.30
OpenGL extensions:


This is the output of /var/log/Xorg.0.log


If this is any help, I used to run the proprietary drivers

Any help would be greatly appreciated, as I'd much rather run the free AMD drivers over the proprietary ones.
mashen
 
Posts: 17
Joined: 2012-05-15 22:41

Re: Can't get OpenGL to work on Radeon free drivers (Jessie)

Postby gradinaruvasile » 2014-04-01 19:45

Hm. Your video card is
Code: Select all
Chipset: "VERDE" (ChipID = 0x682d)

According to this:
http://www.x.org/wiki/RadeonFeature/#index5h2
VERDE is a "Southern Islands" series chip.
The Southern Islands chips are supported only in the newer OSS radeon drivers. They use the "radeonsi" driver (which is the Xorg sub-driver for newer chips).
The "radeonsi" drivers can use hardware acceleration under X ONLY if they use the GLAMOR acceleration (as opposed to the previous chips that used EXA).
So, naturally you need a GLAMOR implementation. Which isnt part of the X server 1.15 (it will be in 1.16) but can be used only if you have an external library.
The problem is that Debian doesnt provide it ATM. Which isnt right since people with newer hardware that has working drivers are prevented from using them in any worthwile way.

Solution:
Compile glamor yourself:
Code: Select all
git clone git://anongit.freedesktop.org/xorg/driver/glamor
cd glamor
./autogen.sh
make
sudo make install

Here you will probably have to muck around with -dev packages to get it to compile. I honestly dont remember which are exactly needed but the configure (or autogen) script will tell you when something is missing and what its that exactly. And they are all in Debian AFAIK.

and then set up xorg.conf with:
Code: Select all
Section "Module"
   Load  "dri2"
   Load  "glamoregl"
EndSection
Section "Device"
    Identifier "radeon"
    Driver "radeon"
    Option "AccelMethod" "glamor"
EndSection

Restart.
If X fails to launch, save the log, rename xorg.conf and restart it.
Now i dont know how it will work with the current mesa in Jessie but worth a try. Also i dont know if the HW decoding VDPAU code is enabled in Debian so the stock packages might not provide hardware decoding for HD videos (which works really well if its compiled in BTW).

If you want to have it all, and its probably best for your hardware since the radeonsi driver is in full swing of development and the latest code (likely not in Debian) is very promising, you will have to compile:
- latest kernel
- latest mesa
- latest libdrm
- latest glamor
- latest xf86-ati

PS. Since you use a 64 bit system make sure you have BOTH 32 AND 64 bit mesa components installed because if you run a 32 bit application (STEAM and everything on it for example) it will work ONLY if you have corresponding 32 bit mesa libraries.
I personally have r600g hardware (previous generation) and i run GLAMOR on it and have all the above components compiled directly from the git code periodically (including 32 bit versions).
User avatar
gradinaruvasile
 
Posts: 935
Joined: 2010-01-31 22:03
Location: Cluj, Romania

Re: Can't get OpenGL to work on Radeon free drivers (Jessie)

Postby mashen » 2014-04-03 08:00

Wow, that was a very thorough reply, thanks so much. I'll try that and report back if I had any issues or if it was successful.
mashen
 
Posts: 17
Joined: 2012-05-15 22:41

Re: Can't get OpenGL to work on Radeon free drivers (Jessie)

Postby mashen » 2014-04-04 12:34

I think I got pretty far, but the output of
glxinfo | grep -i opengl
after rebooting is still
Code: Select all
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 256 bits)
OpenGL version string: 2.1 Mesa 10.1.0
OpenGL shading language version string: 1.30
OpenGL extensions:

And that is after setting a xorg.conf file with those options as well.

Honestly, it got to a point where .autogen.sh and make wouldn't tell me anything so I didn't know what to try next.
Here's the output of ./autogen.sh :

It seemed to run successfully, however
Code: Select all
make

I though I could ignore the warnings, so I tried
Code: Select all
sudo make install

It did create library files, but they don't seem to work.
mashen
 
Posts: 17
Joined: 2012-05-15 22:41

Re: Can't get OpenGL to work on Radeon free drivers (Jessie)

Postby gradinaruvasile » 2014-04-04 13:31

Damn. Wrong info...

Sorry.
Last edited by gradinaruvasile on 2014-04-04 15:32, edited 1 time in total.
User avatar
gradinaruvasile
 
Posts: 935
Joined: 2010-01-31 22:03
Location: Cluj, Romania

Re: Can't get OpenGL to work on Radeon free drivers (Jessie)

Postby mashen » 2014-04-04 14:05

I got the following error messages:
First script: http://pastebin.com/iJRRiS45
Second script: http://pastebin.com/hKpXRpsp
mashen
 
Posts: 17
Joined: 2012-05-15 22:41

Re: Can't get OpenGL to work on Radeon free drivers (Jessie)

Postby gradinaruvasile » 2014-04-04 15:35

Dang. I poosted something wrong there (mesa build options instead of glamor...).
Ok, so i build gramor like this:

Code: Select all
make clean
./autogen.sh --prefix=/usr --enable-glx-tls --enable-xv
make


And build the .deb (instead of make install):

Code: Select all
fakeroot checkinstall --install=no --pkgarch=amd64 --backup=no --pkgname=glamor --pkgversion=5.1-`git describe` --default
User avatar
gradinaruvasile
 
Posts: 935
Joined: 2010-01-31 22:03
Location: Cluj, Romania

Re: Can't get OpenGL to work on Radeon free drivers (Jessie)

Postby mashen » 2014-04-04 16:43

That's OK! I compiled with the new options now.
Unfortunately, I keep getting the same output of glxinfo | grep -i opengl after rebooting:
Code: Select all
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 256 bits)
OpenGL version string: 2.1 Mesa 10.1.0
OpenGL shading language version string: 1.30
OpenGL extensions:

Here's the output of the compiling commands if they're any help:

Code: Select all
$ ./autogen.sh --prefix=/usr --enable-glx-tls --enable-xv
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force -I m4
autoreconf: configure.ac: tracing
autoreconf: running: libtoolize --copy --force
libtoolize: putting auxiliary files in `.'.
libtoolize: copying file `./ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIR, `m4'.
libtoolize: copying file `m4/libtool.m4'
libtoolize: copying file `m4/ltoptions.m4'
libtoolize: copying file `m4/ltsugar.m4'
libtoolize: copying file `m4/ltversion.m4'
libtoolize: copying file `m4/lt~obsolete.m4'
autoreconf: running: /usr/bin/autoconf --force
autoreconf: running: /usr/bin/autoheader --force
autoreconf: running: automake --add-missing --copy --force-missing
autoreconf: Leaving directory `.'
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether to enable maintainer-specific portions of Makefiles... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking how to print strings... printf
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out                                   
checking for suffix of executables...                                                       
checking whether we are cross compiling... no                                               
checking for suffix of object files... o                                                     
checking whether we are using the GNU C compiler... yes                                     
checking whether gcc accepts -g... yes                                                       
checking for gcc option to accept ISO C89... none needed                                     
checking whether gcc understands -c and -o together... yes                                   
checking dependency style of gcc... gcc3                                                     
checking for a sed that does not truncate output... /bin/sed                                 
checking for grep that handles long lines and -e... /bin/grep                               
checking for egrep... /bin/grep -E                                                           
checking for fgrep... /bin/grep -F                                                                                                                                                           
checking for ld used by gcc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking how to convert x86_64-unknown-linux-gnu file names to x86_64-unknown-linux-gnu format... func_convert_file_noop
checking how to convert x86_64-unknown-linux-gnu file names to toolchain format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for ar... ar
checking for archiver @FILE support... @
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for sysroot... no
checking for mt... mt
checking if mt is a manifest tool... no
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking for gcc option to accept ISO C99... -std=gnu99
checking whether __clang__ is declared... no
checking whether __INTEL_COMPILER is declared... no
checking whether __SUNPRO_C is declared... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking if gcc -std=gnu99 supports -Werror=unknown-warning-option... no
checking if gcc -std=gnu99 supports -Werror=unused-command-line-argument... no
checking if gcc -std=gnu99 supports -Wall... yes
checking if gcc -std=gnu99 supports -Wpointer-arith... yes
checking if gcc -std=gnu99 supports -Wmissing-declarations... yes
checking if gcc -std=gnu99 supports -Wformat=2... yes
checking if gcc -std=gnu99 supports -Wstrict-prototypes... yes
checking if gcc -std=gnu99 supports -Wmissing-prototypes... yes
checking if gcc -std=gnu99 supports -Wnested-externs... yes
checking if gcc -std=gnu99 supports -Wbad-function-cast... yes
checking if gcc -std=gnu99 supports -Wold-style-definition... yes
checking if gcc -std=gnu99 supports -Wdeclaration-after-statement... yes
checking if gcc -std=gnu99 supports -Wunused... yes
checking if gcc -std=gnu99 supports -Wuninitialized... yes
checking if gcc -std=gnu99 supports -Wshadow... yes
checking if gcc -std=gnu99 supports -Wmissing-noreturn... yes
checking if gcc -std=gnu99 supports -Wmissing-format-attribute... yes
checking if gcc -std=gnu99 supports -Wredundant-decls... yes
checking if gcc -std=gnu99 supports -Werror=implicit... yes
checking if gcc -std=gnu99 supports -Werror=nonnull... yes
checking if gcc -std=gnu99 supports -Werror=init-self... yes
checking if gcc -std=gnu99 supports -Werror=main... yes
checking if gcc -std=gnu99 supports -Werror=missing-braces... yes
checking if gcc -std=gnu99 supports -Werror=sequence-point... yes
checking if gcc -std=gnu99 supports -Werror=return-type... yes
checking if gcc -std=gnu99 supports -Werror=trigraphs... yes
checking if gcc -std=gnu99 supports -Werror=array-bounds... yes
checking if gcc -std=gnu99 supports -Werror=write-strings... yes
checking if gcc -std=gnu99 supports -Werror=address... yes
checking if gcc -std=gnu99 supports -Werror=int-to-pointer-cast... yes
checking if gcc -std=gnu99 supports -Werror=pointer-to-int-cast... yes
checking if gcc -std=gnu99 supports -pedantic... yes
checking if gcc -std=gnu99 supports -Werror... yes
checking if gcc -std=gnu99 supports -Werror=attributes... yes
checking whether make supports nested variables... (cached) yes
checking for pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for XORG... yes
checking for DRI2... yes
checking whether to include GLAMOR_GLES2 support... no
checking whether to include GLAMOR Xv support... yes
checking whether to enable DEBUG... no
checking for GL... yes
checking for LIBDRM... yes
checking for EGL... yes
checking for GBM... yes
checking for GBMv9... yes
checking Enable Glamor Dri3 helpers... yes
checking for thread local storage (TLS) support... __thread
checking for tls_model attribute support... yes
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating glamor-egl.pc
config.status: creating glamor.pc
config.status: creating src/Makefile
config.status: creating conf/Makefile
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing depfiles commands
config.status: executing libtool commands

Code: Select all
$ fakeroot checkinstall --install=no --pkgarch=amd64 --backup=no --pkgname=glamor --pkgversion=5.1-`git describe` --default

checkinstall 1.6.2, Copyright 2009 Felipe Eduardo Sanchez Diaz Duran
           This software is released under the GNU GPL.



*****************************************
**** Debian package creation selected ***
*****************************************

This package will be built according to these values:

0 -  Maintainer: [ machine@Precision ]
1 -  Summary: [ Package created with checkinstall 1.6.2 ]
2 -  Name:    [ glamor ]
3 -  Version: [ 5.1-glamor-egl-0.6.0-41-ga4fbc77 ]
4 -  Release: [ 1 ]
5 -  License: [ GPL ]
6 -  Group:   [ checkinstall ]
7 -  Architecture: [ amd64 ]
8 -  Source location: [ glamor ]
9 -  Alternate source location: [  ]
10 - Requires: [  ]
11 - Provides: [ glamor ]
12 - Conflicts: [  ]
13 - Replaces: [  ]

Enter a number to change any of them or press ENTER to continue:

Installing with make install...

========================= Installation results ===========================
Making install in src
make[1]: Entering directory `/home/machine/glamor/src'
make[2]: Entering directory `/home/machine/glamor/src'
 /bin/mkdir -p '/usr/lib'
 /bin/bash ../libtool   --mode=install /usr/bin/install -c   libglamor.la '/usr/lib'
libtool: install: /usr/bin/install -c .libs/libglamor.so.0.0.0 /usr/lib/libglamor.so.0.0.0
libtool: install: (cd /usr/lib && { ln -s -f libglamor.so.0.0.0 libglamor.so.0 || { rm -f libglamor.so.0 && ln -s libglamor.so.0.0.0 libglamor.so.0; }; })
libtool: install: (cd /usr/lib && { ln -s -f libglamor.so.0.0.0 libglamor.so || { rm -f libglamor.so && ln -s libglamor.so.0.0.0 libglamor.so; }; })
libtool: install: /usr/bin/install -c .libs/libglamor.lai /usr/lib/libglamor.la
libtool: finish: PATH="/home/machine/.rvm/gems/ruby-2.1.0/bin:/home/machine/.rvm/gems/ruby-2.1.0@global/bin:/home/machine/.rvm/rubies/ruby-2.1.0/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/home/machine/.rvm/bin:/home/machine/.rvm/bin:/sbin" ldconfig -n /usr/lib
----------------------------------------------------------------------
Libraries have been installed in:
   /usr/lib

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,-rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
 /bin/mkdir -p '/usr/lib/xorg/modules'
 /bin/bash ../libtool   --mode=install /usr/bin/install -c   libglamoregl.la '/usr/lib/xorg/modules'
libtool: install: warning: relinking `libglamoregl.la'
libtool: install: (cd /home/machine/glamor/src; /bin/bash /home/machine/glamor/libtool  --silent --tag CC --mode=relink gcc -std=gnu99 -Wall -Wpointer-arith -Wmissing-declarations -Wformat=2 -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Wbad-function-cast -Wold-style-definition -Wdeclaration-after-statement -Wunused -Wuninitialized -Wshadow -Wmissing-noreturn -Wmissing-format-attribute -Wredundant-decls -Werror=implicit -Werror=nonnull -Werror=init-self -Werror=main -Werror=missing-braces -Werror=sequence-point -Werror=return-type -Werror=trigraphs -Werror=array-bounds -Werror=write-strings -Werror=address -Werror=int-to-pointer-cast -Werror=pointer-to-int-cast -fno-strict-aliasing -fvisibility=hidden -I/usr/include/pixman-1 -I/usr/include/libdrm -I/usr/include/xorg -I/usr/include/X11/dri -I/usr/include/libdrm -DGLX_USE_TLS -DPTHREADS -I/usr/include/libdrm -I/usr/include/libdrm -g -O2 -avoid-version -module -o libglamoregl.la -rpath /usr/lib/xorg/modules libglamoregl_la-glamor_eglmodule.lo libglamoregl_la-glamor_egl.lo -lEGL -lpthread -lgbm libglamor.la )
libtool: install: /usr/bin/install -c .libs/libglamoregl.soT /usr/lib/xorg/modules/libglamoregl.so
libtool: install: /usr/bin/install -c .libs/libglamoregl.lai /usr/lib/xorg/modules/libglamoregl.la
libtool: finish: PATH="/home/machine/.rvm/gems/ruby-2.1.0/bin:/home/machine/.rvm/gems/ruby-2.1.0@global/bin:/home/machine/.rvm/rubies/ruby-2.1.0/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/home/machine/.rvm/bin:/home/machine/.rvm/bin:/sbin" ldconfig -n /usr/lib/xorg/modules
----------------------------------------------------------------------
Libraries have been installed in:
   /usr/lib/xorg/modules

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,-rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
 /bin/mkdir -p '/usr/include/xorg'
 /usr/bin/install -c -m 644 glamor.h '/usr/include/xorg'
make[2]: Leaving directory `/home/machine/glamor/src'
make[1]: Leaving directory `/home/machine/glamor/src'
Making install in conf
make[1]: Entering directory `/home/machine/glamor/conf'
make[2]: Entering directory `/home/machine/glamor/conf'
make[2]: Nothing to be done for `install-exec-am'.
 /bin/mkdir -p '/usr/share/X11/xorg.conf.d'
 /usr/bin/install -c -m 644 glamor.conf '/usr/share/X11/xorg.conf.d'
make[2]: Leaving directory `/home/machine/glamor/conf'
make[1]: Leaving directory `/home/machine/glamor/conf'
make[1]: Entering directory `/home/machine/glamor'
make[2]: Entering directory `/home/machine/glamor'
make[2]: Nothing to be done for `install-exec-am'.
 /bin/mkdir -p '/usr/lib/pkgconfig'
 /usr/bin/install -c -m 644 glamor-egl.pc glamor.pc '/usr/lib/pkgconfig'
make[2]: Leaving directory `/home/machine/glamor'
make[1]: Leaving directory `/home/machine/glamor'

======================== Installation successful ==========================

Copying documentation directory...
./
./COPYING
./README

Copying files to the temporary directory...OK

Stripping ELF binaries and libraries...OK

Compressing man pages...OK

Building file list...OK

Building Debian package...OK

NOTE: The package will not be installed

Erasing temporary files...OK

Deleting temp dir...OK


**********************************************************************

 Done. The new package has been saved to

 /home/machine/glamor/glamor_5.1-glamor-egl-0.6.0-41-ga4fbc77-1_amd64.deb
 You can install it in your system anytime using:

      dpkg -i glamor_5.1-glamor-egl-0.6.0-41-ga4fbc77-1_amd64.deb

**********************************************************************

mashen
 
Posts: 17
Joined: 2012-05-15 22:41

Re: Can't get OpenGL to work on Radeon free drivers (Jessie)

Postby gradinaruvasile » 2014-04-04 16:48

Did you restart after compiling and installing glamor?

What gives:
Code: Select all
ldd /usr/bin/glxgears

?
And post the xorg log too.
User avatar
gradinaruvasile
 
Posts: 935
Joined: 2010-01-31 22:03
Location: Cluj, Romania

Re: Can't get OpenGL to work on Radeon free drivers (Jessie)

Postby mashen » 2014-04-04 17:07

Yep, I even restarted again just in case.
The output of that command is:
Code: Select all
$ ldd /usr/bin/glxgears
        linux-vdso.so.1 (0x00007fffb6318000)
        libGLEW.so.1.10 => /usr/lib/x86_64-linux-gnu/libGLEW.so.1.10 (0x00007fdbfa830000)
        libGLU.so.1 => /usr/lib/x86_64-linux-gnu/libGLU.so.1 (0x00007fdbfa5c2000)
        libGL.so.1 => /usr/lib/x86_64-linux-gnu/libGL.so.1 (0x00007fdbfa35c000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fdbfa059000)
        libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007fdbf9d1e000)
        libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007fdbf9b0b000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fdbf9762000)
        libXmu.so.6 => /usr/lib/x86_64-linux-gnu/libXmu.so.6 (0x00007fdbf9548000)
        libXi.so.6 => /usr/lib/x86_64-linux-gnu/libXi.so.6 (0x00007fdbf9337000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fdbf9033000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fdbf8e1d000)
        libglapi.so.0 => /usr/lib/x86_64-linux-gnu/libglapi.so.0 (0x00007fdbf8bf5000)
        libXdamage.so.1 => /usr/lib/x86_64-linux-gnu/libXdamage.so.1 (0x00007fdbf89f2000)
        libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007fdbf87ec000)
        libX11-xcb.so.1 => /usr/lib/x86_64-linux-gnu/libX11-xcb.so.1 (0x00007fdbf85e9000)
        libxcb-glx.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-glx.so.0 (0x00007fdbf83d2000)
        libxcb-dri2.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri2.so.0 (0x00007fdbf81cd000)
        libxcb-dri3.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri3.so.0 (0x00007fdbf7fc9000)
        libxcb-present.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-present.so.0 (0x00007fdbf7dc6000)
        libxcb-sync.so.1 => /usr/lib/x86_64-linux-gnu/libxcb-sync.so.1 (0x00007fdbf7bc0000)
        libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007fdbf79a0000)
        libxshmfence.so.1 => /usr/lib/x86_64-linux-gnu/libxshmfence.so.1 (0x00007fdbf779e000)
        libXxf86vm.so.1 => /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1 (0x00007fdbf7598000)
        libdrm.so.2 => /usr/lib/x86_64-linux-gnu/libdrm.so.2 (0x00007fdbf738b000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fdbf716e000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fdbf6f6a000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fdbfaadf000)
        libXt.so.6 => /usr/lib/x86_64-linux-gnu/libXt.so.6 (0x00007fdbf6d03000)
        libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007fdbf6aff000)
        libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007fdbf68f9000)
        libSM.so.6 => /usr/lib/x86_64-linux-gnu/libSM.so.6 (0x00007fdbf66f2000)
        libICE.so.6 => /usr/lib/x86_64-linux-gnu/libICE.so.6 (0x00007fdbf64d7000)
        libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007fdbf62d1000)


The contents of Xorg.0.log are here: http://pastebin.com/Hkkxebh7
mashen
 
Posts: 17
Joined: 2012-05-15 22:41

Re: Can't get OpenGL to work on Radeon free drivers (Jessie)

Postby gradinaruvasile » 2014-04-04 17:26

Hm. You dont have this in the log:

Code: Select all
(**) RADEON(0): Option "AccelMethod" "glamor"


Make sure you have :
Code: Select all
Section "Device"
    Identifier "radeon"
    Driver "radeon"
    Option "AccelMethod" "glamor"
EndSection

in /etc/X11/xorg.conf and
Code: Select all
Section "Module"
   Load  "dri2"
   Load  "glamoregl"
EndSection


in /usr/share/X11/xorg.conf.d/glamor.conf
Although the whole stuff should work in xorg.conf too.
User avatar
gradinaruvasile
 
Posts: 935
Joined: 2010-01-31 22:03
Location: Cluj, Romania

Re: Can't get OpenGL to work on Radeon free drivers (Jessie)

Postby mashen » 2014-04-04 17:46

Yeah, I noticed some funny things in the log. For example, glamor seems to be loaded
Code: Select all
[    23.985] (II) "glx" will be loaded by default.
[    23.985] (II) LoadModule: "dri2"
[    23.985] (II) Module "dri2" already built-in
[    23.985] (II) LoadModule: "glamoregl"
[    23.995] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[    24.123] (II) Module glamoregl: vendor="X.Org Foundation"
[    24.123]    compiled for 1.15.0, module version = 0.6.0
[    24.123]    ABI class: X.Org ANSI C Emulation, version 0.4
[    24.123] (II) LoadModule: "glx"
[    24.123] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    24.135] (II) Module glx: vendor="X.Org Foundation"
[    24.135]    compiled for 1.15.0, module version = 1.0.0
[    24.135]    ABI class: X.Org Server Extension, version 8.0
[    24.135] (==) AIGLX enabled
[    24.135] Loading extension GLX

Which would make it seem as if it'd work. However, after that it says
Code: Select all
[    24.375] (WW) RADEON(0): Direct rendering disabled
[    24.375] (II) RADEON(0): Acceleration disabled

Could it be because of my version of mesa? I'm using the latest mesa version from Jessie, which is 10.1.0-4
Anyway, both /usr/share/X11/xorg.conf.d/glamor.conf and /etc/X11/xorg.conf were actually already there, and with the right content in.
Code: Select all
$ cat /usr/share/X11/xorg.conf.d/glamor.conf
Section "Module"
   Load  "dri2"
   Load  "glamoregl"
EndSection


Code: Select all
$ cat /etc/X11/xorg.conf
Section "Module"
   Load  "dri2"
   Load  "glamoregl"
EndSection
Section "Device"
    Identifier "radeon"
    Driver "radeon"
    Option "AccelMethod" "glamor"
EndSection
mashen
 
Posts: 17
Joined: 2012-05-15 22:41

Re: Can't get OpenGL to work on Radeon free drivers (Jessie)

Postby gradinaruvasile » 2014-04-05 07:37

Could it be because of my version of mesa? I'm using the latest mesa version from Jessie, which is 10.1.0-4

Not the version itself, but how it is compiled.
Make sure you have libegl1-mesa, libegl1-mesa-drivers installed too.

Also check for the radeonsi lib
Code: Select all
sudo updatedb
locate /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so

If its there, you have radeonsi support for mesa. But it might have some other config options not suitable for glamor.
And besides, there is the xorg video driver and that has a option to disable glamor for good in it (--disable-glamor). I dont know how it is compiled by default for Debian.

Anyway, for starters see if you install libegl1-mesa, libegl1-mesa-drivers and remove the "module" section from xorg.conf only (leave it in the glamor.conf), and leave the rest in xorg.conf and restart.
User avatar
gradinaruvasile
 
Posts: 935
Joined: 2010-01-31 22:03
Location: Cluj, Romania

Re: Can't get OpenGL to work on Radeon free drivers (Jessie)

Postby mashen » 2014-04-05 17:46

Sure!
Both libegl1-mesa and libegl1-mesa-drivers are currently installed.
Code: Select all
# aptitude show libegl1-mesa
Package: libegl1-mesa                   
State: installed
Automatically installed: yes
Multi-Arch: same
Version: 10.1.0-4

Code: Select all
# aptitude show libegl1-mesa-drivers
Package: libegl1-mesa-drivers           
State: installed
Automatically installed: yes
Multi-Arch: same
Version: 10.1.0-4

radeonsi_dri.so is there
Code: Select all
# locate /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
/usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so

xorg.conf now only has the "Device" section:
Code: Select all
# cat /etc/X11/xorg.conf
Section "Device"
    Identifier "radeon"
    Driver "radeon"
    Option "AccelMethod" "glamor"
EndSection

However, upon reboot, I get the same result:
Code: Select all
$ glxinfo | grep -i opengl
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 256 bits)
OpenGL version string: 2.1 Mesa 10.1.0
OpenGL shading language version string: 1.30
OpenGL extensions:

Here's my Xorg.0.log: http://pastebin.com/AjhNwEMw
mashen
 
Posts: 17
Joined: 2012-05-15 22:41

Re: Can't get OpenGL to work on Radeon free drivers (Jessie)

Postby gradinaruvasile » 2014-04-05 18:50

I tracked down one of my older post about this:

http://www.phoronix.com/forums/showthre ... post359760

I dont know what exactly made it work eventually, but seems to have involved deleting some libraries in that xorg folder.
But, as i posted there, i have everything compiled from git. In this case i would sugges you do the same since the system mesa/xorg driver might not work with glamor.

Do you have libgles2-mesa installed?
User avatar
gradinaruvasile
 
Posts: 935
Joined: 2010-01-31 22:03
Location: Cluj, Romania

Next

Return to Hardware

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable