[SOLVED] RTL8723BE & Debian 8 | lwfinger rtlwifi_new

Getting your soundcard to work, using Debian on non-i386 hardware, etc

[SOLVED] RTL8723BE & Debian 8 | lwfinger rtlwifi_new

Postby mylittlepavilion » 2015-05-25 10:31

Hello from germany,

first, sorry for my bad english. I try my best. I have a HP Pavilion 15-p150ng Notebook with a Realtek 8723BE Wifi modul. If had googled so many times, an every board say: use lwfinger rtlwifi new from github. But this fix my problem not good, my lost connection every 5 - 10 minutes, and then a reconnect helps to have internet. Does anyone now the problem and can help me?

Many thanks!
Last edited by mylittlepavilion on 2015-05-27 21:42, edited 1 time in total.
mylittlepavilion
 
Posts: 11
Joined: 2015-05-25 10:25

Re: RTL8723BE & Debian 8 | lwfinger rtlwifi_new

Postby squeeze » 2015-05-25 12:43

ALWAYS do a forum search and try things before asking again! GIYF

mylittlepavilion wrote:Hello from germany,

first, sorry for my bad english.


There is a german forum available too ;-)

greets from AT
“Have you tried turning it off and on again?”
User avatar
squeeze
 
Posts: 284
Joined: 2010-06-14 23:16
Location: thimbleweedpark

Re: RTL8723BE & Debian 8 | lwfinger rtlwifi_new

Postby v&n » 2015-05-25 12:51

If you really searched, you should have already found this, but in case you didn't, here's a fix that works for most people -

In a terminal, please run this command (you may copy-paste) -
Code: Select all
sudo tee /etc/modprobe.d/rtl8723be.conf <<< "options rtl8723be ips=N fwlps=N"

Reboot and see if the connection is any better.

If the problem persists, please post the outputs of -
Code: Select all
sudo iwconfig
grep -R [[:graph:]] /sys/module/rtl8723be/parameters
dmesg | grep rtl87


PS:
Your English is good enough to communicate. And I'm sure your German must be much better than mine (which is 'zero'). :P

PPS: Beaten by squeeze, but lets post that solution here also, let us not let UF enjoy all the fame.. ;)
v&n
 
Posts: 555
Joined: 2015-02-04 02:57

Re: RTL8723BE & Debian 8 | lwfinger rtlwifi_new

Postby squeeze » 2015-05-25 13:09

v&n wrote:If you really searched, you should have already found this, but in case you didn't, here's a fix that works for most people -


People should learn to help themselves imo, and they won't in the future if everything is prepared for them on a silver tablet.
“Have you tried turning it off and on again?”
User avatar
squeeze
 
Posts: 284
Joined: 2010-06-14 23:16
Location: thimbleweedpark

Re: RTL8723BE & Debian 8 | lwfinger rtlwifi_new

Postby mylittlepavilion » 2015-05-25 13:40

Hello again,

thanks for all your replys. The option "deactivate the sleep mode" dont work. :(

iwconfig
Code: Select all
eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"Datenhafen" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: 34:81:C4:DB:88:C1   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-32 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:440   Missed beacon:0

lo        no wireless extensions.


grep -R [[:graph:]] /sys/module/rtl8723be/parameters
Code: Select all
/sys/module/rtl8723be/parameters/ips:Y
/sys/module/rtl8723be/parameters/msi:N
/sys/module/rtl8723be/parameters/debug:0
/sys/module/rtl8723be/parameters/fwlps:N
/sys/module/rtl8723be/parameters/swenc:N
/sys/module/rtl8723be/parameters/swlps:N
/sys/module/rtl8723be/parameters/disable_watchdog:N


dmesg | grep rtl87
Code: Select all
[   15.362558] Using firmware rtlwifi/rtl8723befw.bin
[   15.422547] rtl8723be 0000:02:00.0: firmware: direct-loading firmware rtlwifi/rtl8723befw.bin
mylittlepavilion
 
Posts: 11
Joined: 2015-05-25 10:25

Re: RTL8723BE & Debian 8 | lwfinger rtlwifi_new

Postby v&n » 2015-05-25 14:07

squeeze wrote:
v&n wrote:If you really searched, you should have already found this, but in case you didn't, here's a fix that works for most people -


People should learn to help themselves imo, and they won't in the future if everything is prepared for them on a silver tablet.

Yes, people should. But as evident from millions of years of history, people don't always do what they should.

We all know most users just want a working system and are not interested in learning. Even among those who are tinkerers, a vast majority is of those who have priorities other than learning all the time, and if forced to learn, they'll just give up and move on. Asking for help on forums is, I believe, the 'last option' for those who are really interested in learning. And sometimes even these 'real interested ones' have other priorities and don't have mood or time to learn.

As for me, I am among those who spend time on such forums to just gather and share knowledge. We share what we know, and leave the choice to blindly copy it or learn from it to the users. In my (not very little) experience (on net or in real life profession), offering solutions the lengthy way only makes people lose interest.

I believe simple (non-curious) users are no less important for FOSS than contributors/troubleshooters like us or even developers. They tell us what can or should be made better, and they make the market (or userbase) bigger which contributes in other ways.

In this particular case, the mention of 'lwfinger' is good enough for me to believe the OP tried something before posting. One incorrect solution/process can be more than enough for a person to get desperate and ask for help.

Just 'My' personal opinion. :)
v&n
 
Posts: 555
Joined: 2015-02-04 02:57

Re: RTL8723BE & Debian 8 | lwfinger rtlwifi_new

Postby v&n » 2015-05-25 14:13

mylittlepavilion wrote:... The option "deactivate the sleep mode" dont work. :(

Sorry, couldn't understand what you mean by "deactivate the sleep mode". Could you explain it please?

And "ips" is still set to "Y", not "N" that I suggested -
mylittlepavilion wrote:
Code: Select all
/sys/module/rtl8723be/parameters/ips:Y

Which suggests that the conf file was probably not created, or is not as recommended. If you ran the command I suggested (or the one you found in the ubuntuforums post), please show us the contents of the 'rtl8723be.conf file -
Code: Select all
grep -R rtl87 /etc/modprobe.d/
v&n
 
Posts: 555
Joined: 2015-02-04 02:57

Re: RTL8723BE & Debian 8 | lwfinger rtlwifi_new

Postby mylittlepavilion » 2015-05-25 14:20

Its a very sadly problem. First, my Wlan wórks for 10 Minutes, then i have no connection. But the "icon" show connectet. Then i disconnect, and connect again, and internet works again for few minutes.


grep -R rtl87 /etc/modprobe.d/
Code: Select all
/etc/modprobe.d/rtl8723be.conf:options rtl8723be ips=N fwlps=N


Hope to get help. :(
mylittlepavilion
 
Posts: 11
Joined: 2015-05-25 10:25

Re: RTL8723BE & Debian 8 | lwfinger rtlwifi_new

Postby v&n » 2015-05-25 14:42

Interesting! I'm afraid I may need a detailed diagnostics report of your wifi setup.

---------------------------------
[DISCLAIMER : Running unknown scripts from not-trustworthy-sources is never recommended for security reasons. Do so at your own risk!]

Please download this script onto your Desktop (right-click the link > save as) : https://dl.dropbox.com/s/qjc87hzk1z5x6z ... ess_script
This script tries to collect all the relevant info about a wireless setup, puts the collected info in a report file, filtering/masking all the potentially sensitive info (e.g. wifi passkeys, MAC IDs etc.).

Once the script is on your Desktop, run it with -
Code: Select all
cd Desktop
su
bash wireless_script
exit

(browsers like chromium can automatically append ".txt" in the downloaded file's name. If that happens, use "wireless_script.txt" in the command above)

It will create a file named "wireless-info.txt" on your Desktop (or wherever you ran the script from). Upload this file's contents to pastebin.com and post here the pastebin link.

PS:
If you can stay connected to internet for 2-3 minutes, you can also run this single command in a terminal to download and run the script in one go -
Code: Select all
wget -N -t 5 -T 10 https://dl.dropbox.com/s/qjc87hzk1z5x6z0/wireless_script && chmod +x wireless_script && sudo ./wireless_script

(if 'sudo' is not installed, you may wish to change to super user mode before running the above code without sudo. Certain commands in the script do need root privilege to work correctly in Debian)
Last edited by v&n on 2015-08-04 13:44, edited 3 times in total.
v&n
 
Posts: 555
Joined: 2015-02-04 02:57

Re: RTL8723BE & Debian 8 | lwfinger rtlwifi_new

Postby mylittlepavilion » 2015-05-25 14:49

Thanks for all your help. Here is the output:

Code: Select all
   ======== Wireless-Info START ========

System-Info ~~~~~~~~~~~~~~~~~~~~~~~~

hp-pavilion 3.16.0-4-amd64 x86_64,  Debian GNU/Linux 8.0 (jessie), jessie

CPU    : AMD A8-6410 APU with AMD Radeon R5 Graphics
Memory : 6865 MB
Uptime : 16:47:55 up 36 min,  3 users,  load average: 0,10, 0,30, 0,30


lspci ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
   Subsystem: Hewlett-Packard Company Device [103c:2231]
   Kernel driver in use: rtl8723be
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 07)
   Subsystem: Hewlett-Packard Company Device [103c:2269]
   Kernel driver in use: r8169


lsusb ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Bus 002 Device 003: ID 04f2:b45e Chicony Electronics Co., Ltd
Bus 002 Device 002: ID 0438:7900 Advanced Micro Devices, Inc.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0bda:b001 Realtek Semiconductor Corp.
Bus 001 Device 003: ID 24ae:2000 
Bus 001 Device 002: ID 0438:7900 Advanced Micro Devices, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


PCMCIA Card Info ~~~~~~~~~~~~~~~~~~~



iwconfig ~~~~~~~~~~~~~~~~~~~~~~~~~~~

wlan0     IEEE 802.11bgn  ESSID:"Datenhafen" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: <MAC C-01 Datenhafen>   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-32 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:89   Missed beacon:0



rfkill ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~




lsmod ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

rtl8723be             133167  0
btcoexist             181045  1 rtl8723be
rtl_pci                38276  1 rtl8723be
rtlwifi               106197  3 btcoexist,rtl_pci,rtl8723be
hp_wmi                 13330  0
sparse_keymap          12818  1 hp_wmi
mac80211              474218  3 rtl_pci,rtlwifi,rtl8723be
cfg80211              405538  2 mac80211,rtlwifi
rfkill                 18867  5 cfg80211,hp_wmi,bluetooth
wmi                    17339  1 hp_wmi


module parameters ~~~~~~~~~~~~~~~~~~

cfg80211      (2): cfg80211_disable_40mhz_24ghz=N | ieee80211_regdom=00
mac80211      (5): beacon_loss_count=7 | ieee80211_default_rc_algo=minstrel_ht | max_nullfunc_tries=2 | max_probe_tries=5 | probe_wait_ms=500
rfkill        (1): default_state=1
rtl8723be     (7): debug=0 | disable_watchdog=N | fwlps=N | ips=N | msi=N | swenc=N | swlps=N
wmi           (2): debug_dump_wdg=N | debug_event=N


nm-tool ~~~~~~~~~~~~~~~~~~~~~~~~~~~~


================o======o========o========o=========o===========o==============o===========
 Interface & ID | Type | Driver | State  | Default | Speed     | Support      | HW Addr   
================o======o========o========o=========o===========o==============o===========
                |      |        |        |         |           |              |           
----------------+------+--------+--------+---------+-----------+--------------+-----------


NetworkManager.state ~~~~~~~~~~~~~~~
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true


NetworkManager.conf ~~~~~~~~~~~~~~~~

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false


NM WiFi Profiles ~~~~~~~~~~~~~~~~~~~
 


interfaces ~~~~~~~~~~~~~~~~~~~~~~~~~

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

resolv.conf ~~~~~~~~~~~~~~~~~~~~~~~~

search fritz.box
nameserver 192.168.178.1


Routes & Ping ~~~~~~~~~~~~~~~~~~~~~~

Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.178.1   0.0.0.0         UG    1024   0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0
192.168.178.0   0.0.0.0         255.255.255.0   U     0      0        0 wlan0

--- 192.168.178.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 2.412/2.462/2.513/0.070 ms

--- 192.168.178.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 2.588/2.946/3.305/0.362 ms


iw reg get ~~~~~~~~~~~~~~~~~~~~~~~~~

(Region : "de_DE.UTF-8")
country DE: DFS-ETSI
   (2400 - 2483 @ 40), (N/A, 20), (N/A)
   (5150 - 5250 @ 80), (N/A, 20), (N/A), NO-OUTDOOR
   (5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS
   (5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
   (57000 - 66000 @ 2160), (N/A, 40), (N/A)


iwlist chan ~~~~~~~~~~~~~~~~~~~~~~~~

wlan0     13 channels in total; available frequencies :
          Channel 01 (2.412 GHz) - 13 (2.472 GHz)

          Current Frequency:2.412 GHz (Channel 1)


iwlist scan ~~~~~~~~~~~~~~~~~~~~~~~~

wlan0     Scan completed :
          Cell 01 - Address: <MAC C-01 Datenhafen>
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=70/70  Signal level=-30 dBm 
                    Encryption key:on
                    ESSID:"Datenhafen"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=00000051f9468021
                    Extra: Last beacon: 8ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
          Cell 02 - Address: <MAC C-02 EasyBox-BB7027>
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=44/70  Signal level=-66 dBm 
                    Encryption key:on
                    ESSID:"EasyBox-BB7027"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=00000177206112b3
                    Extra: Last beacon: 184ms ago
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                       Preauthentication Supported
          Cell 03 - Address: <MAC C-03 WLAN-NXMXD4>
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=40/70  Signal level=-70 dBm 
                    Encryption key:on
                    ESSID:"WLAN-NXMXD4"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000072a1f5c780a
                    Extra: Last beacon: 8ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
          Cell 04 - Address: <MAC C-04 Sonnenblume>
                    Channel:9
                    Frequency:2.452 GHz (Channel 9)
                    Quality=42/70  Signal level=-68 dBm 
                    Encryption key:on
                    ESSID:"Sonnenblume"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000005186e9d1e0b
                    Extra: Last beacon: 8ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                       Preauthentication Supported
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK


blacklist ~~~~~~~~~~~~~~~~~~~~~~~~~~

[/etc/modprobe.d/amd64-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/intel-microcode-blacklist.conf]
blacklist microcode


modinfo ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[rtl8723be]
filename:       /lib/modules/3.16.0-4-amd64/kernel/drivers/net/wireless/rtlwifi/rtl8723be/rtl8723be.ko
firmware:       rtlwifi/rtl8723befw.bin
depends:        rtlwifi,rtl_pci,btcoexist,mac80211
parm:           swlps:bool
parm:           swenc:using hardware crypto (default 0 [hardware])
parm:           ips:using no link power save (default 1 is open)
parm:           fwlps:using linked fw control power save (default 1 is open)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
parm:           debug:Set debug level (0-5) (default 0) (int)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)

[btcoexist]
filename:       /lib/modules/3.16.0-4-amd64/kernel/drivers/net/wireless/rtlwifi/btcoexist/btcoexist.ko
depends:        rtlwifi

[rtl_pci]
filename:       /lib/modules/3.16.0-4-amd64/kernel/drivers/net/wireless/rtlwifi/rtl_pci.ko
depends:        mac80211,rtlwifi

[rtlwifi]
filename:       /lib/modules/3.16.0-4-amd64/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
depends:        mac80211,cfg80211

[hp_wmi]
filename:       /lib/modules/3.16.0-4-amd64/kernel/drivers/platform/x86/hp-wmi.ko
depends:        wmi,sparse-keymap,rfkill

[mac80211]
filename:       /lib/modules/3.16.0-4-amd64/kernel/net/mac80211/mac80211.ko
depends:        cfg80211
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211]
filename:       /lib/modules/3.16.0-4-amd64/kernel/net/wireless/cfg80211.ko
depends:        rfkill
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

[rfkill]
filename:       /lib/modules/3.16.0-4-amd64/kernel/net/rfkill/rfkill.ko
depends:       
parm:           master_switch_mode:SW_RFKILL_ALL ON should: 0=do nothing (only unlock); 1=restore; 2=unblock all (uint)
parm:           default_state:Default initial state for all radio types, 0 = radio off (uint)

[wmi]
filename:       /lib/modules/3.16.0-4-amd64/kernel/drivers/platform/x86/wmi.ko
depends:       
parm:           debug_event:Log WMI Events [0/1] (bool)
parm:           debug_dump_wdg:Dump available WMI interfaces [0/1] (bool)


udev rules ~~~~~~~~~~~~~~~~~~~~~~~~~

# PCI device 0x10ec:0x8136 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC eth0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x10ec:0xb723 (rtl8723be)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC wlan0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"


Custom files/entries ~~~~~~~~~~~~~~~

/etc/modules        : Default
/etc/rc.local       : Default
/etc/modprobe.d     : Not Default
/etc/pm/(cnf|pw|sl) : Default

[/etc/modprobe.d]
modesetting.conf  : options cirrus modeset=1
                    options mgag200 modeset=1
rtl8723be.conf    : options rtl8723be ips=N fwlps=N


Kernel boot line ~~~~~~~~~~~~~~~~~~~

BOOT_IMAGE=/boot/vmlinuz-3.16.0-4-amd64 root=UUID=36d1ae7e-16c0-4d54-bd71-652c47b2e16f ro quiet


dmesg ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[    0.045566] Initializing cgroup subsys net_cls
[    0.045590] Initializing cgroup subsys net_prio
[    2.384841] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
[    2.385472] audit: initializing netlink subsys (disabled)
[    2.445506] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[    4.281997] platform microcode: firmware: direct-loading firmware amd-ucode/microcode_amd_fam16h.bin
[   11.885174] wmi: Mapper loaded
[   16.493628] Using firmware rtlwifi/rtl8723befw.bin
[   16.520612] rtl8723be 0000:02:00.0: firmware: direct-loading firmware rtlwifi/rtl8723befw.bin
[   16.623938] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[   16.624681] rtlwifi: wireless switch is on
[   22.565224] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   24.301797] r8169 0000:03:00.0: firmware: direct-loading firmware rtl_nic/rtl8106e-1.fw
[   25.008988] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   26.531153] wlan0: authenticate with <MAC C-01 Datenhafen>
[   26.542278] wlan0: send auth to <MAC C-01 Datenhafen> (try 1/3)
[   26.547620] wlan0: authenticated
[   26.550629] wlan0: associate with <MAC C-01 Datenhafen> (try 1/3)
[   26.558277] wlan0: RX AssocResp from <MAC C-01 Datenhafen> (capab=0x31 status=0 aid=1)
[   26.560642] wlan0: associated
[   26.560669] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  331.589069] wlan0: AP <MAC C-01 Datenhafen> changed bandwidth, new config is 2412 MHz, width 1 (2412/0 MHz)
[  378.840943] wlan0: deauthenticating from <MAC C-01 Datenhafen> by local choice (Reason: 3=DEAUTH_LEAVING)
[  381.114105] wlan0: authenticate with <MAC C-01 Datenhafen>
[  381.125289] wlan0: send auth to <MAC C-01 Datenhafen> (try 1/3)
[  381.131893] wlan0: authenticated
[  381.133807] wlan0: associate with <MAC C-01 Datenhafen> (try 1/3)
[  381.155566] wlan0: RX AssocResp from <MAC C-01 Datenhafen> (capab=0x31 status=0 aid=1)
[  381.157554] wlan0: associated
[  381.157666] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

   ======== Done ========
mylittlepavilion
 
Posts: 11
Joined: 2015-05-25 10:25

Re: RTL8723BE & Debian 8 | lwfinger rtlwifi_new

Postby v&n » 2015-05-25 15:07

Hmm.. everything looks nice and good this time, including module parameters -
mylittlepavilion wrote:
Code: Select all
rtl8723be     (7): debug=0 | disable_watchdog=N | fwlps=N | ips=N | msi=N | swenc=N | swlps=N


However, I'm a bit suspicious about this in dmesg -
mylittlepavilion wrote:
Code: Select all
[  331.589069] wlan0: AP <MAC C-01 Datenhafen> changed bandwidth, new config is 2412 MHz, width 1 (2412/0 MHz)
[  378.840943] wlan0: deauthenticating from <MAC C-01 Datenhafen> by local choice (Reason: 3=DEAUTH_LEAVING)

It shows a change of bandwidth at AP's end, which is what possibly lead to the deauthentication in the next line. Does your Access-Point support 2.4/5 GHz dual-band? If yes, and if it is set to use both bands, please try fixing it to use only 2.4 GHz mode.

Also, if the channel is set to 'Auto', try fixing it to channels 1 or 11 or 6 (1 is being used by other APs nearby, so I think 11 should offer better signal quality).
Furthermore, if the AP is set to use 20/40 MHz mixed mode, try fixing it to 20 MHz mode only. Reboot the AP after saving any changes to make sure the change is applied properly.

You can apply all these changes at once, but it is recommended to try one change at a time in the AP.
v&n
 
Posts: 555
Joined: 2015-02-04 02:57

Re: RTL8723BE & Debian 8 | lwfinger rtlwifi_new

Postby mylittlepavilion » 2015-05-25 15:14

I hava a FRITZ!Box 7362 SL, i am going now to try to disable the 5Ghz channel.
mylittlepavilion
 
Posts: 11
Joined: 2015-05-25 10:25

Re: RTL8723BE & Debian 8 | lwfinger rtlwifi_new

Postby mylittlepavilion » 2015-05-25 15:24

In the attachment is my current router configuration. I will test this for a few hours, and will reply how it works.

Image
mylittlepavilion
 
Posts: 11
Joined: 2015-05-25 10:25

Re: RTL8723BE & Debian 8 | lwfinger rtlwifi_new

Postby mylittlepavilion » 2015-05-26 10:03

MANY MANY THANKS FOR ALL HELP!

So, my wifi work's now, i hope so ^^ I switched yesterday to another channel ( 4 from 1 ) and disabled 5Ghz. I think it works now. I am online 5 Hours ago, no connection lost. Great!!!
mylittlepavilion
 
Posts: 11
Joined: 2015-05-25 10:25

Re: RTL8723BE & Debian 8 | lwfinger rtlwifi_new

Postby v&n » 2015-05-26 11:12

Awesome!

If you have tested it long enough, and across multiple reboots to be sure it is stable now, please mark the thread as [SOLVED] to help others. To do so, you'll have to edit your first post in the thread, and add [SOLVED] prefix to the subject line. Thanks for your precious feedback! :)
v&n
 
Posts: 555
Joined: 2015-02-04 02:57

Next

Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable