very slow wifi Intel Wireless-N 1000

Getting your soundcard to work, using Debian on non-i386 hardware, etc

very slow wifi Intel Wireless-N 1000

Postby xedni » 2015-06-09 15:09

I've noticed that my wifi connection is significantly slower than my wired connection. Obviously wired is always faster, but when I boot in to windoze or use Mac, the difference between wired and wifi is negligible. I'm running Debian 8 testing on a Lenovo X201 with Intel Corporation Centrino Wireless-N 1000 [Condor Peak] network card. Could somebody please advise on how to resolve the problem?
xedni
 
Posts: 40
Joined: 2014-02-07 07:53
Location: Polska

Re: very slow wifi Intel Wireless-N 1000

Postby Head_on_a_Stick » 2015-06-09 18:16

Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10607
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: very slow wifi Intel Wireless-N 1000

Postby xedni » 2015-06-09 21:59

Head_on_a_Stick wrote:http://forums.debian.net/viewtopic.php?f=16&t=121696


Great, thanks for the lead, but none of that seems to have helped. My wired speed is still around 5-6 times faster than wifi....My wired connection is getting around 44 Mbps, whilst the wifi is managing only around 11 (at best, but sometimes it's down to ~6Mbps). Under windoze, however, wifi is moving at around 30 Mbps.
xedni
 
Posts: 40
Joined: 2014-02-07 07:53
Location: Polska

Re: very slow wifi Intel Wireless-N 1000

Postby Head_on_a_Stick » 2015-06-10 06:00

It would be helpful if you could explicitly list all the things you have tried.

For example, is the card's power management enabled?
Code: Select all
# iwconfig
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10607
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: very slow wifi Intel Wireless-N 1000

Postby xedni » 2015-06-10 09:12

Head_on_a_Stick wrote:It would be helpful if you could explicitly list all the things you have tried.

For example, is the card's power management enabled?
Code: Select all
# iwconfig


Yes, of course, have tried:

Code: Select all
ifconfig wlan0 power off
in /etc/rc.local and

Code: Select all
options iwlwifi led_mode=1 # turns irritating blinking wifi led to on when wifi is on

    # options iwlwifi 11n_disable=1 # disable 802.11n
    options iwlwifi 11n_disable=8 # enable antenna aggregation

    options iwlwifi swcrypto=1 # enable software encryption - helps performance on some intel cards
in /etc/modprobe.d/iwlwifi.conf.

I also tried putting
Code: Select all
ifconfig wlan0 power off
in /etc/pm/power.d/wireless, although I'm not sure how to make it executable, as suggested by v&n.

Finally, I did

Code: Select all
sudo tee /etc/modprobe.d/iwlmvm.conf <<< "options iwlmvm power_scheme=1"


The result of
Code: Select all
iwconfig
indicates that power management is off:

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"Frajer"
Mode:Managed Frequency:2.437 GHz Access Point: F4:9F:F3:4E:F2:D2
Bit Rate=1 Mb/s Tx-Power=14 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=70/70 Signal level=-30 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:76 Missed beacon:0

lo no wireless extensions.
xedni
 
Posts: 40
Joined: 2014-02-07 07:53
Location: Polska

Re: very slow wifi Intel Wireless-N 1000

Postby v&n » 2015-06-10 17:10

xedni wrote:I also tried putting
Code: Select all
ifconfig wlan0 power off
in /etc/pm/power.d/wireless, although I'm not sure how to make it executable, as suggested by v&n.

First, the command should be "iwconfig wlan0 power off", not "ifconfig....." (I just noticed that error and mentioned it in the referred thread).

Second, files are made executable with 'chmod +x <filename>' command. For example -
Code: Select all
sudo chmod +x /etc/pm/power.d/wireless

..for the file in this case.

Thirdly, the power management already appears to be 'off' in iwconfig output. So the above may not be needed. We shall need to see more settings to verify where the culprit may be. Can you run a script and post its report file please? That should give us most of the required info in one go. The script and the method to download/run it is mentioned here : viewtopic.php?p=579154#p579154

PS: Just as a statutory warning, you should never run unknown scripts. Run them only if you know what exactly they are going to do. The one mentioned above just collects wireless related info and puts it in a report file (wireless-info.txt) while filtering out all the sensitive info (wifi password, MAC IDs etc.). Personally I trust it, but the statutory warning still stands. ;)
v&n
 
Posts: 621
Joined: 2015-02-04 02:57

Re: very slow wifi Intel Wireless-N 1000

Postby xedni » 2015-06-10 18:53

Thanks for the advice :) and here's the output of the script:

Code: Select all
   ======== Wireless-Info START ========

System-Info ~~~~~~~~~~~~~~~~~~~~~~~~

debilian 3.16.0-4-amd64 x86_64,  Debian GNU/Linux testing (stretch), stretch

CPU    : Intel(R) Core(TM) i7 CPU       M 620  @ 2.67GHz
Memory : 5781 MB
Uptime : 20:50:57 up 9 min,  2 users,  load average: 0.40, 0.54, 0.35


lspci ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

00:19.0 Ethernet controller [0200]: Intel Corporation 82577LM Gigabit Network Connection [8086:10ea] (rev 06)
   Subsystem: Lenovo Device [17aa:2153]
   Kernel driver in use: e1000e
--
02:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 1000 [Condor Peak] [8086:0084]
   Subsystem: Intel Corporation Centrino Wireless-N 1000 BGN [8086:1315]
   Kernel driver in use: iwlwifi


lsusb ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 007: ID 17ef:4816 Lenovo
Bus 001 Device 011: ID 0bc2:2332 Seagate RSS LLC
Bus 001 Device 009: ID 04fc:0c25 Sunplus Technology Co., Ltd SATALink SPIF225A
Bus 001 Device 010: ID 04c5:201d Fujitsu, Ltd
Bus 001 Device 008: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth
Bus 001 Device 006: ID 17ef:1005 Lenovo
Bus 001 Device 004: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
Bus 001 Device 003: ID 12d1:14dc Huawei Technologies Co., Ltd.
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


PCMCIA Card Info ~~~~~~~~~~~~~~~~~~~



iwconfig ~~~~~~~~~~~~~~~~~~~~~~~~~~~

wlan0     IEEE 802.11bgn  ESSID:"Frajer" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: <MAC ID removed>   
          Bit Rate=1 Mb/s   Tx-Power=14 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-40 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:53   Missed beacon:0



rfkill ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      Interface                    Soft blocked  Hard blocked
0: tpacpi_bluetooth_sw: Bluetooth      yes           no
2: phy0: Wireless LAN                  no            no


lsmod ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

iwldvm                135156  0
mac80211              474277  1 iwldvm
iwlwifi                96547  1 iwldvm
wmi                    17339  0
cfg80211              405538  3 iwlwifi,mac80211,iwldvm


module parameters ~~~~~~~~~~~~~~~~~~

cfg80211      (2): cfg80211_disable_40mhz_24ghz=N | ieee80211_regdom=00
iwlwifi      (13): 11n_disable=0 | amsdu_size_8K=0 | antenna_coupling=0 | bt_coex_active=Y | fw_monitor=N | fw_restart=Y | led_mode=0 | nvm_file=(null) | power_level=0 | power_save=N | swcrypto=0 | uapsd_disable=Y | wd_disable=1
mac80211      (5): beacon_loss_count=7 | ieee80211_default_rc_algo=minstrel_ht | max_nullfunc_tries=2 | max_probe_tries=5 | probe_wait_ms=500
wmi           (2): debug_dump_wdg=N | debug_event=N


nm-tool ~~~~~~~~~~~~~~~~~~~~~~~~~~~~


================o======o========o========o=========o===========o==============o===========
 Interface & ID | Type | Driver | State  | Default | Speed     | Support      | HW Addr   
================o======o========o========o=========o===========o==============o===========
                |      |        |        |         |           |              |           
----------------+------+--------+--------+---------+-----------+--------------+-----------


NetworkManager.state ~~~~~~~~~~~~~~~
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true


NetworkManager.conf ~~~~~~~~~~~~~~~~

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false


NM WiFi Profiles ~~~~~~~~~~~~~~~~~~~
 


interfaces ~~~~~~~~~~~~~~~~~~~~~~~~~

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

resolv.conf ~~~~~~~~~~~~~~~~~~~~~~~~

nameserver 192.168.8.1


Routes & Ping ~~~~~~~~~~~~~~~~~~~~~~

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.8.1     0.0.0.0         UG    100    0        0 eth2
0.0.0.0         192.168.8.1     0.0.0.0         UG    600    0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth2
192.168.8.0     0.0.0.0         255.255.255.0   U     100    0        0 eth2
192.168.8.0     0.0.0.0         255.255.255.0   U     600    0        0 wlan0

--- 192.168.8.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 13.824/14.561/15.298/0.737 ms

--- 192.168.8.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 15.023/15.622/16.221/0.599 ms


iw reg get ~~~~~~~~~~~~~~~~~~~~~~~~~

(Region : "en_US.utf8")
country 00: DFS-UNSET
   (2402 - 2472 @ 40), (N/A, 20), (N/A)
   (2457 - 2482 @ 40), (N/A, 20), (N/A), NO-IR
   (2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, NO-IR
   (5170 - 5250 @ 80), (N/A, 20), (N/A), NO-IR
   (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, NO-IR
   (5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, NO-IR
   (5735 - 5835 @ 80), (N/A, 20), (N/A), NO-IR
   (57240 - 63720 @ 2160), (N/A, 0), (N/A)


iwlist chan ~~~~~~~~~~~~~~~~~~~~~~~~

wlan0     13 channels in total; available frequencies :
          Channel 01 (2.412 GHz) - 13 (2.472 GHz)

          Current Frequency:2.437 GHz (Channel 6)


iwlist scan ~~~~~~~~~~~~~~~~~~~~~~~~



blacklist ~~~~~~~~~~~~~~~~~~~~~~~~~~


modinfo ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[iwldvm]
filename:       /lib/modules/3.16.0-4-amd64/kernel/drivers/net/wireless/iwlwifi/dvm/iwldvm.ko
version:        in-tree:
srcversion:     BDE65929E307956A36DDD4C
depends:        iwlwifi,mac80211,cfg80211

[mac80211]
filename:       /lib/modules/3.16.0-4-amd64/kernel/net/mac80211/mac80211.ko
depends:        cfg80211
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[iwlwifi]
filename:       /lib/modules/3.16.0-4-amd64/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko
version:        in-tree:
firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-135-6.ucode
firmware:       iwlwifi-105-6.ucode
firmware:       iwlwifi-2030-6.ucode
firmware:       iwlwifi-2000-6.ucode
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-5.ucode
firmware:       iwlwifi-6000g2b-6.ucode
firmware:       iwlwifi-6000g2a-5.ucode
firmware:       iwlwifi-6050-5.ucode
firmware:       iwlwifi-6000-4.ucode
firmware:       iwlwifi-7265-9.ucode
firmware:       iwlwifi-3160-9.ucode
firmware:       iwlwifi-7260-9.ucode
firmware:       iwlwifi-8000-8.ucode
srcversion:     3E4DCD8265C8E43DCA7B0EA
depends:        cfg80211
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
parm:           amsdu_size_8K:enable 8K amsdu size (default 0) (int)
parm:           fw_restart:restart firmware in case of error (default true) (bool)
parm:           antenna_coupling:specify antenna coupling in dB (defualt: 0 dB) (int)
parm:           wd_disable:Disable stuck queue watchdog timer 0=system default, 1=disable (default: 1) (int)
parm:           nvm_file:NVM file name (charp)
parm:           uapsd_disable:disable U-APSD functionality (default: Y) (bool)
parm:           bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)
parm:           power_save:enable WiFi power management (default: disable) (bool)
parm:           power_level:default power save level (range from 1 - 5, default: 1) (int)
parm:           fw_monitor:firmware monitor - to debug FW (default: false - needs lots of memory) (bool)

[wmi]
filename:       /lib/modules/3.16.0-4-amd64/kernel/drivers/platform/x86/wmi.ko
depends:       
parm:           debug_event:Log WMI Events [0/1] (bool)
parm:           debug_dump_wdg:Dump available WMI interfaces [0/1] (bool)

[cfg80211]
filename:       /lib/modules/3.16.0-4-amd64/kernel/net/wireless/cfg80211.ko
depends:        rfkill
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)


udev rules ~~~~~~~~~~~~~~~~~~~~~~~~~

# PCI device 0x8086:/sys/devices/pci0000:00/0000:00:19.0 (e1000e)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC eth0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x8086:/sys/devices/pci0000:00/0000:00:1c.4/0000:02:00.0 (iwlwifi)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC wlan0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

# USB device 0x:0x (cdc_ether)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC eth1>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

# USB device 0x:0x (cdc_ether)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC eth2>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth2"


Custom files/entries ~~~~~~~~~~~~~~~

/etc/modules        : Not Default
/etc/rc.local       : Not Default
/etc/modprobe.d     : Not Default
/etc/pm/(cnf|pw|sl) : Default

[/etc/modules]
loop
coretemp

[/etc/rc.local]
rfkill block bluetooth
exit 0

[/etc/modprobe.d]
iwlmvm.conf       : options iwlmvm power_scheme=1
modesetting.conf  : options cirrus modeset=1
                    options mgag200 modeset=1
open-vm-tools.conf: install pcnet32 /sbin/modprobe -q --ignore-install vmxnet; /sbin/modprobe -q --ignore-install pcnet32 $CMDLINE_OPTS; /bin/true;
radeon-kms.conf   : options radeon modeset=1
thinkfan.conf     : options thinkpad_acpi fan_control=1
thinkpad-acpi.conf: options thinkpad-acpi experimental=1 fan_control=1


Kernel boot line ~~~~~~~~~~~~~~~~~~~

BOOT_IMAGE=/boot/vmlinuz-3.16.0-4-amd64 root=UUID=6691626b-9717-4686-9ebf-eb018b49aee1 ro initrd=/install/initrd.gz quiet


dmesg ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[    0.033207] Initializing cgroup subsys net_cls
[    0.033217] Initializing cgroup subsys net_prio
[    0.666133] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
[    0.666442] audit: initializing netlink subsys (disabled)
[    3.073503] thinkpad_acpi: http://ibm-acpi.sf.net/
[    3.078544] wmi: Mapper loaded
[    3.091012] iwlwifi 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control
[    3.091162] iwlwifi 0000:02:00.0: irq 44 for MSI/MSI-X
[    3.095563] iwlwifi 0000:02:00.0: firmware: direct-loading firmware iwlwifi-1000-5.ucode
[    3.095707] iwlwifi 0000:02:00.0: loaded firmware version 39.31.5.1 build 35138 op_mode iwldvm
[    3.122850] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUG disabled
[    3.122853] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[    3.122855] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
[    3.122857] iwlwifi 0000:02:00.0: Detected Intel(R) Centrino(R) Wireless-N 1000 BGN, REV=0x6C
[    3.122950] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[    3.150014] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[    3.151823] cdc_ether 1-1.1:1.0 eth1: register 'cdc_ether' at usb-0000:00:1a.0-1.1, CDC Ethernet Device, <MAC eth2>
[    3.260508] systemd-udevd[246]: renamed network interface eth1 to eth2
[    4.071317] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    4.487359] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[    4.494825] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x3
[    4.529845] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[    4.537274] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x3
[    4.572638] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    5.001094] wlan0: authenticate with <MAC ID removed>
[    5.005666] wlan0: send auth to <MAC ID removed> (try 1/3)
[    5.008412] wlan0: authenticated
[    5.008663] wlan0: AP has invalid WMM params (AIFSN=1 for ACI 2), disabling WMM
[    5.012290] wlan0: associate with <MAC ID removed> (try 1/3)
[    5.015038] wlan0: RX AssocResp from <MAC ID removed> (capab=0x411 status=0 aid=2)
[    5.018873] wlan0: associated
[    5.018910] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[    9.424774] psmouse serio2: trackpoint: IBM TrackPoint firmware: 0x0e, buttons: 3/3

   ======== Done ========
xedni
 
Posts: 40
Joined: 2014-02-07 07:53
Location: Polska

Re: very slow wifi Intel Wireless-N 1000

Postby v&n » 2015-06-10 19:19

Quoting the parts that look significant to me -
xedni wrote:
Code: Select all
module parameters ~~~~~~~~~~~~~~~~~~
....
iwlwifi      (13): 11n_disable=0 | amsdu_size_8K=0 ....
....

Custom files/entries ~~~~~~~~~~~~~~~
....
[/etc/modprobe.d]
iwlmvm.conf       : options iwlmvm power_scheme=1
....
dmesg ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
....
[    5.008663] wlan0: AP has invalid WMM params (AIFSN=1 for ACI 2), disabling WMM


Now suggestions for now, try one at a time, moving forward (without reverting the previous change) as and if required -

1. The "11n_disable" parameter is still set to "0" which is obvious because it is default and nowhere else any other mode is forced. So I suggest you create a conf file to force mode '8' -
Code: Select all
sudo tee /etc/modprobe.d/iwlwifi.conf <<< "options iwlwifi 11n_disable=8"

Reboot and see if your connection is good now (check connection speed in 'iwconfig').

2. Your laptop is not using the 'iwlmvm' driver (is using 'iwldvm' instead), so the 'iwlmvm.conf' file is needless (not causing any harm, but is needless). I suggest you delete it to eliminate unnecessary confusion/complexity -
Code: Select all
sudo rm /etc/modprobe.d/iwlmvm.conf


3. I keep seeing those "..invalid WMM params" warnings in dmesg and usually they don't seem to cause any troubles. But sometimes I believe they can. So check your router's settings for QoS/WMM, and try changing the status of the WMM feature if the router's interface provides the option to enable/disable it. Usually turning it off helps, but some users have reported they need it to get optimal performance.

If these don't seem to help, please run the script again (with root privileges), after making above changes, and post back its fresh report. Running it with root privileges is recommended here since the script was originally created for Ubuntu, while some of its presumed 'basic' commands need root privilege in Debian.

Oh, and make sure you run it with ONLY wireless connected. Preferably no ethernet connection in picture. Of course no need to run if any of the suggestions proposed above fix the issue.
v&n
 
Posts: 621
Joined: 2015-02-04 02:57

Re: very slow wifi Intel Wireless-N 1000

Postby xedni » 2015-06-10 20:03

I' ve set it to mode 8 and deleted iwlmvm.conf, although my router doesn't seem to have an option to set QoS/WMM. Unfortunately I haven't noticed any changes in the connection speed :(

Here's the output of the script, with wifi only and as root:

Code: Select all
   ======== Wireless-Info START ========

System-Info ~~~~~~~~~~~~~~~~~~~~~~~~

debilian 3.16.0-4-amd64 x86_64,  Debian GNU/Linux testing (stretch), stretch

CPU    : Intel(R) Core(TM) i7 CPU       M 620  @ 2.67GHz
Memory : 5781 MB
Uptime : 21:40:41 up 2 min,  2 users,  load average: 1.54, 0.95, 0.38


lspci ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

00:19.0 Ethernet controller [0200]: Intel Corporation 82577LM Gigabit Network Connection [8086:10ea] (rev 06)
   Subsystem: Lenovo Device [17aa:2153]
   Kernel driver in use: e1000e
--
02:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 1000 [Condor Peak] [8086:0084]
   Subsystem: Intel Corporation Centrino Wireless-N 1000 BGN [8086:1315]
   Kernel driver in use: iwlwifi


lsusb ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 006: ID 17ef:4816 Lenovo
Bus 001 Device 010: ID 0bc2:2332 Seagate RSS LLC
Bus 001 Device 008: ID 04fc:0c25 Sunplus Technology Co., Ltd SATALink SPIF225A
Bus 001 Device 009: ID 04c5:201d Fujitsu, Ltd
Bus 001 Device 007: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth
Bus 001 Device 005: ID 17ef:1005 Lenovo
Bus 001 Device 003: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


PCMCIA Card Info ~~~~~~~~~~~~~~~~~~~



iwconfig ~~~~~~~~~~~~~~~~~~~~~~~~~~~

wlan0     IEEE 802.11bgn  ESSID:"Frajer" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: <MAC ID removed>   
          Bit Rate=1 Mb/s   Tx-Power=14 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-28 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:122   Missed beacon:0



rfkill ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      Interface                    Soft blocked  Hard blocked
0: tpacpi_bluetooth_sw: Bluetooth      yes           no
2: phy0: Wireless LAN                  no            no


lsmod ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

iwldvm                135156  0
mac80211              474277  1 iwldvm
iwlwifi                96547  1 iwldvm
cfg80211              405538  3 iwlwifi,mac80211,iwldvm
wmi                    17339  0


module parameters ~~~~~~~~~~~~~~~~~~

cfg80211      (2): cfg80211_disable_40mhz_24ghz=N | ieee80211_regdom=00
iwlwifi      (13): 11n_disable=8 | amsdu_size_8K=0 | antenna_coupling=0 | bt_coex_active=Y | fw_monitor=N | fw_restart=Y | led_mode=0 | nvm_file=(null) | power_level=0 | power_save=N | swcrypto=0 | uapsd_disable=Y | wd_disable=1
mac80211      (5): beacon_loss_count=7 | ieee80211_default_rc_algo=minstrel_ht | max_nullfunc_tries=2 | max_probe_tries=5 | probe_wait_ms=500
wmi           (2): debug_dump_wdg=N | debug_event=N


nm-tool ~~~~~~~~~~~~~~~~~~~~~~~~~~~~


================o======o========o========o=========o===========o==============o===========
 Interface & ID | Type | Driver | State  | Default | Speed     | Support      | HW Addr   
================o======o========o========o=========o===========o==============o===========
                |      |        |        |         |           |              |           
----------------+------+--------+--------+---------+-----------+--------------+-----------


NetworkManager.state ~~~~~~~~~~~~~~~
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true


NetworkManager.conf ~~~~~~~~~~~~~~~~

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false


NM WiFi Profiles ~~~~~~~~~~~~~~~~~~~
 


interfaces ~~~~~~~~~~~~~~~~~~~~~~~~~

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

resolv.conf ~~~~~~~~~~~~~~~~~~~~~~~~

nameserver 192.168.8.1


Routes & Ping ~~~~~~~~~~~~~~~~~~~~~~

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.8.1     0.0.0.0         UG    600    0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0
192.168.8.0     0.0.0.0         255.255.255.0   U     600    0        0 wlan0

--- 192.168.8.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 2.053/2.056/2.060/0.045 ms

--- 192.168.8.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 2.005/3.213/4.422/1.209 ms


iw reg get ~~~~~~~~~~~~~~~~~~~~~~~~~

(Region : "en_US.utf8")
country 00: DFS-UNSET
   (2402 - 2472 @ 40), (N/A, 20), (N/A)
   (2457 - 2482 @ 40), (N/A, 20), (N/A), NO-IR
   (2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, NO-IR
   (5170 - 5250 @ 80), (N/A, 20), (N/A), NO-IR
   (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, NO-IR
   (5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, NO-IR
   (5735 - 5835 @ 80), (N/A, 20), (N/A), NO-IR
   (57240 - 63720 @ 2160), (N/A, 0), (N/A)


iwlist chan ~~~~~~~~~~~~~~~~~~~~~~~~

wlan0     13 channels in total; available frequencies :
          Channel 01 (2.412 GHz) - 13 (2.472 GHz)

          Current Frequency:2.437 GHz (Channel 6)


iwlist scan ~~~~~~~~~~~~~~~~~~~~~~~~



blacklist ~~~~~~~~~~~~~~~~~~~~~~~~~~


modinfo ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[iwldvm]
filename:       /lib/modules/3.16.0-4-amd64/kernel/drivers/net/wireless/iwlwifi/dvm/iwldvm.ko
version:        in-tree:
srcversion:     BDE65929E307956A36DDD4C
depends:        iwlwifi,mac80211,cfg80211

[mac80211]
filename:       /lib/modules/3.16.0-4-amd64/kernel/net/mac80211/mac80211.ko
depends:        cfg80211
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[iwlwifi]
filename:       /lib/modules/3.16.0-4-amd64/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko
version:        in-tree:
firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-135-6.ucode
firmware:       iwlwifi-105-6.ucode
firmware:       iwlwifi-2030-6.ucode
firmware:       iwlwifi-2000-6.ucode
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-5.ucode
firmware:       iwlwifi-6000g2b-6.ucode
firmware:       iwlwifi-6000g2a-5.ucode
firmware:       iwlwifi-6050-5.ucode
firmware:       iwlwifi-6000-4.ucode
firmware:       iwlwifi-7265-9.ucode
firmware:       iwlwifi-3160-9.ucode
firmware:       iwlwifi-7260-9.ucode
firmware:       iwlwifi-8000-8.ucode
srcversion:     3E4DCD8265C8E43DCA7B0EA
depends:        cfg80211
parm:           swcrypto:using crypto in software (default 0 [hardware]) (int)
parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
parm:           amsdu_size_8K:enable 8K amsdu size (default 0) (int)
parm:           fw_restart:restart firmware in case of error (default true) (bool)
parm:           antenna_coupling:specify antenna coupling in dB (defualt: 0 dB) (int)
parm:           wd_disable:Disable stuck queue watchdog timer 0=system default, 1=disable (default: 1) (int)
parm:           nvm_file:NVM file name (charp)
parm:           uapsd_disable:disable U-APSD functionality (default: Y) (bool)
parm:           bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
parm:           led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)
parm:           power_save:enable WiFi power management (default: disable) (bool)
parm:           power_level:default power save level (range from 1 - 5, default: 1) (int)
parm:           fw_monitor:firmware monitor - to debug FW (default: false - needs lots of memory) (bool)

[cfg80211]
filename:       /lib/modules/3.16.0-4-amd64/kernel/net/wireless/cfg80211.ko
depends:        rfkill
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

[wmi]
filename:       /lib/modules/3.16.0-4-amd64/kernel/drivers/platform/x86/wmi.ko
depends:       
parm:           debug_event:Log WMI Events [0/1] (bool)
parm:           debug_dump_wdg:Dump available WMI interfaces [0/1] (bool)


udev rules ~~~~~~~~~~~~~~~~~~~~~~~~~

# PCI device 0x8086:/sys/devices/pci0000:00/0000:00:19.0 (e1000e)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC eth0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x8086:/sys/devices/pci0000:00/0000:00:1c.4/0000:02:00.0 (iwlwifi)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC wlan0>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

# USB device 0x:0x (cdc_ether)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC eth1>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

# USB device 0x:0x (cdc_ether)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC eth2>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth2"


Custom files/entries ~~~~~~~~~~~~~~~

/etc/modules        : Not Default
/etc/rc.local       : Not Default
/etc/modprobe.d     : Not Default
/etc/pm/(cnf|pw|sl) : Default

[/etc/modules]
loop
coretemp

[/etc/rc.local]
rfkill block bluetooth
exit 0

[/etc/modprobe.d]
iwlwifi.conf      : options iwlwifi 11n_disable=8
modesetting.conf  : options cirrus modeset=1
                    options mgag200 modeset=1
open-vm-tools.conf: install pcnet32 /sbin/modprobe -q --ignore-install vmxnet; /sbin/modprobe -q --ignore-install pcnet32 $CMDLINE_OPTS; /bin/true;
radeon-kms.conf   : options radeon modeset=1
thinkfan.conf     : options thinkpad_acpi fan_control=1
thinkpad-acpi.conf: options thinkpad-acpi experimental=1 fan_control=1


Kernel boot line ~~~~~~~~~~~~~~~~~~~

BOOT_IMAGE=/boot/vmlinuz-3.16.0-4-amd64 root=UUID=6691626b-9717-4686-9ebf-eb018b49aee1 ro initrd=/install/initrd.gz quiet


dmesg ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[    0.033001] Initializing cgroup subsys net_cls
[    0.033011] Initializing cgroup subsys net_prio
[    0.666694] microcode: Microcode Update Driver: v2.00 <tigran@aivazian.fsnet.co.uk>, Peter Oruba
[    0.667001] audit: initializing netlink subsys (disabled)
[    2.829082] wmi: Mapper loaded
[    2.832478] thinkpad_acpi: http://ibm-acpi.sf.net/
[    2.851901] iwlwifi 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control
[    2.852181] iwlwifi 0000:02:00.0: irq 43 for MSI/MSI-X
[    2.858240] iwlwifi 0000:02:00.0: firmware: direct-loading firmware iwlwifi-1000-5.ucode
[    2.858391] iwlwifi 0000:02:00.0: loaded firmware version 39.31.5.1 build 35138 op_mode iwldvm
[    2.884235] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUG disabled
[    2.884239] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
[    2.884242] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
[    2.884244] iwlwifi 0000:02:00.0: Detected Intel(R) Centrino(R) Wireless-N 1000 BGN, REV=0x6C
[    2.884925] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[    2.913720] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[    3.763635] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    4.155907] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[    4.163415] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x3
[    4.198149] iwlwifi 0000:02:00.0: L1 Enabled - LTR Disabled
[    4.205579] iwlwifi 0000:02:00.0: Radio type=0x0-0x0-0x3
[    4.261260] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    4.787459] wlan0: authenticate with <MAC ID removed>
[    4.791864] wlan0: send auth to <MAC ID removed> (try 1/3)
[    4.794602] wlan0: authenticated
[    4.794823] wlan0: AP has invalid WMM params (AIFSN=1 for ACI 2), disabling WMM
[    4.796795] wlan0: associate with <MAC ID removed> (try 1/3)
[    4.799553] wlan0: RX AssocResp from <MAC ID removed> (capab=0x411 status=0 aid=2)
[    4.803470] wlan0: associated
[    4.803517] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[    9.158500] psmouse serio2: trackpoint: IBM TrackPoint firmware: 0x0e, buttons: 3/3

   ======== Done ========
Last edited by xedni on 2015-06-18 11:31, edited 1 time in total.
xedni
 
Posts: 40
Joined: 2014-02-07 07:53
Location: Polska

Re: very slow wifi Intel Wireless-N 1000

Postby v&n » 2015-06-11 01:39

EDIT: First off, please edit your post above to change the 'quote' tags to 'code' tags for the output part. As you can see, the 'quote' tags cannot preserve the formatting of the report. Remember to use 'code' tags for outputs in future. :)
----------------------

Hmm.. I was hoping to see some outputs in 'iwlist' section. Do you get any errors if running it manually? -
Code: Select all
sudo iwlist scan

Please post back whatever errors or output it returns.

For now, please try some further changes in the router/access-point -

1. Try changing the channel to 1. With no output from iwlist scan, I can't tell if it would be the best channel for you. So please also try fixing the channel to 11 or 13 if ch.1 doesn't make any difference. You can install and run package 'wifi-radar' (a gui tool to create available signal profiles and monitor their quality) to check which of the channels are least congested and have best signal quality.

2. If your AP(access-point) is using 'auto' or '20/40 MHz auto' mode for channel bandwidth, please try fixing it to 20 MHz only mode. So now both the channel and the bandwidth should be 'Fixed', not set to 'auto'.

Reboot the router after saving the changes, connect again and see if the connection is any better. If it is still the same, try adding another parameter in the conf file -
Code: Select all
sudo sed -i 's/options.*/& bt_coex_active=N/' /etc/modprobe.d/iwlwifi.conf

This will add the "bt_coex_active=N" parameter to the existing conf file. It will disable a feature of the driver that is supposed to help wifi connection quality, but sometimes actually causes problems instead (more often in older versions, not required for a long time now in the latest versions, so it is basically just a shot in the dark).

Reboot, recheck the connection. If still the same (less than 24 Mb/s in iwconfig), try adding yet another parameter 'swcrypto' -
Code: Select all
sudo sed -i 's/options.*/& swcrypto=1/' etc/modprobe.d/iwlwifi.conf

This will shift the workload of packet encryption from hardware (wifi chip) to software (driver/OS). Again, this is something that has not been required for a long time in the threads I've troubleshooted (in fact causes more troubles sometimes with latest versions), but is worth a try. Reload the driver or reboot to check the performance again.

If none of this makes any difference, try a forced speed and report back if you get any errors -
Code: Select all
sudo iwconfig wlan0 rate 24M

If it sticks (will show up in iwconfig), check if the connection is stable. Some other supported speeds worth trying could be 11M (to be tested only if 24M makes the connection unstable), 36M, or 48M. There are also higher speeds corresponding to N mode, but a forced speed is really not the way to go. It is just for a test to see if the connection can survive higher speeds.
v&n
 
Posts: 621
Joined: 2015-02-04 02:57

Re: very slow wifi Intel Wireless-N 1000

Postby xedni » 2015-06-18 11:33

Sorry for the late response. The forum seemed to be down and I wasn't able to log in. Here's the output of

Code: Select all
sudo iwlist scan


eth0 Interface doesn't support scanning.

wlan0 Interface doesn't support scanning : Network is down

eth2 Interface doesn't support scanning.

lo Interface doesn't support scanning.
xedni
 
Posts: 40
Joined: 2014-02-07 07:53
Location: Polska

Re: very slow wifi Intel Wireless-N 1000

Postby v&n » 2015-06-18 11:48

Looks like you ran the command when wifi was disabled -
xedni wrote:wlan0 Interface doesn't support scanning : Network is down

Please try again when the wifi is connected. The result will help us see if something in the router/access-point can be done to optimize the connection quality.
v&n
 
Posts: 621
Joined: 2015-02-04 02:57

Re: very slow wifi Intel Wireless-N 1000

Postby xedni » 2015-06-18 11:54

v&n wrote:Looks like you ran the command when wifi was disabled -
xedni wrote:wlan0 Interface doesn't support scanning : Network is down

Please try again when the wifi is connected. The result will help us see if something in the router/access-point can be done to optimize the connection quality.


eth0 Interface doesn't support scanning.

wlan0 Failed to read scan data : Resource temporarily unavailable

lo Interface doesn't support scanning.
xedni
 
Posts: 40
Joined: 2014-02-07 07:53
Location: Polska

Re: very slow wifi Intel Wireless-N 1000

Postby v&n » 2015-06-18 12:34

xedni wrote:wlan0 Failed to read scan data : Resource temporarily unavailable

Now this happens when the interface is active, but is already busy in scanning the network. Once that is done and a connection is established (or if the interface gives up and sits idle (not inactive)), it should return some results.

I must say that this is the first time I've seen iwlist requiring so many retries... makes me wonder if this could be part of the problem.
v&n
 
Posts: 621
Joined: 2015-02-04 02:57

Re: very slow wifi Intel Wireless-N 1000

Postby xedni » 2015-06-19 10:27

This time it gave a result:

wlan0 Scan completed :
Cell 01 - Address: F4:9F:F3:4E:F2:D2
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=63/70 Signal level=-47 dBm
Encryption key:on
ESSID:"Frajer"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=0000001051233ddb
Extra: Last beacon: 109604ms ago
IE: Unknown: 00064672616A6572
IE: Unknown: 010882848B962430486C
IE: Unknown: 030101
IE: Unknown: 2A0100
IE: Unknown: 2F0100
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: 32040C121860
IE: Unknown: 2D1ABC011BFFFF000000000000000000000000000000000000000000
IE: Unknown: 3D1601001700000000000000000000000000000000000000
IE: Unknown: DD050050F20500
IE: Unknown: DD740050F204104A0001101044000102103B0001031047001022210203040506070809F49FF34EF2D21021000842726F6164636F6D10230006536F66744150102400013010420001301054000800060050F20400011011000842726F6164636F6D100800020284103C0001011049000600372A000120
IE: Unknown: DD090010180202000C0000
IE: Unknown: DD180050F202010184000364000027A4000041435E0061322F00
xedni
 
Posts: 40
Joined: 2014-02-07 07:53
Location: Polska

Next

Return to Hardware

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable