acpi power button config ignored

Getting your soundcard to work, using Debian on non-i386 hardware, etc

acpi power button config ignored

Postby skinnny » 2015-09-28 13:30

Hi

I have an Asus EEE Box EB1012 running Debian Jessie (headless with no GUI installed).

I'm trying to get the power button on the front of the machine to put the computer in suspend.

If I run pm-suspend from the command line, it suspends correctly and also recovers correctly by pressing the hardware power button.

Originally, pressing the power button (while running) would shut the computer down.

The acpi power button event script was set to run the command "/sbin/shutdown -h -P now".

I changed it to "/usr/sbin/pm-suspend", and restarted the acpi service/rebooted the computer (I tried both), but the power button still cause the computer to shut down.

I also tried setting no action (empty string) for the power button event, but still the power button caused shutdown.

Is the acpi system getting bypassed somehow? Is there another system to configure instead?

Thanks in advance.

Colin
skinnny
 
Posts: 1
Joined: 2015-09-28 09:45

Return to Hardware

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable