z8700 Kangaroo sound not working

Getting your soundcard to work, using Debian on non-i386 hardware, etc

z8700 Kangaroo sound not working

Postby hanasaki » 2016-09-26 02:09

Trying to get it to work over HDMI. Any help is appreciated. Thank you!

Tried custom kernel since the stock 4.6 did not work from jessie, jessie-backports or stretch (config attached)

[quote]Linux host 4.7.4 #2 SMP PREEMPT Fri Sep 16 16:48:54 EDT 2016 x86_64 GNU/Linux[/quote]
[quote]
[ 0.000000] DMI: Foxconn Kangaroo Mobile Desktop/0E6A, BIOS 07.000 01/12/2016[/quote]

[quote]lsmod | grep snd
snd_soc_sst_cht_bsw_rt5672 7504 0
snd_soc_rt5640 94148 0
snd_soc_rt5645 118020 0
snd_soc_rt5670 108928 1 snd_soc_sst_cht_bsw_rt5672
snd_soc_rl6231 2048 3 snd_soc_rt5640,snd_soc_rt5645,snd_soc_rt5670
snd_soc_tlv320aic31xx 27968 0
snd_intel_sst_acpi 4096 1
snd_intel_sst_core 48640 1 snd_intel_sst_acpi
snd_soc_sst_mfld_platform 62016 1 snd_intel_sst_core
snd_soc_sst_match 1280 1 snd_intel_sst_acpi[/quote]

[quote]lspci
00:00.0 Host bridge: Intel Corporation Device 2280 (rev 20)
00:02.0 VGA compatible controller: Intel Corporation Device 22b0 (rev 20)
00:0b.0 Signal processing controller: Intel Corporation Device 22dc (rev 20)
00:14.0 USB controller: Intel Corporation Device 22b5 (rev 20)
00:1a.0 Encryption controller: Intel Corporation Device 2298 (rev 20)
00:1c.0 PCI bridge: Intel Corporation Device 22c8 (rev 20)
00:1f.0 ISA bridge: Intel Corporation Device 229c (rev 20)
01:00.0 Network controller: Intel Corporation Wireless 7265 (rev 69)[/quote]
hanasaki
 
Posts: 24
Joined: 2013-09-10 22:34

Re: z8700 Kangaroo sound not working

Postby bigrigdriver » 2016-09-28 02:18

Everything I can find at present says there is no support in the Linux kernel for the Kangaroo hardware. It was designed for window$. If there is enough demand, and someone to write the drivers, then, maybe ..... some day....
Registered GNU/Linux user #170078

Go ask google before you ask on these boards.

It it isn't broken, Tweak It !!!
bigrigdriver
 
Posts: 145
Joined: 2014-09-01 17:04
Location: East Central Illinois, USA

Re: z8700 Kangaroo sound not working

Postby hanasaki » 2018-08-27 22:56

Looks like newer kernels might support it. No longer a worry for me... The unit died after ~10 months and the new N4100, N4200, N3450 systems are alot more powerful at about the same price and well supported.
hanasaki
 
Posts: 24
Joined: 2013-09-10 22:34


Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable