Debian doesn't enable wireless iface

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Debian doesn't enable wireless iface

Postby banderas20 » 2017-02-10 14:21

Hi all,

I'm using Debian Jessie and I can't get WiFi card to work.

It's listed in lspci, in lshw and in /etc/network/interfaces. However, if I do
Code: Select all
rfkill list
0: hci0: Bluetooth
   Soft blocked: no
   Hard blocked: no
1: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no


lshw -C network

*-network
description: Ethernet interface
*-network DISABLED
description: Wireless interface


In GNOME the Wifi option is there, but greyed out.

¿Any help?

Thanks!
banderas20
 
Posts: 23
Joined: 2016-11-10 15:30

Re: Debian doesn't enable wireless iface

Postby bigrigdriver » 2017-02-10 16:06

Here is the HowTo setup wifi from the Debian wiki.
https://wiki.debian.org/WiFi/HowToUse
Registered GNU/Linux user #170078

Go as google before you ask on these boards.

It it isn't broken, Tweak It !!!
bigrigdriver
 
Posts: 106
Joined: 2014-09-01 17:04
Location: East Central Illinois, USA

Re: Debian doesn't enable wireless iface

Postby banderas20 » 2017-02-12 16:46

bigrigdriver wrote:Here is the HowTo setup wifi from the Debian wiki.
https://wiki.debian.org/WiFi/HowToUse


Thanks. I've already tried everything with no result.

If I run

iwlist scan

it displays a whole bunch of networks, which means the hardware is working properly.

The thing is my ssid is not broadcasted. I configure it in

Code: Select all
/etc/network/interfaces

auto wlan0
iface wlan0 inet dhcp
wpa-ssid my_SSID
wpa-psk hash_of_WPA
wpa-key-mgmt WPA-PSK



and in wpa_supplicant.conf as:

Code: Select all
network={
       ssid="my_SSID"
       psk=hash_of_WPA
       key_mgmt=WPA-PSK
       proto=WPA
       scan_ssid=1
 }


Then I make ifup wlan0

And still not working..

¿Any clue?

I want to remark that my SSID is NOT BROADCASTED.

Thanks!
banderas20
 
Posts: 23
Joined: 2016-11-10 15:30

Re: Debian doesn't enable wireless iface

Postby edbarx » 2017-02-13 06:38

So, your networking interfaces are recognised, but you cannot connect to a wifi hotspot. My suggestion is to comment the lines following "iface wlan0 inet dhcp". Keep security settings in wpa_supplicant.conf. I have discarded using ifupdown as it fails to connect to OPEN wifi hotspots. These days I use a low level method to connect except for wired connections that are excellently managed automatically by the operating system.

My method goes something like this:
Code: Select all
ifconfig wlan0 up
iwconfig wlan0 essid mycoolessid
wpa_supplicant -i wlan0 -B -c /path/to/wpa_supplicant.conf
dhclient -v wlan0


All the above require root privileges.
Debian == { > 30, 000 packages }; Debian != systemd
The worst infection of all, is a false sense of security!
It is hard to get away from CLI tools.
User avatar
edbarx
 
Posts: 5343
Joined: 2007-07-18 06:19
Location: 35° 50 N, 14 º 35 E

Re: Debian doesn't enable wireless iface

Postby Head_on_a_Stick » 2017-02-13 07:57

banderas20 wrote:
Code: Select all
wpa-psk hash_of_WPA

Please post the exact command that you used to generate this "hash_of_WPA", whatever that means.

Also, a wpa_supplicant configuration file is *not* needed for Debian's ifupdown connection method.

Finally, "hiding" your SSID does *not* improve security in any way whatsoever so you should probably stop that, if you can ;)
“Such is modern computing: everything simple is made too complicated because it’s easy to fiddle with; everything complicated stays complicated because it’s hard to fix." — Rob Pike

Please read before posting How to report a problem
User avatar
Head_on_a_Stick
 
Posts: 6378
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Debian doesn't enable wireless iface

Postby banderas20 » 2017-02-13 15:19

@edbarx

Thanks. I'll give it a go and provide feedback on the results.

@Head_on_a_Stick.

Sure! From https://wiki.debian.org/WiFi/HowToUse#wpa_supplicant

2. Use the WPA passphrase to calculate the correct WPA PSK hash for your SSID by altering the following example:

Code: Select all
$ wpa_passphrase myssid my_very_secret_passphrase


The above command gives the output:

Code: Select all
network={
        ssid="myssid"
        #psk="my_very_secret_passphrase"
        psk=ccb290fd4fe6b22935cbae31449e050edd02ad44627b16ce0151668f5f53c01b
}


you'll need to copy from "psk=" to the end of the line, to put in your /etc/network/interfaces file.


Thank you all.
banderas20
 
Posts: 23
Joined: 2016-11-10 15:30

Re: Debian doesn't enable wireless iface

Postby Head_on_a_Stick » 2017-02-14 20:46

Did you type in "wpa_passphrase myssid my_very_secret_passphrase" or did you use your actual SSID and password?

Have you tried broadcasting your SSID, as I suggested?

Your laptop will broadcast the SSID once it is connected so there really is no benefit to be had from "hiding" it.
“Such is modern computing: everything simple is made too complicated because it’s easy to fiddle with; everything complicated stays complicated because it’s hard to fix." — Rob Pike

Please read before posting How to report a problem
User avatar
Head_on_a_Stick
 
Posts: 6378
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Debian doesn't enable wireless iface

Postby banderas20 » 2017-02-17 13:14

Head_on_a_Stick wrote:Did you type in "wpa_passphrase myssid my_very_secret_passphrase" or did you use your actual SSID and password?

Have you tried broadcasting your SSID, as I suggested?

Your laptop will broadcast the SSID once it is connected so there really is no benefit to be had from "hiding" it.


I typed "wpa_passphrase myssid my_very_secret_passphrase" as the documentation states. I don't want to broadcast mi ssid. It's a personal issue by now.

@edbarx.

I have done as you have said and I have been able to achieve this:
Code: Select all
ifconfig
wlan0     Link encap:Ethernet  HWaddr [edited] 
          inet addr:192.168.1.150  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::de85:deff:fec5:98ca/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:7367 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5839 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:9514836 (9.0 MiB)  TX bytes:640368 (625.3 KiB)


But I still cannot access to network. If i set eth0 down, then I have no connectivity at all.

BTW, it's very strange that in

Code: Select all
/etc/network/interfaces

auto lo
iface lo inet loopback


I only have "lo". Nothing about eth0. But yet it works.
So I don't see eth0 but I have connectivity. I do see wlan0 but I can't connect.
I don't understant nothing at all. :( :( :(

BTW, i have two
Code: Select all
wpa_supplicant.conf
files
Code: Select all
/etc/dbus-1/system.d/wpa_supplicant.conf
/etc/wpa_supplicant/wpa_supplicant.conf


Thanks!

EDIT: Unplugged Ethernet cable and WiFi worked like a charm :evil: . ¿Why?
banderas20
 
Posts: 23
Joined: 2016-11-10 15:30


Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable