RTL8723BE & Deb8

Getting your soundcard to work, using Debian on non-i386 hardware, etc

RTL8723BE & Deb8

Postby wifiProblem » 2017-03-03 09:36

wifi signal is ridiculously weak even when sat next to wireless hub. It's also very intermittent. I'm running Debian Jessie.
The machine is a HP Pavilion 15-ak085na.

I have tried installing the updated driver found HERE, using the guide HERE and my system wouldn't boot up, ctrl+alt+f1 seemed to show a few lines of code being executed repeatedly. I booted a root shell (is it called rescue mode?) and executed make uninstall which allowed me to boot gui mode again. Phew!

I've also gleaned as much info from THIS TOPIC as possible with no luck :(

I executed
Code: Select all
wget -N -t 5 -T 10 https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info && \
chmod +x wireless-info && \
./wireless-info
Here is the wireless-info.txt output:
Code: Select all
########## wireless info START ##########

Report from: 03 Mar 2017 10:16 GMT +0000

Booted last: 03 Mar 2017 09:13 GMT +0000

Script from: 08 Jul 2016 02:16 UTC +0000

##### release ###########################

Distributor ID:   Debian
Description:   Debian GNU/Linux 8.7 (jessie)
Release:   8.7
Codename:   jessie

##### kernel ############################

Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u1 (2017-02-22) x86_64 unknown unknown GNU/Linux

Parameters: ro, quiet

##### desktop ###########################

default

##### lspci #############################

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
   Subsystem: Hewlett-Packard Company Device [103c:804c]
   Kernel driver in use: rtl8723be

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 0a)
   Subsystem: Hewlett-Packard Company Device [103c:8119]
   Kernel driver in use: r8169

##### lsusb #############################

Bus 002 Device 002: ID 8086:0a66 Intel Corp.
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0bda:b006 Realtek Semiconductor Corp.
Bus 001 Device 004: ID 154b:6000 PNY
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

'pccardctl' is not installed (package "pcmciautils").

##### rfkill ############################

./wireless-info: line 192: rfkill: command not found

##### lsmod #############################

wl                   6299053  0
rtl8723be              78818  0
btcoexist              49383  1 rtl8723be
rtl8723_common         17920  1 rtl8723be
rtl_pci                25947  1 rtl8723be
rtlwifi                54719  2 rtl_pci,rtl8723be
mac80211              482315  3 rtl_pci,rtlwifi,rtl8723be
hp_wmi                 13238  0
sparse_keymap          12818  1 hp_wmi
cfg80211              413730  3 wl,mac80211,rtlwifi
rfkill                 18867  6 cfg80211,hp_wmi,bluetooth
wmi                    17339  1 hp_wmi

##### interfaces ########################

source /etc/network/interfaces.d/*

auto lo
iface lo inet loopback

##### ifconfig ##########################

./wireless-info: line 202: ifconfig: command not found

##### iwconfig ##########################

./wireless-info: line 211: iwconfig: command not found

##### route #############################

./wireless-info: line 214: route: command not found

##### resolv.conf #######################

search lan
nameserver 192.168.1.1
nameserver fe80::1%eth0

##### network managers ##################

Installed:

   NetworkManager

Running:

root       679     1  0 09:13 ?        00:00:00 /usr/sbin/NetworkManager --no-daemon

##### NetworkManager info ###############

GENERAL.DEVICE:                         eth0
GENERAL.TYPE:                           ethernet
GENERAL.VENDOR:                         Realtek Semiconductor Co., Ltd.
GENERAL.PRODUCT:                        RTL8101E/RTL8102E PCI Express Fast Ethernet controller
GENERAL.DRIVER:                         r8169
GENERAL.DRIVER-VERSION:                 2.3LK-NAPI
GENERAL.FIRMWARE-VERSION:               
GENERAL.HWADDR:                         <MAC address>
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1c.6/0000:03:00.0/net/eth0
GENERAL.IP-IFACE:                       eth0
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.CONNECTION:                     Wired connection 1
GENERAL.CON-UUID:                       326f30cb-eda1-4912-9121-39de356340d1
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/2
CAPABILITIES.CARRIER-DETECT:            yes
CAPABILITIES.SPEED:                     100 Mb/s
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/{1}
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   326f30cb-eda1-4912-9121-39de356340d1 | Wired connection 1
WIRED-PROPERTIES.CARRIER:               on
IP4.ADDRESS[1]:                         ip = 192.168.1.7/24, gw = 192.168.1.1
IP4.ROUTE[1]:                           dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000
IP4.DNS[1]:                             192.168.1.1
IP4.DOMAIN[1]:                          lan
DHCP4.OPTION[1]:                        network_number = 192.168.1.0
DHCP4.OPTION[2]:                        requested_domain_search = 1
DHCP4.OPTION[3]:                        requested_host_name = 1
DHCP4.OPTION[4]:                        requested_time_offset = 1
DHCP4.OPTION[5]:                        requested_broadcast_address = 1
DHCP4.OPTION[6]:                        requested_domain_name = 1
DHCP4.OPTION[7]:                        requested_rfc3442_classless_static_routes = 1
DHCP4.OPTION[8]:                        requested_wpad = 1
DHCP4.OPTION[9]:                        expiry = 1488622601
DHCP4.OPTION[10]:                       next_server = 0.0.0.0
DHCP4.OPTION[11]:                       domain_name = lan
DHCP4.OPTION[12]:                       broadcast_address = 192.168.1.255
DHCP4.OPTION[13]:                       dhcp_message_type = 5
DHCP4.OPTION[14]:                       requested_subnet_mask = 1
DHCP4.OPTION[15]:                       routers = 192.168.1.1
DHCP4.OPTION[16]:                       ip_address = 192.168.1.7
DHCP4.OPTION[17]:                       dhcp_lease_time = 86400
DHCP4.OPTION[18]:                       requested_static_routes = 1
DHCP4.OPTION[19]:                       dhcp_renewal_time = 43200
DHCP4.OPTION[20]:                       requested_domain_name_servers = 1
DHCP4.OPTION[21]:                       subnet_mask = 255.255.255.0
DHCP4.OPTION[22]:                       dhcp_rebinding_time = 75600
DHCP4.OPTION[23]:                       domain_name_servers = 192.168.1.1 192.168.1.1
DHCP4.OPTION[24]:                       requested_netbios_name_servers = 1
DHCP4.OPTION[25]:                       requested_routers = 1
DHCP4.OPTION[26]:                       requested_ms_classless_static_routes = 1
DHCP4.OPTION[27]:                       requested_interface_mtu = 1
DHCP4.OPTION[28]:                       requested_ntp_servers = 1
DHCP4.OPTION[29]:                       requested_netbios_scope = 1
DHCP4.OPTION[30]:                       dhcp_server_identifier = 192.168.1.1
IP6.ADDRESS[1]:                         ip = fd60:e701:648e:b000:e958:14c:815:8abd/64, gw = ::
IP6.ADDRESS[2]:                         ip = fd60:e701:648e:b000:b25a:daff:fedb:5dab/64, gw = ::
IP6.ADDRESS[3]:                         ip = fe80::b25a:daff:fedb:5dab/64, gw = ::
IP6.ROUTE[1]:                           dst = fd60:e701:648e:b000::/64, nh = ::, mt = 1
IP6.DNS[1]:                             fe80::1
DHCP6.OPTION[1]:                        requested_dhcp6_domain_search = 1
DHCP6.OPTION[2]:                        dhcp6_name_servers = fe80::1
DHCP6.OPTION[3]:                        dhcp6_server_id = 0:1:0:1:12:cf:f7:8f:60:e7:1:64:8e:b0
DHCP6.OPTION[4]:                        requested_dhcp6_server_id = 1
DHCP6.OPTION[5]:                        requested_dhcp6_name_servers = 1
DHCP6.OPTION[6]:                        requested_dhcp6_client_id = 1
DHCP6.OPTION[7]:                        dhcp6_client_id = 0:4:a1:cb:f8:1f:fb:a9:7f:5f:75:b8:75:77:3b:e8:51:78

GENERAL.DEVICE:                         wlan0
GENERAL.TYPE:                           wifi
GENERAL.VENDOR:                         Realtek Semiconductor Co., Ltd.
GENERAL.PRODUCT:                        RTL8723BE PCIe Wireless Network Adapter
GENERAL.DRIVER:                         rtl8723be
GENERAL.DRIVER-VERSION:                 3.16.0-4-amd64
GENERAL.FIRMWARE-VERSION:               N/A
GENERAL.HWADDR:                         <MAC address>
GENERAL.MTU:                            1500
GENERAL.STATE:                          30 (disconnected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1c.5/0000:02:00.0/net/wlan0
GENERAL.IP-IFACE:                       
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.CONNECTION:                     --
GENERAL.CON-UUID:                       --
GENERAL.CON-PATH:                       --
CAPABILITIES.CARRIER-DETECT:            no
CAPABILITIES.SPEED:                     unknown
CONNECTIONS.AVAILABLE-CONNECTION-PATHS:
WIFI-PROPERTIES.WEP:                    yes
WIFI-PROPERTIES.WPA:                    yes
WIFI-PROPERTIES.WPA2:                   yes
WIFI-PROPERTIES.TKIP:                   yes
WIFI-PROPERTIES.CCMP:                   yes
WIFI-PROPERTIES.AP:                     yes
WIFI-PROPERTIES.ADHOC:                  yes

SSID  BSSID  MODE  CHAN  FREQ  RATE  SIGNAL  BARS  SECURITY  ACTIVE  *

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

##### NetworkManager.conf ###############

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/PRETTY-FLY-FOR-A-WIFI]] (600 root)
[connection] id=PRETTY-FLY-FOR-A-WIFI | type=wifi
[wifi] ssid=PRETTY-FLY-FOR-A-WIFI | mac-address=<MAC address>
[ipv4] method=auto
[ipv6] method=auto

##### iw reg get ########################

./wireless-info: line 282: iw: command not found

##### iwlist channels ###################

./wireless-info: line 293: iwlist: command not found

##### iwlist scan #######################

lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wlan0     No scan results

##### module infos ######################

./wireless-info: line 324: modinfo: command not found
[wl]

./wireless-info: line 324: modinfo: command not found
[rtl8723be]

./wireless-info: line 324: modinfo: command not found
[rtl8723_common]

./wireless-info: line 324: modinfo: command not found
[rtl_pci]

./wireless-info: line 324: modinfo: command not found
[rtlwifi]

./wireless-info: line 324: modinfo: command not found
[mac80211]

./wireless-info: line 324: modinfo: command not found
[cfg80211]

##### module parameters #################

[rtl8723be]
debug: 0
fwlps: N
ips: Y
msi: N
swenc: N
swlps: N

[mac80211]
beacon_loss_count: 7
ieee80211_default_rc_algo: minstrel_ht
max_nullfunc_tries: 2
max_probe_tries: 5
probe_wait_ms: 500

[cfg80211]
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

##### modprobe options ##################

[/etc/modprobe.d/amd64-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/broadcom-sta-dkms.conf]
blacklist b43
blacklist b43legacy
blacklist b44
blacklist bcma
blacklist brcm80211
blacklist brcmsmac
blacklist ssb

[/etc/modprobe.d/intel-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/modesetting.conf]
options cirrus modeset=1
options mgag200 modeset=1

[/etc/modprobe.d/open-vm-tools-dkms.conf]
install pcnet32 /sbin/modprobe -q --ignore-install vmxnet; /sbin/modprobe -q --ignore-install pcnet32 $CMDLINE_OPTS; /bin/true;

[/etc/modprobe.d/rtl8723be.conf]
options rtl8723be ant_sel=2 fwlps=0

##### rc.local ##########################

exit 0

##### pm-utils ##########################

find: `/etc/pm/*.d': No such file or directory

##### udev rules ########################

[/etc/udev/rules.d/70-persistent-net.rules]
# PCI device 0x10ec:0x8136 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC address>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
# PCI device 0x10ec:0xb723 (rtl8723be)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC address>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

##### dmesg #############################

[  350.124291] wlan0: associated
[  497.532860] wlan0: Connection to AP <MAC address> lost
[  499.017907] wlan0: authenticate with <MAC address>
[  499.037867] wlan0: send auth to <MAC address> (try 1/3)
[  499.043686] wlan0: authenticated
[  499.045488] wlan0: associate with <MAC address> (try 1/3)
[  499.072467] wlan0: RX AssocResp from <MAC address> (capab=0x411 status=0 aid=1)
[  499.072520] wlan0: associated
[  506.199537] wlan0: Connection to AP <MAC address> lost
[  507.648938] wlan0: authenticate with <MAC address>
[  507.668413] wlan0: send auth to <MAC address> (try 1/3)
[  507.670014] wlan0: authenticated
[  507.672137] wlan0: associate with <MAC address> (try 1/3)
[  507.675621] wlan0: RX AssocResp from <MAC address> (capab=0x411 status=0 aid=1)
[  507.675684] wlan0: associated
[  514.830200] wlan0: Connection to AP <MAC address> lost
[  516.303437] wlan0: authenticate with <MAC address>
[  516.323064] wlan0: send auth to <MAC address> (try 1/3)
[  516.325882] wlan0: authenticated
[  516.326789] wlan0: associate with <MAC address> (try 1/3)
[  516.330375] wlan0: RX AssocResp from <MAC address> (capab=0x411 status=0 aid=1)
[  516.330444] wlan0: associated
[  525.131078] wlan0: deauthenticated from <MAC address> (Reason: 7=CLASS3_FRAME_FROM_NONASSOC_STA)
[  525.210103] wlan0: authenticate with <MAC address>
[  525.220218] wlan0: send auth to <MAC address> (try 1/3)
[  525.222269] wlan0: authenticated
[  525.225443] wlan0: associate with <MAC address> (try 1/3)
[  525.233156] wlan0: RX AssocResp from <MAC address> (capab=0x411 status=0 aid=1)
[  525.233207] wlan0: associated
[  557.551451] wlan0: Connection to AP <MAC address> lost
[  565.328000] wlan0: authenticate with <MAC address>
[  565.347538] wlan0: direct probe to <MAC address> (try 1/3)
[  565.551198] wlan0: direct probe to <MAC address> (try 2/3)
[  565.755181] wlan0: direct probe to <MAC address> (try 3/3)
[  565.959168] wlan0: authentication with <MAC address> timed out
[  623.063161] r8169 0000:03:00.0 eth0: link up
[  623.063180] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 3801.978593] r8169 0000:03:00.0 eth0: link down
[ 3849.154068] r8169 0000:03:00.0 eth0: link up
[ 3849.154086] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

########## wireless info END ############


Please assist me, it really would be appreciated.

Thank you! :)

*edit* to the best of my knowledge the wifi adapter in Realtek rtl8723be */edit*

////////// UPDATE //////////
I had already turned off IPS, but wifi-info.txt shows it has been reactivated whilst i was messing around with the driver...

I exe'd $sudo tee /etc/modprobe.d/rtl8723be.conf <<< "options rtl8723be ips=N fwlps=N"

Now:
:~$ grep -R [[:graph:]] /sys/module/rtl8723be/parameters
/sys/module/rtl8723be/parameters/ips:N
/sys/module/rtl8723be/parameters/msi:N
/sys/module/rtl8723be/parameters/debug:0
/sys/module/rtl8723be/parameters/fwlps:N
/sys/module/rtl8723be/parameters/swenc:N
/sys/module/rtl8723be/parameters/swlps:N
wifiProblem
 
Posts: 6
Joined: 2017-03-03 08:46

Re: RTL8723BE & Deb8

Postby cronoik » 2017-03-03 14:59

I also had issue with that driver and as far as I can remeber, the issue is fixed in a newer version and for Debian 8 the following line in /etc/modprobe.d/rtl8723be.conf is enough:
Code: Select all
options rtl8723be swenc=1 fwlps=0 ips=0

No software update was required. It was just a default setting issue.
Have a nice day!
cronoik
 
Posts: 205
Joined: 2015-05-20 21:17

Re: RTL8723BE & Deb8

Postby wifiProblem » 2017-03-03 15:45

cronoik wrote:I also had issue with that driver and as far as I can remeber, the issue is fixed in a newer version and for Debian 8 the following line in /etc/modprobe.d/rtl8723be.conf is enough:
Code: Select all
options rtl8723be swenc=1 fwlps=0 ips=0

No software update was required. It was just a default setting issue.


Thank you for your advice, I have made the changes exactly as you specified but wifi on this machine is still unusable. :(

I am running the latest 'current' iso of debian with the non-free-firmware (unless a newer dist has been issued in the last 3-weeks.)

also have just run ~$ sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade
wifiProblem
 
Posts: 6
Joined: 2017-03-03 08:46

Re: RTL8723BE & Deb8

Postby Dai_trying » 2017-03-04 07:25

This seems to be a problem for many users, hopefully this will help.
Dai_trying
 
Posts: 276
Joined: 2016-01-07 12:25

Re: RTL8723BE & Deb8

Postby wifiProblem » 2017-03-04 11:30

Dai_trying wrote:This seems to be a problem for many users, hopefully this will help.

Dai_trying wrote:This seems to be a problem for many users, hopefully this will help.


Thank you so much for getting back to me :)

Unfortunately every time I try to install a new driver for the Wi-Fi I get the same problem:

I installed this driver using the following commands but can no longer start Debian in gui mode. Ctrl, alt and F1 shows what appears to be the same segment of code running repeatedly without ending.

change directory to rtlwifi_new
git pull
make
sudo make install
sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be

Please see the following YouTube video, which depicts the issue/code running repeatedly: https://youtu.be/oVCPxK8Ii9E


Thanks
wifiProblem
 
Posts: 6
Joined: 2017-03-03 08:46

Re: RTL8723BE & Deb8

Postby Dai_trying » 2017-03-05 09:48

I have a friend with this chipset and although he never had this kind of issue I had to change some settings to get it configured properly. He was suffering from occasional signal drops so I issued the command below and it stabilised the connection. It just sets a couple of options and if you try it and then want to remove it simply delete the file /etc/modprobe.d/rtl8723be.conf ( or remove the added info if you already have this file)
Code: Select all
echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf

This was after installing the firmware-realtek package.
I can see that the problem is different for you but it might be worth a try.
Dai_trying
 
Posts: 276
Joined: 2016-01-07 12:25

Re: RTL8723BE & Deb8

Postby wifiProblem » 2017-03-06 18:32

Dai_trying wrote:I have a friend with this chipset and although he never had this kind of issue I had to change some settings to get it configured properly. He was suffering from occasional signal drops so I issued the command below and it stabilised the connection. It just sets a couple of options and if you try it and then want to remove it simply delete the file /etc/modprobe.d/rtl8723be.conf ( or remove the added info if you already have this file)
Code: Select all
echo "options rtl8723be fwlps=N ips=N" | sudo tee /etc/modprobe.d/rtl8723be.conf

This was after installing the firmware-realtek package.
I can see that the problem is different for you but it might be worth a try.


Thank you for your response. :)

I have firmware-realtek installed and the contents of rtl8723be.conf is currently "options rtl8723be swenc=1 fwlps=0 ips=0"

Currently I am having to use my Pi's USB wifi adapter which is pretty crazy. The internal wifi doesn't work on my install disk (Jessie + non-free) in live mode, either. :(
wifiProblem
 
Posts: 6
Joined: 2017-03-03 08:46

Re: RTL8723BE & Deb8

Postby wifiProblem » 2017-03-09 08:13

Apologies for this bump. Does anybody have any idea what I am doing wrong?
wifiProblem
 
Posts: 6
Joined: 2017-03-03 08:46

Re: RTL8723BE & Deb8

Postby Dai_trying » 2017-03-09 09:29

have you tried a live-cd from a distro that ships non-free firmware? I would try Ubuntu/Q4OS/Mint and see if the live cd works properly and then while in the live session check what modules are loaded and versions to see if there are any clues...
Dai_trying
 
Posts: 276
Joined: 2016-01-07 12:25

Re: RTL8723BE & Deb8

Postby stevepusser » 2017-03-09 15:11

Your current driver uses "N" instead of "0" to set that parameter to off in the conf file. However, it might be better to upgrade the kernel from jessie-backports instead, to get the newer driver inside it, which will use your existing conf file instead. It could depend on your graphics hardware as to what would be best.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.3.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8345
Joined: 2009-10-06 05:53

Re: RTL8723BE & Deb8

Postby v&n » 2017-03-23 06:47

Hi,
My wifi skills have gone way too rusty, but couldn't resist my curiosity, so....

In the wifi report in your first post, these three caught my attention -
ips: Y
ant_sel=2 parameter in your /etc/modprobe.d/rtl8723be.conf file, and
existence of 'broadcom-sta-dkms.conf file

If you ran the 'tee /etm/modprobe.d....' command after generating the above report, it must have overwritten the conf file with the parameters we want. But I'm still curious about confirming the current status. Can you please generate that wireless-info report again and post it so we can see the current status?

The ant_sel=2 parameter raises some doubts in my mind. Which driver were/are you using? Which source? That parameter is not available for the default driver as far as I know (I'm not running any of the recent kernels to verify that, so I may be wrong).

The broadcom-sta-dkms.conf file gets generated if one tries to install the broadcom-sta-dkms driver. Since you don't seem to have any broadcom card in your computer, it indicates possibility of you blindly following random suggestions from the internet. If so, it might cause more errors than we may care to fix. Better start afresh.

Besides these, the existence of open-vm-tools... is also a little confusing to me, so please help me - You are not running this setup in a VM (virtual machine), are you?

And above all (even though I'm writing this at the bottom), as stevepusser recommended, you should trying upgrading the kernel to get newer driver. While we may try a few other things, I recall from somewhere that the 'weak signal' issue in some realtek drivers was a bug in some version, which was fixed in later versions.
v&n
 
Posts: 588
Joined: 2015-02-04 02:57


Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable