Disabling tap to click on Asus T200TA

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Disabling tap to click on Asus T200TA

Postby digitalfx » 2017-03-18 18:53

I have Debian Stretch working on my Asus T200TA and most things are working well after some configuration. One major issue for me is that I can't disable the tap to click on my touchpad. I tried setting Option "Tapping" "off" in 40-libinput.conf under every section, but it is still enabled. The XFCE mouse and touchpad settings don't show an option for tapping. I'm looking for suggestions on what else to try and any suggestions would be appreciated.
digitalfx
 
Posts: 9
Joined: 2017-03-18 18:47

Re: Disabling tap to click on Asus T200TA

Postby Head_on_a_Stick » 2017-03-18 18:57

digitalfx wrote:I tried setting Option "Tapping" "off" in 40-libinput.conf under every section, but it is still enabled.

Did you remember to copy /usr/share/X11/xorg.conf.d/40-libinput.conf to /etc/X11/xorg.conf.d/40-libinput.conf before editing the latter file?

Please post the full content (and location) of your 40-libinput.conf file.

I have no idea if XFCE honours /etc/X11/xorg.conf.d though.
“Controlling complexity is the essence of computer programming."Brian Kernighan

Please read before posting How to report a problem
User avatar
Head_on_a_Stick
 
Posts: 6491
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Disabling tap to click on Asus T200TA

Postby digitalfx » 2017-03-18 19:24

Yes, the file is in both locations. Here are the contents.

Section "InputClass"
Identifier "libinput pointer catchall"
MatchIsPointer "on"
MatchDevicePath "/dev/input/event*"
Driver "libinput"
Option "Tapping" "off"
EndSection

Section "InputClass"
Identifier "libinput keyboard catchall"
MatchIsKeyboard "on"
MatchDevicePath "/dev/input/event*"
Driver "libinput"
Option "Tapping" "off"
EndSection

Section "InputClass"
Identifier "libinput touchpad catchall"
MatchIsTouchpad "on"
MatchDevicePath "/dev/input/event*"
Driver "libinput"
Option "Tapping" "off"
Option "DisableWhileTyping" "on"
EndSection

Section "InputClass"
Identifier "libinput touchscreen catchall"
MatchIsTouchscreen "on"
MatchDevicePath "/dev/input/event*"
Driver "libinput"
Option "Tapping" "off"
EndSection

Section "InputClass"
Identifier "libinput tablet catchall"
MatchIsTablet "on"
MatchDevicePath "/dev/input/event*"
Driver "libinput"
Option "Tapping" "off"
EndSection
digitalfx
 
Posts: 9
Joined: 2017-03-18 18:47

Re: Disabling tap to click on Asus T200TA

Postby Head_on_a_Stick » 2017-03-18 19:46

Do you have xserver-xorg-input-synaptics installed?

My stretch system (Openbox/tint2) will use the synaptics driver automatically if it is installed and fall back to libinput otherwise.
“Controlling complexity is the essence of computer programming."Brian Kernighan

Please read before posting How to report a problem
User avatar
Head_on_a_Stick
 
Posts: 6491
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Disabling tap to click on Asus T200TA

Postby digitalfx » 2017-03-18 19:51

Hmm. Yes, I do. I will try removing it and report back.

Edit: No luck. Same issue with the package removed.
digitalfx
 
Posts: 9
Joined: 2017-03-18 18:47

Re: Disabling tap to click on Asus T200TA

Postby Head_on_a_Stick » 2017-03-18 20:07

Put the package back, remove /etc/X11/xorg.conf.d/40-libinput.conf, copy over 70-synaptic.conf to /etc/X11/xorg.conf.d and configure that instead.

I find synaptics to be far more configurable and user-friendly than libinput, at the moment anyway.
“Controlling complexity is the essence of computer programming."Brian Kernighan

Please read before posting How to report a problem
User avatar
Head_on_a_Stick
 
Posts: 6491
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Disabling tap to click on Asus T200TA

Postby digitalfx » 2017-03-18 20:25

I did as you said, but it appears that it's still using libinput (or something else is going on).

$ synclient -l
Couldn't find synaptics properties. No synaptics driver loaded?

Tap to click is still enabled and there are still no touchpad options in xfce.
digitalfx
 
Posts: 9
Joined: 2017-03-18 18:47

Re: Disabling tap to click on Asus T200TA

Postby stevepusser » 2017-03-18 20:32

I've found the touchpad-indicator package works well with the synaptics driver in Jessie-based MX Linux. I rebuilt the package from source to get them into the MX repo, but since it's a Python package, you should also be able to just install the PPA deb directly--use gdebi to do so, just so it can check it first.

http://ppa.launchpad.net/atareao/atarea ... indicator/

In its preferences, set the Option for one-finger tapping to "none".
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.3.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8339
Joined: 2009-10-06 05:53

Re: Disabling tap to click on Asus T200TA

Postby digitalfx » 2017-03-18 21:01

touchpad-indecator won't run. Lots of information in the console, but the most obvious and most common is "Couldn't find synaptics properties. No synaptics driver loaded?"
digitalfx
 
Posts: 9
Joined: 2017-03-18 18:47

Re: Disabling tap to click on Asus T200TA

Postby stevepusser » 2017-03-18 23:36

Libinput must be blocking it somehow. Maybe if you try a simulated (-s) removal of it to see how much fire & smoke comes out of the system?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.3.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8339
Joined: 2009-10-06 05:53

Re: Disabling tap to click on Asus T200TA

Postby digitalfx » 2017-03-19 00:43

Digging around some more it looks like the device is still using the libinput pointer driver. I commented the pointer section out of the config, and my touchpad just stopped working (not picked up by anything). Here is some info from my Xorg log about the device.

[ 31.633] (II) config/udev: Adding input device ASUSTek COMPUTER INC. ASUS Base Station. (/dev/input/event5)
[ 31.633] (**) ASUSTek COMPUTER INC. ASUS Base Station.: Applying InputClass "libinput pointer catchall"
[ 31.634] (II) Using input driver 'libinput' for 'ASUSTek COMPUTER INC. ASUS Base Station.'
[ 31.634] (**) ASUSTek COMPUTER INC. ASUS Base Station.: always reports core events
[ 31.634] (**) Option "Device" "/dev/input/event5"
[ 31.634] (**) Option "_source" "server/udev"
[ 31.693] (II) input device 'ASUSTek COMPUTER INC. ASUS Base Station.', /dev/input/event5 is tagged by udev as: Mouse
[ 31.694] (II) input device 'ASUSTek COMPUTER INC. ASUS Base Station.', /dev/input/event5 is a pointer caps
[ 31.748] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-3/1-3:1.2/0003:0B05:17E0.0003/input/input5/ev$
[ 31.748] (II) XINPUT: Adding extended input device "ASUSTek COMPUTER INC. ASUS Base Station." (type: MOUSE, id 12)
[ 31.750] (**) Option "AccelerationScheme" "none"
[ 31.750] (**) ASUSTek COMPUTER INC. ASUS Base Station.: (accel) selected scheme none/0
[ 31.750] (**) ASUSTek COMPUTER INC. ASUS Base Station.: (accel) acceleration factor: 2.000
[ 31.750] (**) ASUSTek COMPUTER INC. ASUS Base Station.: (accel) acceleration threshold: 4
[ 31.814] (II) input device 'ASUSTek COMPUTER INC. ASUS Base Station.', /dev/input/event5 is tagged by udev as: Mouse
[ 31.814] (II) input device 'ASUSTek COMPUTER INC. ASUS Base Station.', /dev/input/event5 is a pointer caps
[ 31.817] (II) config/udev: Adding input device ASUSTek COMPUTER INC. ASUS Base Station. (/dev/input/mouse0)
[ 31.818] (II) No input driver specified, ignoring this device.
[ 31.818] (II) This device may have been added with another device file.

Here is the information from xinput on the device.

$ xinput list-props 12
Device 'ASUSTek COMPUTER INC. ASUS Base Station.':
Device Enabled (139): 1
Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Accel Speed (278): 0.000000
libinput Accel Speed Default (279): 0.000000
libinput Accel Profiles Available (280): 1, 1
libinput Accel Profile Enabled (281): 1, 0
libinput Accel Profile Enabled Default (282): 1, 0
libinput Natural Scrolling Enabled (274): 0
libinput Natural Scrolling Enabled Default (275): 0
libinput Send Events Modes Available (259): 1, 0
libinput Send Events Mode Enabled (260): 0, 0
libinput Send Events Mode Enabled Default (261): 0, 0
libinput Left Handed Enabled (283): 0
libinput Left Handed Enabled Default (284): 0
libinput Scroll Methods Available (285): 0, 0, 1
libinput Scroll Method Enabled (286): 0, 0, 0
libinput Scroll Method Enabled Default (287): 0, 0, 0
libinput Button Scrolling Button (288): 0
libinput Button Scrolling Button Default (289): 0
Device Node (262): "/dev/input/event5"
Device Product ID (263): 2821, 6112
libinput Drag Lock Buttons (276): 0
libinput Horizontal Scroll Enabled (277): 1

I verified this is the correct device by disabling it and making sure my touchpad stopped responding. There is no mention of anything that looks like it would affect tapping anywhere.
digitalfx
 
Posts: 9
Joined: 2017-03-18 18:47

Re: Disabling tap to click on Asus T200TA

Postby Head_on_a_Stick » 2017-03-19 09:39

Please post the output of:
Code: Select all
cat /etc/X11/xorg.conf.d/*

I have an openbox/tint2 desktop in stretch and the synaptics driver is used automatically if it is installed; my configuration is blank:
Code: Select all
Helium: ~ $ cat /etc/X11/xorg.conf.d/*
cat: '/etc/X11/xorg.conf.d/*': No such file or directory
Helium: ~ $

I've only tried GNOME in stretch otherwise so I'm not sure how XFCE is handling the libinput switch.
“Controlling complexity is the essence of computer programming."Brian Kernighan

Please read before posting How to report a problem
User avatar
Head_on_a_Stick
 
Posts: 6491
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Disabling tap to click on Asus T200TA

Postby digitalfx » 2017-03-19 16:38

Section "InputClass"
Identifier "touchpad catchall"
Driver "synaptics"
MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-t ... rrors.html
# MatchDevicePath "/dev/input/event*"
EndSection

Section "InputClass"
Identifier "touchpad ignore duplicates"
MatchIsTouchpad "on"
MatchOS "Linux"
MatchDevicePath "/dev/input/mouse*"
Option "Ignore" "on"
EndSection

# This option enables the bottom right corner to be a right button on clickpads
# and the right and middle top areas to be right / middle buttons on clickpads
# with a top button area.
# This option is only interpreted by clickpads.
Section "InputClass"
Identifier "Default clickpad buttons"
MatchDriver "synaptics"
Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
Option "SecondarySoftButtonAreas" "58% 0 0 15% 42% 58% 0 15%"
EndSection

# This option disables software buttons on Apple touchpads.
# This option is only interpreted by clickpads.
Section "InputClass"
Identifier "Disable clickpad buttons on Apple touchpads"
MatchProduct "Apple|bcm5974"
MatchDriver "synaptics"
Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
EndSection
digitalfx
 
Posts: 9
Joined: 2017-03-18 18:47

Re: Disabling tap to click on Asus T200TA

Postby Head_on_a_Stick » 2017-03-19 18:08

Well, that must mean that XFCE isn't honouring /etc/X11/xorg.conf.d at all.

There must be some desktop-specific method that I am unaware of.

You could post the Xorg log but please use code tags when posting logs & terminal output, it is *much* more readable.
“Controlling complexity is the essence of computer programming."Brian Kernighan

Please read before posting How to report a problem
User avatar
Head_on_a_Stick
 
Posts: 6491
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Disabling tap to click on Asus T200TA

Postby digitalfx » 2017-03-19 22:55

Is there anything specific you are looking for in the logs so that I can limit my reply? I did do some digging and testing after I posted some of the Xorg log above and it looks like my touchpad is being detected as a pointer in libinput and seems to be seen as a generic HID device. I tried adding the following to /etc/X11/xorg.conf.d/70-synaptics.conf.
Code: Select all
Section "InputClass"
        Identifier "pointer catchall"
        Driver "synaptics"
        MatchIsPointer "on"
EndSection

When I did that, my touchpad was loaded with the synaptics driver, but it did not function at all.
digitalfx
 
Posts: 9
Joined: 2017-03-18 18:47

Next

Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest

fashionable