Problem with Wifi

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Problem with Wifi

Postby dcihon » 2017-04-09 13:58

I know you guys have seen a million requests for Wifi issues.
But I have one that I can't find the answer for.
I am running Debian Stretch.
Here is my wifi hardware:
Code: Select all
03:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

Here is my system info:
Code: Select all
Machine:   Device: desktop System: Dell product: Inspiron 3650 v: X00 Chassis: type: 3
           Mobo: Dell model: 0C2XKD v: A01 UEFI [Legacy]: Dell v: 3.3.10 date: 03/15/2017
CPU:       Quad core Intel Core i7-6700 (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27264
           clock speeds: min/max: 800/4000 MHz 1: 3876 MHz 2: 3796 MHz 3: 3835 MHz 4: 3818 MHz 5: 3856 MHz
           6: 3928 MHz 7: 3900 MHz 8: 3900 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM]
           bus-ID: 01:00.0 chip-ID: 1002:665f
           Display Server: X.Org 1.19.2 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on AMD BONAIRE (DRM 2.48.0 / 4.9.0-2-amd64, LLVM 3.9.1)
           GLX Version: 3.0 Mesa 13.0.6 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] Tobago HDMI Audio [Radeon R7 360 / R9 360 OEM]
           driver: snd_hda_intel bus-ID: 01:00.1 chip-ID: 1002:aac0
           Card-2 Intel Sunrise Point-H HD Audio driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:a170
           Card-3 Logitech Webcam C270 driver: USB Audio usb-ID: 001-005 chip-ID: 046d:0825
           Sound: Advanced Linux Sound Architecture v: k4.9.0-2-amd64
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168
           IF: enp2s0 state: down mac: 48:4d:7e:9f:4d:2f
           Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
           driver: ath9k bus-ID: 03:00.0 chip-ID: 168c:0036
           IF: wlp3s0 state: up mac: 90:cd:b6:50:f6:2d
           Card-3: Qualcomm Atheros usb-ID: 001-006 chip-ID: 0cf3:e005
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 2000.4GB (11.1% used)
           ID-1: /dev/sda model: ST2000DM001 size: 2000.4GB serial: Z4Z6SQWW
Partition: ID-1: / size: 59G used: 13G (24%) fs: ext4 dev: /dev/sda7
           ID-2: /home size: 1.3T used: 179G (15%) fs: ext4 dev: /dev/sda8
           ID-3: swap-1 size: 17.18GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 51.0
           Fan Speeds (in rpm): cpu: 802 fan-1: 819
Info:      Processes: 258 Uptime: 51 min Memory: 911.9/15994.9MB
           Init: systemd v: 232 runlevel: 5 default: 2 Gcc sys: 6.3.0 alt: 4.9/5
           Client: Shell (bash 4.4.111 running in mate-terminal) inxi: 2.3.5

My problem is that when I start up the computer wifi is turned off.
I have tracked it down to RFKill
It shows this when it starts:
Code: Select all
rfkill list all
0: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

I am right now using wicd and after I log in I launch wicd
turn on the wireless and refresh the list and connect to my wifi.
Thanks
Dan
I hope someone here is nice enough to give me a little assistance.
I will try whatever you can come up with to help.
I know there are a bunch of very smart Debian users here.
Thanks again.
dcihon
 
Posts: 99
Joined: 2012-09-23 16:18

Re: Problem with Wifi

Postby bw123 » 2017-04-09 14:28

there is another thread about similar problem with bluetooth here.
viewtopic.php?f=30&t=132615

and I did a quick search and suggested reading the arch forum links, like this one.
https://bbs.archlinux.org/viewtopic.php?id=169503

I think I'd start by looking in dmesg for the RF_KILL or radio disabled message from the driver and try tweaking it, if that fails maybe tweaking the rfkill module.
Code: Select all
# modinfo -p rfkill
master_switch_mode:SW_RFKILL_ALL ON should: 0=do nothing (only unlock); 1=restore; 2=unblock all (uint)
default_state:Default initial state for all radio types, 0 = radio off (uint)


I don't think debian has the rfkill-unblock systemd unit discussed in the thread? I suppose you could make one, but personally I don't like the idea of running to systemd to fix every hangnail.

I know there are a bunch of very smart Debian users here.


haha, you'll do well on here with flattery, but seriously we're all frustrated by one thing or another it seems like. If you fix your issue, please mark it solved and share the solution?
thanks.
User avatar
bw123
 
Posts: 2411
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Problem with Wifi

Postby stevepusser » 2017-04-09 17:19

If Wicd is getting the wi-fi to work, can't you just have it autostart? I haven't used it for a while, but it was my understanding that it autostarted by default, anyway.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8905
Joined: 2009-10-06 05:53

Re: Problem with Wifi

Postby debiman » 2017-04-09 17:28

dcihon wrote:I have tracked it down to RFKill
It shows this when it starts:
Code: Select all
rfkill list all
0: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

you're in luck, that "yes" can easily be turned into a "no" programmatically.
iirc, just issue (as root) 'rfkill unblock all'.

there might be a systemd service unit that does that automatically, but you could also add it to your autostart/startup applications.
User avatar
debiman
 
Posts: 1545
Joined: 2013-03-12 07:18


Return to Hardware

Who is online

Users browsing this forum: eoandeb and 4 guests

fashionable