No sound from speakers (OK through headphones)

Getting your soundcard to work, using Debian on non-i386 hardware, etc

No sound from speakers (OK through headphones)

Postby littlebigman » 2017-04-10 08:02


I'm running LXDE Debian 8.7 on an Asus 1001PXD notebook.

Sound plays fine through headphones but I get no sound through the built-in speakers. Google didn't help so far, and am reluctant to try things for other distros in case I make things worse.

Here's some infos:
Code: Select all
Alsa Mixer just says "Card: PulseAudio" and "Chip: PulseAudio". There are no menus I could open.

# cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xf7cf8000 irq 44
# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

# lshw
Intel NM10/ICH7
   description: Audio device
   product: NM10/ICH7 Family High Definition Audio Controller
   vendor: Intel Corporation
   physical id: 1b
   bus info: pci@0000:00:1b.0
   version: 02
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list
   configuration: driver=snd_hda_intel latency=0
   resources: irq:44 memory:f7cf8000-f7cfbfff

# cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version k3.16.0-4-amd64.

# head -n 1 /proc/asound/card*/codec#*
Codec: Realtek ALC269VB

# dpkg -l | grep "alsa"
ii  alsa-base                             1.0.27+1                             all          dummy package to ease purging of obsolete conffiles
ii  alsa-utils                            1.0.28-1                             amd64        Utilities for configuring and using ALSA
ii  alsamixergui                          0.9.0rc2-1-9.1                       amd64        graphical soundcard mixer for ALSA soundcard driver
ii  xmms2-plugin-alsa                     0.8+dfsg-12                          amd64        XMMS2 - ALSA output

Any idea what I could try?

Thank you.

Edit: Posts on the net seem to say that the issue could come from the fact that this audio chip is incorrectly reported as from Intel while it's actually from Realtek:
Code: Select all
# head -n 1 /proc/asound/card*/codec#*

Codec: Realtek ALC269VB

I also tried creating a .asoundrc file, but still no sound:
Code: Select all
# aplay -L

    HDA Intel, ALC269VB Analog
    Front speakers

# echo 'pcm.!default front:Intel' > ~/.asoundrc

# aplay ./acme.mp3
Playing raw data './acme.mp3' : Unsigned 8 bit, Rate 8000 Hz, Mono
aplay: set_params:1233: Sample format non available
Available formats:
- S16_LE
- S32_LE
Posts: 15
Joined: 2008-01-16 21:30

Re: No sound from speakers (OK through headphones)

Postby lbuiyzxl » 2017-06-09 13:56

Seem alsa-XXX package is not powerful for multi-sound case
Maybe you can try uninstall alsa-XXX package then install "pavucontrol" to replace it
I'm sorry for my bad English skills
I'm don't want to be a nuisance.
Posts: 66
Joined: 2017-05-11 08:35

Re: No sound from speakers (OK through headphones)

Postby phenest » 2017-06-09 14:09

Have you tried alsamixer? Maybe the speakers (or another channel) are muted?
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS Sabertooth P67 i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
Posts: 1571
Joined: 2010-03-09 09:38
Location: The Matrix

Return to Hardware

Who is online

Users browsing this forum: No registered users and 4 guests