[SOLVED]Stretch, CPU on maximum frequency most the time.

Getting your soundcard to work, using Debian on non-i386 hardware, etc

[SOLVED]Stretch, CPU on maximum frequency most the time.

Postby floreado » 2017-04-24 17:24

Hi,

On Debian 9, my CPU sticks to max frequency, it means 1,70 GHz, no more, no less.
It occurs when I play any mp4, youtube, etc. via internet, even under HTML5.
This occurs only on Debian, on every other distro I tried (Kubuntu, Netrunner, Suse, Centos, Rosa) i
t changes values all the time between 800 Hz and 2,7 GHz even when I play film online but not on Debian.
Is it normal behaviour?

Code: Select all
cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 69
model name      : Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz
stepping        : 1
microcode       : 0x1c
cpu MHz         : 1694.238
cache size      : 3072 KB
physical id     : 0
siblings        : 4
core id         : 0
cpu cores       : 2
apicid          : 0
initial apicid  : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm epb tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid xsaveopt dtherm ida arat pln pts
bugs            :
bogomips        : 4789.13
clflush size    : 64
cache_alignment : 64
address sizes   : 39 bits physical, 48 bits virtual
power management:

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 69
model name      : Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz
stepping        : 1
microcode       : 0x1c
cpu MHz         : 1694.824
cache size      : 3072 KB
physical id     : 0
siblings        : 4
core id         : 0
cpu cores       : 2
apicid          : 1
initial apicid  : 1
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm epb tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid xsaveopt dtherm ida arat pln pts
bugs            :
bogomips        : 4791.02
clflush size    : 64
cache_alignment : 64
address sizes   : 39 bits physical, 48 bits virtual
power management:

processor       : 2
vendor_id       : GenuineIntel
cpu family      : 6
model           : 69
model name      : Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz
stepping        : 1
microcode       : 0x1c
cpu MHz         : 1890.527
cache size      : 3072 KB
physical id     : 0
siblings        : 4
core id         : 1
cpu cores       : 2
apicid          : 2
initial apicid  : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm epb tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid xsaveopt dtherm ida arat pln pts
bugs            :
bogomips        : 4790.61
clflush size    : 64
cache_alignment : 64
address sizes   : 39 bits physical, 48 bits virtual
power management:

processor       : 3
vendor_id       : GenuineIntel
cpu family      : 6
model           : 69
model name      : Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz
stepping        : 1
microcode       : 0x1c
cpu MHz         : 1700.244
cache size      : 3072 KB
physical id     : 0
siblings        : 4
core id         : 1
cpu cores       : 2
apicid          : 3
initial apicid  : 3
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm epb tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid xsaveopt dtherm ida arat pln pts
bugs            :
bogomips        : 4790.55
clflush size    : 64
cache_alignment : 64
address sizes   : 39 bits physical, 48 bits virtual
power management:


Code: Select all
uname -a
Linux debian 4.9.0-2-amd64 #1 SMP Debian 4.9.18-1 (2017-03-30) x86_64 GNU/Linux
Last edited by floreado on 2017-05-02 17:44, edited 1 time in total.
floreado
 
Posts: 62
Joined: 2016-01-26 18:15

Re: Stretch, CPU on maximum frequency most the time.

Postby phenest » 2017-04-24 17:35

floreado wrote:On Debian 9, my CPU sticks to max frequency

What about Debian 8? Debian 9 is not yet a stable release.
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS Sabertooth P67 i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1571
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Stretch, CPU on maximum frequency most the time.

Postby floreado » 2017-04-24 18:46

On Debian 8 it works good,like on other distros but in Jessie is not used intel_pstate as far as I know.
I thought that maybe it's because of intel_pstate. I want use Stretch becasue for example Jessie does not recognize my phone when it's pugged to the computer.
floreado
 
Posts: 62
Joined: 2016-01-26 18:15

Re: Stretch, CPU on maximum frequency most the time.

Postby phenest » 2017-04-24 19:01

You could report a bug.
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS Sabertooth P67 i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1571
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Stretch, CPU on maximum frequency most the time.

Postby Dai_trying » 2017-04-24 19:01

You could install cpufrequtils to give some information regarding cpu speeds, governors etc, you can also use it to set the policy powersave/performance. It might help...
Dai_trying
 
Posts: 292
Joined: 2016-01-07 12:25

Re: Stretch, CPU on maximum frequency most the time.

Postby phenest » 2017-04-24 19:09

NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS Sabertooth P67 i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1571
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Stretch, CPU on maximum frequency most the time.

Postby stevepusser » 2017-04-24 22:00

The Liquorix 4.9 kernels were using the more standard cpufreq governors plus schedutil for recent Intel processors, but then went back to p-state for the new 4.10 kernel. The 4.9 kernel is still available (for now) in the Liquorix repository if you want to try it and see if you can detect any differences.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8419
Joined: 2009-10-06 05:53

Re: Stretch, CPU on maximum frequency most the time.

Postby floreado » 2017-05-02 17:44

Hi,

I didn't put any output of cpufreq-info because it's default one,
I didn't change nothing, governor: powersave on intel_pstate driver.
I tried the newest Rosa with 4.9 and the situatin is the same so I think that is the kernel which cause this.
It was a bad decision to not to wait for Linux 4.10, everything works very fine on Kubuntu 17.04 with this kernel.
CPU frequency changes all the time, no matter I play a film on line or not. That's how CPU scaling has to look like.
I doubt this error will be fixed until final release of Stretch.
floreado
 
Posts: 62
Joined: 2016-01-26 18:15

Re: [SOLVED]Stretch, CPU on maximum frequency most the time.

Postby mystique » 2017-05-05 15:54

linux-image-4.9.0-23.1-liquorix-amd64
cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_available_governors
conservative userspace powersave ondemand performance schedutil

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
ondemand

cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
driver: acpi-cpufreq
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: 10.0 us.
hardware limits: 1.60 GHz - 3.40 GHz
available frequency steps: 3.40 GHz, 3.40 GHz, 3.20 GHz, 3.00 GHz, 2.80 GHz, 2.60 GHz, 2.40 GHz, 2.20 GHz, 2.00 GHz, 1.80 GHz, 1.60 GHz
available cpufreq governors: conservative, userspace, powersave, ondemand, performance, schedutil
current policy: frequency should be within 1.60 GHz and 3.40 GHz.
The governor "ondemand" may decide which speed to use
within this range.
current CPU frequency is 1.60 GHz.


linux-image-4.10.0-14.1-liquorix-amd64
cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_available_governors
performance powersave

cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
powersave

cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
driver: intel_pstate
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: 0.97 ms.
hardware limits: 1.60 GHz - 3.80 GHz
available cpufreq governors: performance, powersave
current policy: frequency should be within 1.60 GHz and 3.80 GHz.
The governor "powersave" may decide which speed to use
within this range.
current CPU frequency is 1.60 GHz.

My ESXI and Physical Debian systems run with a 1.0 load constantly on the 4.10 kernels.

So I've rolled back systems to the 4.9.0-23 liquorix kernels in past..

I posted in liquorix forum as well.. no answer there either..
mystique
 
Posts: 1
Joined: 2017-05-05 15:36

Re: [SOLVED]Stretch, CPU on maximum frequency most the time.

Postby stevepusser » 2017-05-05 21:35

Also posted in the Liquorix forum:

just boot with the kernel cheat

intel_pstate=disabled

and the kernel falls back to cpufreq cpu scaling.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.0, Liquorix kernel 4.11-9, mpv 0.25.0, Kodi 17.3, Ksnip 1.3.1, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8419
Joined: 2009-10-06 05:53


Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable