WoL - Compaq 6710b

Getting your soundcard to work, using Debian on non-i386 hardware, etc

WoL - Compaq 6710b

Postby Roken » 2017-04-30 15:13

Hi all, been a while since I had to post, but this has me stumped, now.

My main rig is running Arch (testing if it matters), and the laptop (HP Compaq 6710b) is running Debian Jessie (I think, whatever the latest is) on non-testing.

I have Synergy setup and working so that I can control the laptop (pre-login and onwards) from my main rig. Now, I prefer to keep the laptop closed and tucked away. It's plugged in to an external monitor, so being able to power on via LAN would be the final, no nonsense approach to my setup, but whatever I try, it doesn't work.

A bit of research tells me that WoL is only supported from standby or hibernate, but even that isn't working. This means I have to dig the laptop out to power up. Being bone idle, I'd rather just fire of a magic packet and be done with it.

I've tried everything suggested on the Debian Wiki, and out of desperation, went to the Arch Wiki and created the systemd units etc. Still, none of etherwake, wol or wakeonlan will wake the damned thing up.

So over to you - any ideas?

TIA

EDIT: If it's relevant, I'm a UK user on BT, with a HH5, single ethernet cable coming out of the router into a Netgear switch. Both the main rig and the laptop are wired to the switch. I'm not looking for WowLAN, just WoL. Also not looking for over the internet, just on the LAN.

EDIT2: It's not an issue with the Arch machine sending the packet. Wake also fails from my phone using WakeOnLan in Android.
Roken
 
Posts: 76
Joined: 2011-02-06 01:12

Re: WoL - Compaq 6710b

Postby Dai_trying » 2017-04-30 20:08

This might be too obvious and already checked, but have you enabled WOL in the BIOS? I use WOL occasionally (just on upstairs machine) and it worked first time I set it up (after changing bios) and never had reason to change anything.
Dai_trying
 
Posts: 318
Joined: 2016-01-07 12:25

Re: WoL - Compaq 6710b

Postby Roken » 2017-05-01 03:24

Yes, it's enabled in the BIOS.

I can honestly think of no reason why it isn't working, it's just not.
Roken
 
Posts: 76
Joined: 2011-02-06 01:12

Re: WoL - Compaq 6710b

Postby Dai_trying » 2017-05-01 06:47

I can only suggest checking the Debian wiki instructions for anything you might have missed.

Also if you are keeping the lid closed this might be stopping the laptop from powering up, I had this problem with a laptop running mythbuntu (PVR) with external monitor and had to modify (uncomment) the line to read HandleLidSwitch=ignore in /etc/systemd/logind.conf.
Dai_trying
 
Posts: 318
Joined: 2016-01-07 12:25

Re: WoL - Compaq 6710b

Postby Roken » 2017-05-01 08:05

I'll keep the lid issue in mind when I get it going, but at the moment it's not working even with the lid open.

As additional info (just checked this). After a system shutdown and normal boot, ethtool eth0 shows everything is fine, but after suspend and resume, wol is getting disabled.

I've tried all the tricks in the wiki, but have had to adapt for my H/W so maybe I'm getting something wrong. The driver here is tg3, so if any knowledgeable guys can shed some light on translating the wiki to this, that may help.
Roken
 
Posts: 76
Joined: 2011-02-06 01:12

Re: WoL - Compaq 6710b

Postby Dai_trying » 2017-05-01 09:48

I just did a quick search and found this ubuntu forum post which might help, it could be somethig to do with preventing the network manager from sleeping and therefore allowing wol to work. Might need some adjusting as it is from Ubuntu, but could help point you in the right direction.
Dai_trying
 
Posts: 318
Joined: 2016-01-07 12:25

Re: WoL - Compaq 6710b

Postby Head_on_a_Stick » 2017-05-01 10:06

Hey Roken, good to see you here :)
Roken wrote:After a system shutdown and normal boot, ethtool eth0 shows everything is fine, but after suspend and resume, wol is getting disabled.

I think we need to see the journal contents for the suspend and resume cycle.
"Are you quite sure that all those bells and whistles, all those wonderful facilities of your so called powerful programming languages, belong to the solution set rather than the problem set?" — Edsger W. Dijkstra
User avatar
Head_on_a_Stick
 
Posts: 6585
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: WoL - Compaq 6710b

Postby Roken » 2017-05-01 15:28

Which logs do you want. Happy to provide any.
Roken
 
Posts: 76
Joined: 2011-02-06 01:12

Re: WoL - Compaq 6710b

Postby Head_on_a_Stick » 2017-05-01 17:23

I like to use journalctl(1)

The --since= flag will help filter the output ;)
"Are you quite sure that all those bells and whistles, all those wonderful facilities of your so called powerful programming languages, belong to the solution set rather than the problem set?" — Edsger W. Dijkstra
User avatar
Head_on_a_Stick
 
Posts: 6585
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: WoL - Compaq 6710b

Postby Roken » 2017-05-01 19:12

OK, there's a lot of it. Restricted to a clean boot, suspend and resume:

https://pastebin.com/axSLMU1U
Roken
 
Posts: 76
Joined: 2011-02-06 01:12

Re: WoL - Compaq 6710b

Postby Head_on_a_Stick » 2017-05-01 19:27

Looks like you're using pm-utils to suspend, try https://ubuntuforums.org/showthread.php ... st11075475

Otherwise, does your WoL setting persist if you suspend with
Code: Select all
systemctl suspend

Also, please post the full content of /etc/network/interfaces
"Are you quite sure that all those bells and whistles, all those wonderful facilities of your so called powerful programming languages, belong to the solution set rather than the problem set?" — Edsger W. Dijkstra
User avatar
Head_on_a_Stick
 
Posts: 6585
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: WoL - Compaq 6710b

Postby Roken » 2017-05-01 20:43

That's how I have been suspending.

Also tried with pm-utils with the same result.
Code: Select all
cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback
iface eth0 inet dhcp
   up /sbin/ethtool -s $IFACE wol g
Roken
 
Posts: 76
Joined: 2011-02-06 01:12

Re: WoL - Compaq 6710b

Postby Head_on_a_Stick » 2017-05-02 05:44

Try adding this line to /etc/network/interfaces:
Code: Select all
auto eth0
"Are you quite sure that all those bells and whistles, all those wonderful facilities of your so called powerful programming languages, belong to the solution set rather than the problem set?" — Edsger W. Dijkstra
User avatar
Head_on_a_Stick
 
Posts: 6585
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: WoL - Compaq 6710b

Postby Roken » 2017-05-02 17:43

Sorry for the delay - work got in the way.

No different. Doesn't WoL and resuming from suspend with the button still shows WoL got disabled on the suspend :(
Roken
 
Posts: 76
Joined: 2011-02-06 01:12

Re: WoL - Compaq 6710b

Postby Head_on_a_Stick » 2017-05-03 05:48

Some clues in this thread:

https://ubuntuforums.org/showthread.php?t=2235571

Looks like it may be a firmware issue.
"Are you quite sure that all those bells and whistles, all those wonderful facilities of your so called powerful programming languages, belong to the solution set rather than the problem set?" — Edsger W. Dijkstra
User avatar
Head_on_a_Stick
 
Posts: 6585
Joined: 2014-06-01 17:46
Location: /dev/chair

Next

Return to Hardware

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable