Debian Stretch AMDGPU-PRO doesn't work

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Debian Stretch AMDGPU-PRO doesn't work

Postby kuba67 » 2017-05-04 12:53

I have MSI RX480 4GB and I just installed Debian Stretch on kernel 4.9.0-2-amd64 with MATE DE ( when I previously was trying to install with GNOME I couldn't boot the system after installation ).

To install AMDGPU-PRO I had to change in the installation file word 'ubuntu' to 'debian' and install libssl1.0.0 from jessie-backports repositories. The installation succeeded, I didn't have any troubles after rebooting and when I type:
Code: Select all
dpkg -l amdgpu-pro

I get:
Code: Select all
Wybór:U=nieznany/I=instalacja/R=usunięcie/P=wyczyszczenie/H=zatrzymanie
| Stan:N=brak/I=zainstalowany/C=skonfigurowany/U=rozpakowany/
|/  F=częśc. skonfigurowany/H=częśc. zainstalowany/W=wyzw. czek./T=wyzw. zapl.
|| Błędy?=(brak)/R-do pon. inst. (duże litery w "Stan" i "Błędy"=problemy)
||/ Nazwa          Wersja       Architektura Opis
+++-==============-============-============-=================================
ii  amdgpu-pro     17.10-414273 amd64        Meta package to install amdgpu Pr


( Polish translation )



But despite that I couldn't get any signs that it actually worked. I tried fixing screen tearing with adding 20-radeon.conf file to /usr/share/X11/xorg.conf.d/ :
Code: Select all
Section "Device"
    Identifier "Radeon"
    Driver "radeon"
    Option "TearFree" "on"
EndSection

And after rebooting system couldn't load lightDM. Same happened when I added 01-amdgpu-pro.conf to the same directory:
Code: Select all
ection "Device"
Identifier  "Card0"
Driver      "amdgpu"
BusID       "PCI:1:0:0"
Option      "DRI3" "1"
Option "TearFree" "on"
EndSection

Previously, when I had other distro installed, I had no issues with screen-tearing fix, after installation of prpietary drivers.
Moreover, the system doesn't recognize my monitor or my monitor's frequency.


And I can't use my built in monitor speakers either... When I go to System -> Preferences -> Hardware -> Sound the profile of my HDA ATI HDMI is set to turned off and I can't change it.

So it looks like despite being installed, amdgpu-pro isn't used. Do you guys hav any ideas how to fix it?

After typing
Code: Select all
sudo lspci -v
I got:
Code: Select all
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480] (rev c7) (prog-if 00 [VGA controller])
   Subsystem: Micro-Star International Co., Ltd. [MSI] Radeon RX 480
   Flags: bus master, fast devsel, latency 0, IRQ 11
   Memory at c0000000 (64-bit, prefetchable) [size=256M]
   Memory at d0000000 (64-bit, prefetchable) [size=2M]
   I/O ports at e000 [size=256]
   Memory at dfe00000 (32-bit, non-prefetchable) [size=256K]
   Expansion ROM at 000c0000 [disabled] [size=128K]
   Capabilities: [48] Vendor Specific Information: Len=08 <?>
   Capabilities: [50] Power Management version 3
   Capabilities: [58] Express Legacy Endpoint, MSI 00
   Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
   Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
   Capabilities: [150] Advanced Error Reporting
   Capabilities: [200] #15
   Capabilities: [270] #19
   Capabilities: [2b0] Address Translation Service (ATS)
   Capabilities: [2c0] Page Request Interface (PRI)
   Capabilities: [2d0] Process Address Space ID (PASID)
   Capabilities: [320] Latency Tolerance Reporting
   Capabilities: [328] Alternative Routing-ID Interpretation (ARI)
   Capabilities: [370] L1 PM Substates
   Kernel modules: amdgpu
Last edited by kuba67 on 2017-05-04 13:37, edited 4 times in total.
kuba67
 
Posts: 3
Joined: 2017-05-04 12:14

Re: Debian Stretch AMDGPU-PRO doesn't work

Postby kuba67 » 2017-05-04 13:02

Oh and here some mooooooo outputs:
Code: Select all
$ inxi -Fxz
System:    Host: debian Kernel: 4.9.0-2-amd64 x86_64 (64 bit gcc: 6.3.0)
           Desktop: MATE 1.16.1 (Gtk 3.22.11-1)
           Distro: Debian GNU/Linux 9 (stretch)
Machine:   Device: desktop Mobo: ASRock model: H110M-HDV
           UEFI [Legacy]: American Megatrends v: P7.10 date: 10/07/2016
CPU:       Quad core Intel Core i5-6500 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 25536
           clock speeds: max: 3600 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz
           4: 800 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480]
           bus-ID: 01:00.0
           Display Server: X.Org 1.19.2 drivers: ati,vesa (unloaded: modesetting,fbdev,radeon)
           Resolution: 1920x1080@0.00hz
           GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] Device aaf0
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel Sunrise Point-H HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.9.0-2-amd64
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1255.9GB (1.4% used)
           ID-1: /dev/sdb model: WDC_WD10EZEX size: 1000.2GB temp: 37C
           ID-2: /dev/sda model: GOODRAM size: 240.1GB temp: 30C
           ID-3: USB /dev/sdc model: Ultra size: 15.6GB temp: 0C
Partition: ID-1: / size: 33G used: 5.6G (18%) fs: ext4 dev: /dev/sdb4
           ID-2: swap-1 size: 8.55GB used: 0.00GB (0%) fs: swap dev: /dev/sdb5
Sensors:   System Temperatures: cpu: 33.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 161 Uptime: 1 min Memory: 664.7/7950.9MB
           Init: systemd runlevel: 5 Gcc sys: 6.3.0
           Client: Shell (bash 4.4.111) inxi: 2.3.5



And here is the part of amdgpu-pro installation output ( with my own pl -> en translation ):

Code: Select all
Loading new amdgpu-pro-17.10-414273 DKMS files...
Building for 4.9.0-2-amd64
Building for architecture amd64
Building initial module for 4.9.0-2-amd64
Done.
Forcing installation of amdgpu-pro

amdgpu:
Running module version sanity check.
 - Original module
 - Installation
   - Installing to /lib/modules/4.9.0-2-amd64/updates/dkms/

amdttm.ko:
Running module version sanity check.
 - Original module
 - Installation
   - Installing to /lib/modules/4.9.0-2-amd64/updates/dkms/

amdkcl.ko:
Running module version sanity check.
 - Original module
 - Installation
   - Installing to /lib/modules/4.9.0-2-amd64/updates/dkms/

depmod...

Backing up initrd.img-4.9.0-2-amd64 to /boot/initrd.img-4.9.0-2-amd64.old-dkms
Making new initrd.img-4.9.0-2-amd64
(If next boot fails, revert to initrd.img-4.9.0-2-amd64.old-dkms image)
update-initramfs....

DKMS: install completed.
Configuring package libgl1-amdgpu-pro-appprofiles (17.10-414273) ...
Configuring package libgles2-amdgpu-pro:amd64 (17.10-414273) ...
Configuring package libgles2-amdgpu-pro:i386 (17.10-414273) ...
Configuring package libdrm-amdgpu-pro-amdgpu1:amd64 (1:2.4.70-414273) ...
Configuring package libdrm-amdgpu-pro-amdgpu1:i386 (1:2.4.70-414273) ...
Porcessing initiators of package libc-bin (2.24-10)...
Configuring package libgl1-amdgpu-pro-dri:amd64 (17.10-414273) ...
Configuring package libgl1-amdgpu-pro-dri:i386 (17.10-414273) ...
Configuring package libopencl1-amdgpu-pro:amd64 (17.10-414273) ...
Configuring package libopencl1-amdgpu-pro:i386 (17.10-414273) ...
Configuring package vulkan-amdgpu-pro:amd64 (17.10-414273) ...
Configuring package vulkan-amdgpu-pro:i386 (17.10-414273) ...
Configuring package libgl1-amdgpu-pro-glx:amd64 (17.10-414273) ...
Configuring package libgl1-amdgpu-pro-glx:i386 (17.10-414273) ...
Configuring package libvdpau-amdgpu-pro:amd64 (1:13.0.3-414273) ...
Configuring package libvdpau-amdgpu-pro:i386 (1:13.0.3-414273) ...
Configuring package libgbm1-amdgpu-pro:amd64 (17.10-414273) ...
Configuring package libgbm1-amdgpu-pro:i386 (17.10-414273) ...
Configuring package clinfo-amdgpu-pro (17.10-414273) ...
Configuring package xserver-xorg-video-amdgpu-pro (1:1.2.99-414273) ...
Configuring package xserver-xorg-video-glamoregl-amdgpu-pro:amd64 (1.18.3-414273) ...
Configuring package amdgpu-pro-lib32 (17.10-414273) ...
Configuring package libgl1-amdgpu-pro-ext:amd64 (17.10-414273) ...
Configuring package amdgpu-pro (17.10-414273) ...
Porcessing initiators of package libc-bin (2.24-10)...
Last edited by kuba67 on 2017-05-04 13:12, edited 1 time in total.
kuba67
 
Posts: 3
Joined: 2017-05-04 12:14

Re: Debian Stretch AMDGPU-PRO doesn't work

Postby smoki » 2017-05-05 00:25

AMDGPU-PRO does not support xserver 1.19 yet, which is obvious problem... so it would be great surprise if it would work on Debian Stretch.

kuba67 wrote:So it looks like despite being installed, amdgpu-pro isn't used. Do you guys hav any ideas how to fix it?


Wait for their Ubuntu 16.04.3 HWE support (some driver which might be in about 3 months i guess) then it might match something for Debian Stretch by the luck :D
User avatar
smoki
 
Posts: 124
Joined: 2011-08-03 05:04
Location: Srbija, kude snajka posvađa dva sina

Re: Debian Stretch AMDGPU-PRO doesn't work

Postby JLloyd13 » 2017-05-05 01:13

Just in case you haven't been keeping up to date, in the majority of cases the free drivers now out perform the closed source ones, the main exception being Vulkan. Check phoronix.com for some benchies, unless you have a specific thing you want the PRO drivers for I suspect you may decide you don't need them after doing some reading.
Laptop: Debian GNU/Linux 9 'Stretch' 64bit
Read: https://wiki.debian.org/DontBreakDebian/
We are the Universal OS. Be patient, give help, teach the Debian way.
User avatar
JLloyd13
 
Posts: 394
Joined: 2012-06-29 04:08
Location: Halifax NS Canada

Re: Debian Stretch AMDGPU-PRO doesn't work

Postby kuba67 » 2017-05-05 10:43

smoki wrote:AMDGPU-PRO does not support xserver 1.19 yet, which is obvious problem... so it would be great surprise if it would work on Debian Stretch.

kuba67 wrote:So it looks like despite being installed, amdgpu-pro isn't used. Do you guys hav any ideas how to fix it?


Wait for their Ubuntu 16.04.3 HWE support (some driver which might be in about 3 months i guess) then it might match something for Debian Stretch by the luck :D

But will I have a chance of getting it working if I revert kernel to 4.8?
kuba67
 
Posts: 3
Joined: 2017-05-04 12:14

Re: Debian Stretch AMDGPU-PRO doesn't work

Postby stevepusser » 2017-05-05 15:28

No, the xorg and kernel versions are independent.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8893
Joined: 2009-10-06 05:53


Return to Hardware

Who is online

Users browsing this forum: No registered users and 12 guests

fashionable