Trouble seeing iphone7 on my debian install

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Re: Trouble seeing iphone7 on my debian install

Postby dcihon » 2017-05-06 16:07

Code: Select all
cihonm@cihonm:~$ lspci -k | grep -i usb
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
   Subsystem: Dell Sunrise Point-H USB 3.0 xHCI Controller
dcihon
 
Posts: 64
Joined: 2012-09-23 16:18

Re: Trouble seeing iphone7 on my debian install

Postby phenest » 2017-05-06 16:10

You're running Stretch. Has it worked before? Is it since an update perhaps?
Dell XPS 17 L702X i7 2860QM 2.5GHz - 32GB RAM - 4G WWAN - Pioneer TD05-BDR
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS P8P67 EVO i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1441
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Trouble seeing iphone7 on my debian install

Postby dcihon » 2017-05-06 16:14

This is a brand new install of stretch from:
Code: Select all
https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/stretch_di_rc3/multi-arch/iso-cd/

https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/stretch_di_rc3/multi-arch/iso-cd/
dcihon
 
Posts: 64
Joined: 2012-09-23 16:18

Re: Trouble seeing iphone7 on my debian install

Postby phenest » 2017-05-06 16:51

Does your computer have some sort of power saving mode that cuts the power to the USB?
Dell XPS 17 L702X i7 2860QM 2.5GHz - 32GB RAM - 4G WWAN - Pioneer TD05-BDR
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS P8P67 EVO i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1441
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Trouble seeing iphone7 on my debian install

Postby dcihon » 2017-05-07 10:45

If it does I don't know how to find that out. I will check on Dell's Website and see what I can find out.
I noticed with the phone plugged in during boot up that there is power to the phone and then some time during starting up after grub menu it turns it off.
I don't know if that helps any. Can some log files help with that?
dcihon
 
Posts: 64
Joined: 2012-09-23 16:18

Re: Trouble seeing iphone7 on my debian install

Postby phenest » 2017-05-07 11:00

The only log files that spring to mind are dmesg.
Dell XPS 17 L702X i7 2860QM 2.5GHz - 32GB RAM - 4G WWAN - Pioneer TD05-BDR
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS P8P67 EVO i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1441
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Trouble seeing iphone7 on my debian install

Postby dcihon » 2017-05-07 11:17

I see this in my dmesg file but I don't know how to make sense of it. Too technical for me.
Code: Select all
[    1.284697] ACPI: bus type USB registered
[    1.284721] usbcore: registered new interface driver usbfs
[    1.284731] usbcore: registered new interface driver hub
[    1.284749] [drm] Initialized
[    1.284750] usbcore: registered new device driver usb
[    1.284779] SCSI subsystem initialized
[    1.290883] AVX2 version of gcm_enc/dec engaged.
[    1.290884] AES CTR mode by8 optimization enabled
[    1.290972] libata version 3.00 loaded.
[    1.291057] xhci_hcd 0000:00:14.0: xHCI Host Controller
[    1.291061] xhci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 1
[    1.292205] xhci_hcd 0000:00:14.0: hcc params 0x200077c1 hci version 0x100 quirks 0x00109810
[    1.292214] xhci_hcd 0000:00:14.0: cache line size of 64 is not supported
[    1.292333] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    1.292334] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.292335] usb usb1: Product: xHCI Host Controller
[    1.292336] usb usb1: Manufacturer: Linux 4.9.0-2-amd64 xhci-hcd
[    1.292336] usb usb1: SerialNumber: 0000:00:14.0
[    1.292441] hub 1-0:1.0: USB hub found
[    1.292528] hub 1-0:1.0: 10 ports detected
[    1.293993] r8169 0000:02:00.0 eth0: RTL8168h/8111h at 0xffffad6180039000, 48:4d:7e:9f:4d:2f, XID 14100880 IRQ 125
[    1.293994] r8169 0000:02:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[    1.298259] xhci_hcd 0000:00:14.0: xHCI Host Controller
[    1.298261] xhci_hcd 0000:00:14.0: new USB bus registered, assigned bus number 2
[    1.298288] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003
[    1.298289] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.298290] usb usb2: Product: xHCI Host Controller
[    1.298291] usb usb2: Manufacturer: Linux 4.9.0-2-amd64 xhci-hcd
[    1.298292] usb usb2: SerialNumber: 0000:00:14.0
[    1.298404] hub 2-0:1.0: USB hub found
[    1.298411] hub 2-0:1.0: 4 ports detected
[    1.300767] ahci 0000:00:17.0: version 3.0
[    1.301036] ahci 0000:00:17.0: AHCI 0001.0301 32 slots 4 ports 6 Gbps 0xf impl SATA mode
[    1.301037] ahci 0000:00:17.0: flags: 64bit ncq sntf led clo only pio slum part ems deso sadm sds apst

Code: Select all
[    1.769172] usb 1-1: New USB device found, idVendor=05ac, idProduct=12a8
[    1.769175] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    1.769177] usb 1-1: Product: iPhone
[    1.769178] usb 1-1: Manufacturer: Apple Inc.
[    1.769180] usb 1-1: SerialNumber: b8b17f6af48e208ef78e1e31fd5a6dbe923ab3cf
dcihon
 
Posts: 64
Joined: 2012-09-23 16:18

Re: Trouble seeing iphone7 on my debian install

Postby phenest » 2017-05-07 12:15

Dell XPS 17 L702X i7 2860QM 2.5GHz - 32GB RAM - 4G WWAN - Pioneer TD05-BDR
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS P8P67 EVO i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1441
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Trouble seeing iphone7 on my debian install

Postby phenest » 2017-05-07 12:19

I don't think any BIOS settings are wrong, otherwise you'd have the problem in Windows. What I would try is kernel boot parameters, e.g:
Code: Select all
iommu=soft
Dell XPS 17 L702X i7 2860QM 2.5GHz - 32GB RAM - 4G WWAN - Pioneer TD05-BDR
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS P8P67 EVO i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1441
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Trouble seeing iphone7 on my debian install

Postby dcihon » 2017-05-07 12:26

We must be reading the same articles.
I tried those things and it didn't work either so I turned them off:
Code: Select all
GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
# GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
# GRUB_CMDLINE_LINUX="iommu=soft"
GRUB_CMDLINE_LINUX="acpi=force irqpoll"
GRUB_TERMINAL_INPUT="at_keyboard"

I will tun it back on since it doesn't hurt to have it on.
dcihon
 
Posts: 64
Joined: 2012-09-23 16:18

Re: Trouble seeing iphone7 on my debian install

Postby phenest » 2017-05-07 12:30

Code: Select all
iommu=pt

Maybe?
Dell XPS 17 L702X i7 2860QM 2.5GHz - 32GB RAM - 4G WWAN - Pioneer TD05-BDR
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS P8P67 EVO i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1441
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Trouble seeing iphone7 on my debian install

Postby dcihon » 2017-05-07 12:41

No that didn't work.
I am wondering if it could be a systemd thing?
When I am watching the terminal after grub starts (it goes by so fast) wish I could step through it a line at a time.
It says something about systemd hotplug I think and then the battery charge indicator on the phone goes off.
Does this help at all with somewhere different to look?
Thanks for hanging in there with me on this.
dcihon
 
Posts: 64
Joined: 2012-09-23 16:18

Re: Trouble seeing iphone7 on my debian install

Postby phenest » 2017-05-07 12:53

You need to setup systemd journal. Then you check the systemd logs.

Read here if you need to set it up: http://forums.debian.net/viewtopic.php?f=10&t=132666&p=641172&hilit=systemd+journal#p641172
Dell XPS 17 L702X i7 2860QM 2.5GHz - 32GB RAM - 4G WWAN - Pioneer TD05-BDR
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS P8P67 EVO i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1441
Joined: 2010-03-09 09:38
Location: The Matrix

Re: Trouble seeing iphone7 on my debian install

Postby dcihon » 2017-05-07 14:04

As part of getting journal logs to get created I had to install systemd-sysv
and guess what. Not only do I have logs but the iPhone is seen now.
I got the error:
Unable to mount Documents on Dcihon iPhone
Unhandled Lockdown error (-3)
dcihon
 
Posts: 64
Joined: 2012-09-23 16:18

Re: Trouble seeing iphone7 on my debian install

Postby phenest » 2017-05-07 14:25

Dell XPS 17 L702X i7 2860QM 2.5GHz - 32GB RAM - 4G WWAN - Pioneer TD05-BDR
NEC Spirit 550 P4 3.8GHz HT - 2GB RAM - nVidia 7600GT - Pioneer BDR-209DBK
ASUS P8P67 EVO i7 3770K - 32GB RAM - 2x nVidia 660GTX SLI'd
User avatar
phenest
 
Posts: 1441
Joined: 2010-03-09 09:38
Location: The Matrix

PreviousNext

Return to Hardware

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable