Laptop + external monitor text size problem

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Laptop + external monitor text size problem

Postby DeBob » 2017-05-09 19:34

Hello,

I'm new to this forum and to Linux in general, but not to computers at all.
So here is my problem and what I already tried to solve it.

I want to use a external monitor with my Linux laptop (OS is Debian, the monitor actually is a TV :!:).

The OS is working fine with the laptop, no resolution and/or text size problems. I actually can choose size and resolution as I want, and it works fine.
When I now plug in the external screen, it automatically detects the right resoltion and displays the screen 1:1 as I set in in the settings on my laptop. No problems so far.

However, If I restart now or plug the monitor in before I boot the laptop, then the resolution will also automatically be detected as I set it. Taskbar and icons also be the same size, but every text is shown as it was set to size 1. It is so tiny you can't read anything. The problem is, when I go to settings now, the resolution and text size etc is still untouched and didn't change, the only problem is the text size is shown very small, it is as small as this '.......' (yes only dots, but thats how small the size of the text actually look like :( )

When I try to change the resolution and text size, it won't affects the problem, all texts (including text of icons, text of windows, text of descriptions, text in the taskbar, every text is still as small as '.......' this.

When I unplug the monitor, the problem stays on, but if I reboot now after I unplugged it, this problem is gone.

Btw, the laptop has a SIS graphic card and a single core AMD cpu. It's an old, not my main machine.

I haven't find a similar problem so far, so I ask you people for help.

Thanks for any help and suggestions.
DeBob
 
Posts: 1
Joined: 2017-05-09 18:28

Re: Laptop + external monitor text size problem

Postby ruffwoof » 2017-05-09 20:55

Open a Terminal and run
Code: Select all
xrandr

That will give you a guide as to your graphics monitors
For instance I get two sets of values, the first looks like
Code: Select all
root@debian:/home/user# xrandr
Screen 0: minimum 320 x 200, current 1280 x 720, maximum 8192 x 8192
DVI-I-1 connected (normal left inverted right x axis y axis)
   1024x768      60.00 
   800x600       60.32    56.25 
   848x480       60.00 
   640x480       59.94 
.....

My actual preferred device is DVI-I-2 ... which is a 720p LCD 32 inch TV, which I prefer to have running at 1280x720 resolution (720p indicates 720 second value).

When I run
Code: Select all
cvt 1280 720

I get
Code: Select all
root@debian:/home/user# cvt 1280 720
# 1280x720 59.86 Hz (CVT 0.92M9) hsync: 44.77 kHz; pclk: 74.50 MHz
Modeline "1280x720_60.00"   74.50  1280 1344 1472 1664  720 723 728 748 -hsync +vsync

Armed with the above I create a /etc/X11/xorg.conf file ... that looks like
Code: Select all
Section "Monitor"
   Identifier   "DVI-I-2"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
Modeline "1280x720_60.00"   74.50  1280 1344 1472 1664  720 723 728 748 -hsync +vsync
   Option "PreferredMode" "1280x720_60.00"
EndSection

Perhaps try replicating that process, changing the Identifier and Modeline values for your particular case and then see what that looks like when you login. If you black screen at restarting then Ctrl-Alt-F1 (or F2, F3 ....etc) to access another console, login in as root and rename or delete the /etc/X11/xorg.conf file. Note that you can have more than one of those sections with different values for each device, for instance I could add another duplicate of that, but with perhaps Identifier "DVI-I-1" .... with a different Modeline and PreferredMode values.

For general font size, sometimes I create a ~/.Xresources file containing
Code: Select all
! ~/.XResources
! Xft settings ---------------------------------------------------------
Xft.autohint: 0
Xft.antialias: 1
Xft.hinting: 1
Xft.hintstyle: hintslight
! Xft.hintstyle: hintfull
Xft.dpi: 120
Xft.rgba: rgb
Xft.lcdfilter: lcddefault

The Xft.dip: 120 is quite a large font size, many use a 96 or even 80 value. Again you have to logout/login for the changes to be applied.

I suspect your two graphics outputs are being set differently. In Debian Gnome for instance you can usually see (and change) those settings in Settings, Display. That (or whatever alternative for whichever Debian you're running) should really be your first stop before trying the above.
Debian OldStable (Jessie MAIN only), Xfce (pcmanfm desktop) + brightside hot corners (top left set to toggle show/hide desktop)
Acer Aspire M3201 (2GB), AMD Phenom X4, Nvidia GT8600
ruffwoof
 
Posts: 132
Joined: 2016-08-20 21:00

Re: Laptop + external monitor text size problem

Postby Head_on_a_Stick » 2017-05-10 06:08

DeBob wrote:However, If I restart now or plug the monitor in before I boot the laptop, then the resolution will also automatically be detected as I set it. Taskbar and icons also be the same size, but every text is shown as it was set to size 1. It is so tiny you can't read anything. The problem is, when I go to settings now, the resolution and text size etc is still untouched and didn't change, the only problem is the text size is shown very small, it is as small as this '.......' (yes only dots, but thats how small the size of the text actually look like :( )

When I try to change the resolution and text size, it won't affects the problem, all texts (including text of icons, text of windows, text of descriptions, text in the taskbar, every text is still as small as '.......' this.

This sounds like a DPI issue.

Check with:
Code: Select all
xdpyinfo | grep dots > dpi.txt

Then you can read the dpi.txt file when the screen's back to normal :)
“Controlling complexity is the essence of computer programming."Brian Kernighan

Please read before posting How to report a problem
User avatar
Head_on_a_Stick
 
Posts: 6491
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable