Dual monitor on different video cards

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Dual monitor on different video cards

Postby neos7m » 2017-06-23 11:03

I'm trying to use two monitors on my PC using my dedicated graphics card (NVIDIA GTX 960) together with the integrated card (Intel Xeon E3-1200). This configuration works perfectly on Windows, although I had to allow discrete graphics in the BIOS. However, it does not work in Debian, as I can only see output on the primary monitor (connected to the dedicated video card).

Here is the output of inxi -G:
Code: Select all
Graphics:  Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
           Card-2: NVIDIA GM206 [GeForce GTX 960]
           Display Server: X.Org 1.19.3 driver: nvidia
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 960/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 375.66


sudo lshw -c video:
Code: Select all
  *-display                 
       description: VGA compatible controller
       product: GM206 [GeForce GTX 960]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:30 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:c0000-dffff
  *-display UNCLAIMED
       description: Display controller
       product: Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm bus_master cap_list
       configuration: latency=0
       resources: memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)


Finally, xrandr:
Code: Select all
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
DVI-I-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080     60.00*+
   1680x1050     59.95 
   1600x900      60.00 
   1440x900      59.89 
   1366x768      59.79 
   1280x1024     75.02    60.02 
   1280x800      59.81 
   1280x720      60.00 
   1152x864      75.00 
   1024x768      75.03    70.07    60.00 
   800x600       75.00    72.19    60.32 
   640x480       75.00    72.81    59.94 
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)
DP-5 disconnected (normal left inverted right x axis y axis)


It looks like inxi detects my integrated video card, lshw tells me it's unclaimed, and xrandr doesn't have any clue that there is a second monitor attached (and turned on, if that matters). Can anybody help me?
neos7m
 
Posts: 1
Joined: 2017-06-23 10:59

Return to Hardware

Who is online

Users browsing this forum: maximus1978, qunt and 5 guests

fashionable