Wifi wasnt working in debian 9.0.1

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Wifi wasnt working in debian 9.0.1

Postby mharris » 2017-06-23 12:43

I bought this cheap $5 usb wifi dongle https://www.amazon.com/gp/product/B01DS ... UTF8&psc=1

It didn't work with Debian 8.8 and sources wouldn't compile etc so i went ahead and installed debian 9.0.1 from the non-free gnome live cd which included the necessary drivers to get the card to be recognized.

Wireless networks were detected but it couldnt connect to any of them.

I remembered this fix i had to do for ubuntu testing on the same machine with a different card that i did not have do do for debian 8.8. SO.... i tried it and it works.

https://askubuntu.com/questions/902992/ ... 019#905019

The odd thing is that it was not required for debian 8.8, but the wifi adapter does so there is an improvement.

long story short,

Code: Select all
sudo nano /etc/NetworkManager/NetworkManager.conf


and add

Code: Select all
[device]
wifi.scan-rand-mac-address=no


and run

Code: Select all
sudo service network-manager restart

and it might start working for you as well. Hope this saves someone some time.
mharris
 
Posts: 2
Joined: 2017-06-23 12:30

Re: Wifi wasnt working in debian 9.0.1

Postby orythem27 » 2017-06-23 14:03

Thank you very much, I haven't realized that it's actually this issue. There are a couple of posts reporting this issue recently, and I told them to disable systemd's predictable ifnames... :oops: Although (coincidentally?...) that will also work, now I guess it's a overkill. Your solution should be the standard.
User avatar
orythem27
 
Posts: 252
Joined: 2017-05-11 07:59
Location: P.R. China

Re: Wifi wasnt working in debian 9.0.1

Postby mharris » 2017-06-23 14:31

Anytime, I"m glad you found it useful.
mharris
 
Posts: 2
Joined: 2017-06-23 12:30


Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable