Stretch nvidia-vulkan-common upgrade

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Stretch nvidia-vulkan-common upgrade

Postby TerminalAddict » 2017-07-27 01:56

Hi all,
first post !
Been using debian since 2005, and linux since well before then, so not really a noob :P

Trying to upgrade nvidia-vulkan-common
safe-upgrade holds it back, dist-upgrade gives:
Code: Select all
aptitude -s dist-upgrade
The following packages will be upgraded:
  nvidia-vulkan-common{b}
1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/171 kB of archives. After unpacking 0 B will be used.
The following packages have unmet dependencies:
 nvidia-vulkan-common : Conflicts: libgl1-nvidia-glx but 375.66-2~deb9u1 is installed
                        Conflicts: libgl1-nvidia-glx:i386 but 375.66-2~deb9u1 is installed
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     nvidia-vulkan-common [375.66-1 (now)]



I can see in the changelog
Code: Select all
nvidia-graphics-drivers (375.66-2) unstable; urgency=medium

  [ Andreas Beckmann ]
  * nvidia-vulkan-common: Add Conflicts: libgl1-nvidia-glx as a workaround for
    #864477 (wrong library referenced in nvidia_icd.json in non-GLVND setups).


but can't see anywhere to do a successful upgrade

for reference
Code: Select all
dpkg -l | grep nvidia
ii  glx-alternative-nvidia                0.7.4                                amd64        allows the selection of NVIDIA as GLX provider
ii  libegl-nvidia0:amd64                  375.66-2~deb9u1                      amd64        NVIDIA binary EGL library
ii  libegl1-glvnd-nvidia:amd64            375.66-2~deb9u1                      amd64        Vendor neutral GL dispatch library -- libEGL
ii  libgl1-nvidia-glx:amd64               375.66-2~deb9u1                      amd64        NVIDIA binary OpenGL/GLX library (non-GLVND variant)
ii  libgl1-nvidia-glx:i386                375.66-2~deb9u1                      i386         NVIDIA binary OpenGL/GLX library (non-GLVND variant)
ii  libgldispatch0-nvidia:amd64           375.66-2~deb9u1                      amd64        Vendor neutral GL dispatch library -- libGLdispatch
ii  libgles-nvidia1:amd64                 375.66-2~deb9u1                      amd64        NVIDIA binary OpenGL|ES 1.x library
ii  libgles-nvidia2:amd64                 375.66-2~deb9u1                      amd64        NVIDIA binary OpenGL|ES 2.x library
ii  libgles1-glvnd-nvidia:amd64           375.66-2~deb9u1                      amd64        NVIDIA binary OpenGL|ES 1.x GLVND stub library
ii  libgles2-glvnd-nvidia:amd64           375.66-2~deb9u1                      amd64        NVIDIA binary OpenGL|ES 2.x GLVND stub library
ii  libglx-nvidia0:amd64                  375.66-2~deb9u1                      amd64        NVIDIA binary GLX library
ii  libglx0-glvnd-nvidia:amd64            375.66-2~deb9u1                      amd64        Vendor neutral GL dispatch library -- libGLX
ii  libnvidia-cfg1:amd64                  375.66-2~deb9u1                      amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-eglcore:amd64               375.66-2~deb9u1                      amd64        NVIDIA binary EGL core libraries
ii  libnvidia-glcore:amd64                375.66-2~deb9u1                      amd64        NVIDIA binary OpenGL/GLX core libraries
ii  libnvidia-glcore:i386                 375.66-2~deb9u1                      i386         NVIDIA binary OpenGL/GLX core libraries
ii  libnvidia-ml1:amd64                   375.66-2~deb9u1                      amd64        NVIDIA Management Library (NVML) runtime library
ii  libopengl0-glvnd-nvidia:amd64         375.66-2~deb9u1                      amd64        Vendor neutral GL dispatch library -- libOpenGL
ii  nvidia-alternative                    375.66-2~deb9u1                      amd64        allows the selection of NVIDIA as GLX provider
ii  nvidia-detect                         375.66-2~deb9u1                      amd64        NVIDIA GPU detection utility
ii  nvidia-driver                         375.66-2~deb9u1                      amd64        NVIDIA metapackage
ii  nvidia-driver-bin                     375.66-2~deb9u1                      amd64        NVIDIA driver support binaries
ii  nvidia-driver-libs:amd64              375.66-2~deb9u1                      amd64        NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries)
ii  nvidia-egl-common                     375.66-2~deb9u1                      amd64        NVIDIA binary EGL driver - common files
ii  nvidia-egl-icd:amd64                  375.66-2~deb9u1                      amd64        NVIDIA EGL installable client driver (ICD)
ii  nvidia-installer-cleanup              20151021+4                           amd64        cleanup after driver installation with the nvidia-installer
ii  nvidia-kernel-common                  20151021+4                           amd64        NVIDIA binary kernel module support files
ii  nvidia-kernel-dkms                    375.66-2~deb9u1                      amd64        NVIDIA binary kernel module DKMS source
ii  nvidia-kernel-support                 375.66-2~deb9u1                      amd64        NVIDIA binary kernel module support files
ii  nvidia-legacy-check                   375.66-2~deb9u1                      amd64        check for NVIDIA GPUs requiring a legacy driver
ii  nvidia-modprobe                       375.26-1                             amd64        utility to load NVIDIA kernel modules and create device nodes
ii  nvidia-persistenced                   375.26-2                             amd64        daemon to maintain persistent software state in the NVIDIA driver
ii  nvidia-settings                       375.66-1                             amd64        tool for configuring the NVIDIA graphics driver
ii  nvidia-support                        20151021+4                           amd64        NVIDIA binary graphics driver support files
ii  nvidia-vdpau-driver:amd64             375.66-2~deb9u1                      amd64        Video Decode and Presentation API for Unix - NVIDIA driver
ii  nvidia-vulkan-common                  375.66-1                             amd64        NVIDIA Vulkan driver - common files
ii  nvidia-vulkan-icd:amd64               375.66-2~deb9u1                      amd64        NVIDIA Vulkan installable client driver (ICD)
ii  nvidia-xconfig                        375.26-1                             amd64        deprecated X configuration tool for non-free NVIDIA drivers
ii  xserver-xorg-video-nvidia             375.66-2~deb9u1                      amd64        NVIDIA binary Xorg driver
TerminalAddict
 
Posts: 2
Joined: 2017-07-10 09:11

Re: Stretch nvidia-vulkan-common upgrade

Postby 4D696B65 » 2017-07-27 08:26

Fixed in sid
Code: Select all
nvidia-vulkan-common:
  Installed: 375.82-1
  Candidate: 375.82-1
  Version table:
 *** 375.82-1 500
        500 http://ftp.ca.debian.org/debian unstable/non-free amd64 Packages
        100 /var/lib/dpkg/status
User avatar
4D696B65
 
Posts: 1992
Joined: 2009-06-28 06:09

Re: Stretch nvidia-vulkan-common upgrade

Postby TerminalAddict » 2017-07-28 03:15

4D696B65 wrote:Fixed in sid
Code: Select all
nvidia-vulkan-common:
  Installed: 375.82-1
  Candidate: 375.82-1
  Version table:
 *** 375.82-1 500
        500 http://ftp.ca.debian.org/debian unstable/non-free amd64 Packages
        100 /var/lib/dpkg/status


ok , so wait for it to make to stable.
TerminalAddict
 
Posts: 2
Joined: 2017-07-10 09:11


Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable