No sound on Acer Aspire One with Stretch

Getting your soundcard to work, using Debian on non-i386 hardware, etc

No sound on Acer Aspire One with Stretch

Postby toquinho » 2017-08-01 03:45

Hello!

I am trying to get audio working on a friend's old Acer Aspire One running a recent installation of Stretch. During boot, the following message appears:

Code: Select all
[    9.310394] snd_hda_intel 0000:00:1b.0: no codecs found!


When running modprobe by hand to load snd_hda_intel, I get no error. I have searched several forums and tried to load the module by adding files to /etc/modprobe.d/, but all this did not make a difference.

The system does not find a sound card, and pavucontrol shows only a virtual card in the list of output devices.

Below, I am posting the output of alsa-info assuming that it contains all necessary info to trace down the problem. Any help is greatly appreciated.

Toquinho


Code: Select all
!!################################
!!ALSA Information Script v 0.4.64
!!################################

!!Script ran on: Tue Aug  1 04:15:18 UTC 2017


!!Linux Distribution
!!------------------

Debian GNU/Linux 9 \n \l PRETTY_NAME="Debian GNU/Linux 9 (stretch)" NAME="Debian GNU/Linux" ID=debian HOME_URL="https://www.debian.org/" SUPPORT_URL="https://www.debian.org/support" BUG_REPORT_URL="https://bugs.debian.org/"


!!DMI Information
!!---------------

Manufacturer:      Acer           
Product Name:      AO532h         
Product Version:   V1.08
Firmware Version:  V1.08


!!Kernel Information
!!------------------

Kernel release:    4.9.0-3-amd64
Operating System:  GNU/Linux
Architecture:      x86_64
Processor:         unknown
SMP Enabled:       Yes


!!ALSA Version
!!------------

Driver version:     k4.9.0-3-amd64
Library version:    1.1.3
Utilities version:  1.1.3


!!Loaded ALSA modules
!!-------------------



!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes


!!Soundcards recognised by ALSA
!!-----------------------------

--- no soundcards ---


!!PCI Soundcards installed in the system
!!--------------------------------------

00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)


!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------

00:1b.0 0403: 8086:27d8 (rev 02)
   Subsystem: 1025:0349


!!Modprobe options (Sound related)
!!--------------------------------

snd_pcsp: index=-2
snd_usb_audio: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_hda_intel: model=acer-aspire


!!Loaded sound module options
!!---------------------------


!!ALSA Device nodes
!!-----------------

crw-rw----  1 root audio 116,  1 Aug  1 00:58 /dev/snd/seq
crw-rw----  1 root audio 116, 33 Aug  1 00:58 /dev/snd/timer


!!Aplay/Arecord output
!!--------------------

APLAY

aplay: device_list:270: no soundcards found...

ARECORD

arecord: device_list:270: no soundcards found...

!!Amixer output
!!-------------


!!Alsactl output
!!--------------

--startcollapse--
--endcollapse--


!!All Loaded Modules
!!------------------

Module
fuse
ctr
ccm
cpufreq_userspace
cpufreq_conservative
cpufreq_powersave
uvcvideo
videobuf2_vmalloc
videobuf2_memops
videobuf2_v4l2
videobuf2_core
videodev
media
iTCO_wdt
acer_wmi
iTCO_vendor_support
sparse_keymap
arc4
ath9k
ath9k_common
ath9k_hw
ath
coretemp
mac80211
i915
evdev
cfg80211
pcspkr
rfkill
lpc_ich
joydev
serio_raw
mfd_core
battery
sg
drm_kms_helper
ac
drm
shpchp
button
video
wmi
i2c_algo_bit
acpi_cpufreq
snd_hda_intel
snd_hda_codec
snd_hda_core
snd_hwdep
snd_pcm
snd_timer
snd
soundcore
parport_pc
ppdev
lp
parport
ip_tables
x_tables
autofs4
ext4
crc16
jbd2
crc32c_generic
fscrypto
ecb
glue_helper
lrw
gf128mul
ablk_helper
cryptd
aes_x86_64
mbcache
sd_mod
ata_generic
ata_piix
libata
psmouse
i2c_i801
i2c_smbus
scsi_mod
ehci_pci
uhci_hcd
ehci_hcd
usbcore
usb_common
atl1c
fan
thermal


!!ALSA/HDA dmesg
!!--------------

[    8.938268] ppdev: user-space parallel port driver
[    9.310394] snd_hda_intel 0000:00:1b.0: no codecs found!
[   12.052112] wmi: Mapper loaded


toquinho
 
Posts: 20
Joined: 2014-06-24 16:50

Re: No sound on Acer Aspire One with Stretch

Postby Bulkley » 2017-08-01 04:28

Are you sure Alsa is turned on?

You might need firmware-misc-nonfree, firmware-linux-free or firmware-linux-nonfree.
Bulkley
 
Posts: 5239
Joined: 2006-02-11 18:35

Re: No sound on Acer Aspire One with Stretch

Postby toquinho » 2017-08-01 05:28

Thanks a lot for your quick reply. I installed the firmware packages including one that is called firmware-intel-sound, but the result is unchanged. The output of alsa-info changes a bit (at the end of the post). The only thing I noticed is that this line:


Code: Select all
snd_hda_intel: model=acer-aspire

only appears in the output of alsa-info if I have a file with the following contents in modprobe.d:

Code: Select all
options snd-hda-intel model=acer-aspire


Regarding your question whether Alsa is turned on, I am not sure how to find out. But alsa-info says that pulse audio is running.

The output of alsa-info now is:

Code: Select all
upload=true&script=true&cardinfo=
!!################################
!!ALSA Information Script v 0.4.64
!!################################

!!Script ran on: Tue Aug  1 06:03:50 UTC 2017


!!Linux Distribution
!!------------------

Debian GNU/Linux 9 \n \l PRETTY_NAME="Debian GNU/Linux 9 (stretch)" NAME="Debian GNU/Linux" ID=debian HOME_URL="https://www.debian.org/" SUPPORT_URL="https://www.debian.org/support" BUG_REPORT_URL="https://bugs.debian.org/"


!!DMI Information
!!---------------

Manufacturer:      Acer           
Product Name:      AO532h         
Product Version:   V1.08
Firmware Version:  V1.08


!!Kernel Information
!!------------------

Kernel release:    4.9.0-3-amd64
Operating System:  GNU/Linux
Architecture:      x86_64
Processor:         unknown
SMP Enabled:       Yes


!!ALSA Version
!!------------

Driver version:     k4.9.0-3-amd64
Library version:    1.1.3
Utilities version:  1.1.3


!!Loaded ALSA modules
!!-------------------



!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes


!!Soundcards recognised by ALSA
!!-----------------------------

--- no soundcards ---


!!PCI Soundcards installed in the system
!!--------------------------------------

00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)


!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------

00:1b.0 0403: 8086:27d8 (rev 02)
   Subsystem: 1025:0349


!!Modprobe options (Sound related)
!!--------------------------------

snd_pcsp: index=-2
snd_usb_audio: index=-2
snd_atiixp_modem: index=-2
snd_intel8x0m: index=-2
snd_via82xx_modem: index=-2
snd_hda_intel: model=acer-aspire


!!Loaded sound module options
!!---------------------------


!!ALSA Device nodes
!!-----------------

crw-rw----+ 1 root audio 116,  1 Aug  1 03:01 /dev/snd/seq
crw-rw----+ 1 root audio 116, 33 Aug  1 03:01 /dev/snd/timer


!!Aplay/Arecord output
!!--------------------

APLAY

aplay: device_list:270: no soundcards found...

ARECORD

arecord: device_list:270: no soundcards found...

!!Amixer output
!!-------------


!!Alsactl output
!!--------------

--startcollapse--
--endcollapse--


!!All Loaded Modules
!!------------------

Module
fuse
ctr
ccm
cpufreq_userspace
cpufreq_conservative
cpufreq_powersave
uvcvideo
videobuf2_vmalloc
videobuf2_memops
videobuf2_v4l2
videobuf2_core
videodev
media
iTCO_wdt
iTCO_vendor_support
arc4
acer_wmi
ath9k
sparse_keymap
ath9k_common
ath9k_hw
coretemp
joydev
pcspkr
evdev
ath
lpc_ich
mac80211
serio_raw
sg
cfg80211
rfkill
mfd_core
i915
drm_kms_helper
battery
ac
drm
shpchp
video
button
wmi
i2c_algo_bit
acpi_cpufreq
snd_hda_intel
snd_hda_codec
snd_hda_core
snd_hwdep
snd_pcm
snd_timer
snd
soundcore
parport_pc
ppdev
lp
parport
ip_tables
x_tables
autofs4
ext4
crc16
jbd2
crc32c_generic
fscrypto
ecb
glue_helper
lrw
gf128mul
ablk_helper
cryptd
aes_x86_64
mbcache
sd_mod
ata_generic
psmouse
ata_piix
libata
i2c_i801
scsi_mod
i2c_smbus
ehci_pci
uhci_hcd
ehci_hcd
usbcore
usb_common
atl1c
fan
thermal


!!ALSA/HDA dmesg
!!--------------

[    8.860693] ppdev: user-space parallel port driver
[    9.521135] snd_hda_intel 0000:00:1b.0: no codecs found!
[   12.541086] wmi: Mapper loaded

toquinho
 
Posts: 20
Joined: 2014-06-24 16:50

Re: No sound on Acer Aspire One with Stretch

Postby Jordan Morris » 2017-08-02 14:57

if got it working to let us know also thanks
Jordan Morris
 
Posts: 2
Joined: 2017-07-27 15:47

Re: No sound on Acer Aspire One with Stretch

Postby stevepusser » 2017-08-02 16:53

Can you try a live session of a distro that includes the firmware to see if sound works with it?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8525
Joined: 2009-10-06 05:53

Re: No sound on Acer Aspire One with Stretch

Postby toquinho » 2017-08-02 19:28

Thanks a lot, I will try another distro. Which distros do you suggest? I would try Mint or Ubuntu, but first I have to figure out how to boot from my USB stick. The Bios and the boot menu do not see it. Will try a smaller one. As soon as I have news, I will let you know.
toquinho
 
Posts: 20
Joined: 2014-06-24 16:50

Re: No sound on Acer Aspire One with Stretch

Postby stevepusser » 2017-08-02 21:14

I would stick to Debian derivatives rather than going farther astray with Ubuntu or Mint--something like SolydXK, antiX, or MX Linux come to mind.

What are you using to create a bootable USB stick from an ISO file?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.0.6, Pale Moon 27.4.1, Liquorix kernel 4.11-9, mpv 0.26.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8525
Joined: 2009-10-06 05:53


Return to Hardware

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable