Problems with iPhone modem after Stretch upgrade

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Problems with iPhone modem after Stretch upgrade

Postby runfrodorun » 2017-08-22 13:32

Hi, upgraded to stretch and having more problems than usual with the system after an upgrade (all my historical ones have been very smooth). Apart from some very odd kernel messages before it mounts the root filesystem (I'll look into that another time), I used to be able to tether my iPhone to the system through USB and it would recognize as an ethernet device. However, now it doesn't seem the USB connection seems to stay alive for more than a millisecond.

When I plug it in, the iphone flashses for a split second that it is charging, and then from that point forward it appears to be disconnected so I don't even have a chance to initialize the virtual nic. It's a very strange issue. I can plug the usb cable into any other linux machine using jessie and it works fine. Charges, can use the internet, etc.

It only started happening after the stretch upgrade. I've tried loading up the old 3.16 kernel and it suddenly is not working in that kernel either, so it's almost like it is a daemon or a power setting that was changed in the userland. I've reviewed again all of the packages that were added and removed during the upgrade, and nothing looks suspect at all. I thought it could be something with USB core. There have been some hints to disable some automatic power mode or something with usbcore, but the fix applied to jessie as well so it's a little suspect as well.

Anybody have a similar issue?
Much opinionated.
Some abrasive.
No systemd.
Wow.
runfrodorun
 
Posts: 202
Joined: 2013-06-19 05:09

Re: Problems with iPhone modem after Stretch upgrade

Postby runfrodorun » 2017-08-22 13:56

Update: I was more or less able to get this working by using /sys/bus/usb/drivers/usb/unbind and bind respectively to unbind and re-bind the device. In light of that, it could be a udev rule that's messed up.
Much opinionated.
Some abrasive.
No systemd.
Wow.
runfrodorun
 
Posts: 202
Joined: 2013-06-19 05:09

Re: Problems with iPhone modem after Stretch upgrade

Postby runfrodorun » 2017-08-22 14:47

So I guess it's charging, but the nic is still not recognized. It's as if the usb hub driver has no idea what driver to bind to the iphone.
Much opinionated.
Some abrasive.
No systemd.
Wow.
runfrodorun
 
Posts: 202
Joined: 2013-06-19 05:09


Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable