Arduino + Adafruit Trinket problem - Nothing appears in /dev

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Arduino + Adafruit Trinket problem - Nothing appears in /dev

Postby DeadTOm76 » 2017-09-22 18:12

I'm not sure if I'm posting this to the right section, but this seems to be a problem with the OS properly detecting the Trinket, and creating something in /dev for it.

OS: Debian Stretch, completely up to date.
Arduino IDE: 1.8.4

When I plug in an UNO or a Leonardo, they both register at /dev/ttyACM0, and I have no problems. When I plug in my brand new 3V Trinket, the port menu is grayed out in the Arduino IDE. I've downloaded the appropriate board in the board manager, and everything is up to date.

I'm thinking I need to do something with ftdi drivers, modprobe... something. I don't know.

There is no ttyACM0 or ttyUSB0 in /dev.

I am a member of the dialout group.

Running the Arduino IDE from the command line doesn't produce any errors, or anything else helpful.

Here is the output of dmesg:
Code: Select all
[ 3503.489015] usb 2-1.3: new low-speed USB device number 9 using ehci-pci
[ 3503.612325] usb 2-1.3: New USB device found, idVendor=1781, idProduct=0c9f
[ 3503.612331] usb 2-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 3503.612335] usb 2-1.3: Product: Trinket
[ 3503.612338] usb 2-1.3: Manufacturer: Adafruit


Output of lsusb:
Code: Select all
Bus 002 Device 004: ID 0a5c:5802 Broadcom Corp. BCM5880 Secure Applications Processor with fingerprint touch sensor
Bus 002 Device 009: ID 1781:0c9f Multiple Vendors USBtiny
Bus 002 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


And lastly, output of tail /var/log/syslog:
Code: Select all
Sep 21 22:52:43 strahd kernel: [ 4333.187363] usb 2-1.3: new low-speed USB device number 10 using ehci-pci
Sep 21 22:52:43 strahd kernel: [ 4333.304959] usb 2-1.3: New USB device found, idVendor=1781, idProduct=0c9f
Sep 21 22:52:43 strahd kernel: [ 4333.304965] usb 2-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Sep 21 22:52:43 strahd kernel: [ 4333.304968] usb 2-1.3: Product: Trinket
Sep 21 22:52:43 strahd kernel: [ 4333.304971] usb 2-1.3: Manufacturer: Adafruit
Sep 21 22:52:43 strahd mtp-probe: checking bus 2, device 10: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3"
Sep 21 22:52:43 strahd mtp-probe: bus: 2, device: 10 was not an MTP device


Any help is greatly appreciated.

Thanks!
User avatar
DeadTOm76
 
Posts: 2
Joined: 2017-09-22 15:36
Location: Missoula, MT USA

Re: Arduino + Adafruit Trinket problem - Nothing appears in

Postby DeadTOm76 » 2017-09-22 18:28

Well shoot. Here it is then:

https://forums.adafruit.com/viewtopic.php?f=52&t=46960

No Linux support for Trinket. :(

Wish I'd found that first. Glad I only spent $15 on this thing.
User avatar
DeadTOm76
 
Posts: 2
Joined: 2017-09-22 15:36
Location: Missoula, MT USA


Return to Hardware

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable
cron