MultiCard Reader issue

Getting your soundcard to work, using Debian on non-i386 hardware, etc

MultiCard Reader issue

Postby lkk » 2017-10-21 15:50

Hello I have a lenovo thinkpad t430s with a Ricoh MMC/SD reader, it works well on other system (windows 7 and lubuntu 17.10) but on my newly fresh install of debian buster (testing) i have an issue.

thinkwiki page about the hardware :
http://www.thinkwiki.org/wiki/Ricoh_5-i ... ard_Reader

uname :
Linux 4.13.0-1-amd64 #1 SMP Debian 4.13.4-2 (2017-10-15) x86_64 GNU/Linux

lspci :
04:00.0 System peripheral: Ricoh Co Ltd MMC/SD Host Controller (rev 07)

dmesg when i plug and unplug a working sd card:
https://pastebin.com/raw/KZhdQ4A0

Any idea ? Thanks.
lkk
 
Posts: 3
Joined: 2017-10-21 15:40

Re: MultiCard Reader issue

Postby 4D696B65 » 2017-10-21 17:12

The error refers to illegal byte sequence.
Hopefully someone can help you further. Good luck.
User avatar
4D696B65
 
Posts: 2024
Joined: 2009-06-28 06:09

Re: MultiCard Reader issue

Postby Head_on_a_Stick » 2017-10-21 21:17

lkk wrote:on my newly fresh install of debian buster (testing) i have an issue

Do you experience the issue with the stable release?

The "live" environment could be used to check, you may need one of the non-free images:

https://cdimage.debian.org/cdimage/unof ... so-hybrid/
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6678
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: MultiCard Reader issue

Postby lkk » 2017-10-22 09:47

I used debian-live-9.2.0-amd64-lxde+nonfree.iso and it worked.

uname :
Linux debian 4.9.0-4-amd64 #1 SMP Debian 4.9.51-1 (2017-09-28) x86_64 GNU/Linux

dmesg :
[ 261.402614] mmc0: new high speed SDHC card at address a551
[ 261.403562] mmcblk0: mmc0:a551 SD04G 3.69 GiB
[ 261.404427] mmcblk0: error -84 transferring data, sector 0, nr 8, cmd response 0x900, card status 0xb00
[ 261.518416] mmcblk0: p1
lkk
 
Posts: 3
Joined: 2017-10-21 15:40

Re: MultiCard Reader issue

Postby Head_on_a_Stick » 2017-10-22 14:05

lkk wrote:I used debian-live-9.2.0-amd64-lxde+nonfree.iso and it worked.

Well then you should probably look at investigating the issue more and filing a bug report with Debian to help fix things.

In the meantime you could use Debian stable, it is really rather excellent :)
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6678
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: MultiCard Reader issue

Postby lkk » 2017-10-22 18:19

Yeah I'm going to do that, thanks for your answer.
lkk
 
Posts: 3
Joined: 2017-10-21 15:40


Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable