Debian Stretch shutdown probem on Lenovo T500

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Debian Stretch shutdown probem on Lenovo T500

Postby jaja » 2017-10-21 21:18

Hello, and thanks for the help.

On shutdown, my Lenovo T500 Laptop goes into an infinite loop (hangs).
This problem started after a fresh install of Debian 9.2 Stretch.
This problem does *NOT* occur with the older Debian 8.9 Jessie.

My laptop hangs with the following messages:
    [ number.number] i2400m_usb 5-1:1.0: device not connected as high speed
    [ number.number] irq 16: nobody cared (try booting with the "irqpoll" option)
    [ number.number] handlers:
    [ number.number] [<string>] usb_hcd_irq [usbcore]
    [ number.number] [<string>] yenta_interrupt [yenta_socket]
    [ number.number] Disabling IRQ #16
    [ number.number] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
    [ number.number] ata2.00: cmd a0/00:00:00:08:00/00:00:00:00:00/a0 tag 21 pio 16392 in
    [ number.number] Get event status notification 4a 01 00 00 10 00 00 00 08 00res 40/00:02:00:00:02/00:00:00:00:00/00 Emask 0x4 (timeout)
    [ number.number] ata2.00: status: { DRDY }
    [ number.number] ata2.00: revalidation failed (errno=-5)
    [ number.number] ata2.00: revalidation failed (errno=-5)
    [ number.number] ata2.00: revalidation failed (errno=-5)
    [ number.number] INFO: task systemd-shutdow:1 blocked for more than 120 seconds.
    [ number.number] Tainted: G 0 4.9.0-3-amd64 #1 Debian 4.9.51-1
    [ number.number] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
The last 3 lines keep repeating every 120 seconds -- infinite loop.

The problem is in the base Debian 9.2 system (not in the KDE GUI).
I determined this by installing a base Debian 9.2 (Stretch) CLI only version. The shutdown problem occurred.
Then I installed an older base Debian 8.9 (Jessie) CLI only version. There wasn't any shutdown problem.
(This test also shows that there isn't any hardware problem. The failure only occurs in "Stretch", otherwise everything works.)

Next, I followed the suggestions in the shutdown messages.
I added the grub option: irqpoll
The computer still hung on shutdown.
One change is that all the messages disappeared, EXCEPT for the first one:
[ number.number] i2400m_usb 5-1:1.0: device not connected as high speed
So I checked for bootup messages related to "i2400m_usb".
I found one:
[ number.number] i2400m_usb 8-3:1.0: WIMAX interface wmx0 (xx:xx:xx:xx:xx:xx) ready
This message indicates that "i2400m_usb" is loading without error.

Next, I added the "echo" string suggested in the shutdown comments:
sudo echo 0 > /proc/sys/kernel/hung_task_timeout_secs
The computer still hung on shutdown.

To see if there was a clue elsewhere, I checked for bootup errors. There were none.

To test for a power control bug, I tried shutting down with "halt -p", but the problem remained.

I tried replacing "systemd" with "sysvinit" (see: without-systemd.org/wiki/index.php/Debian_Stretch). The problem remained.

I tried changing the BIOS SATA setting from "AHCI" to "Compatibility". The problem remained.

Summary:
The problem is in the base Debian 9.2. (Debian 8.9 works. Debian 9.2 fails.)
It is not due to hardware (Debian 8.9 works).
The Intel wireless drivers are loading ("i2400m_usb").
There are no other message indicating driver problems.
It's not a power-off problem (not fixed with "halt -p").
The BIOS settings work for Debian 8.9.

I'm running out of ideas.

I'd appreciate any suggestions as to how to fix this shutdown problem.
Thank you for the help.

P.S. About 2 weeks ago, I posted an earlier version of this message on the "Installation" forum, but did not receive any responses. Hence, my reason for posting here.
jaja
 
Posts: 17
Joined: 2016-01-25 00:20

Re: Debian Stretch shutdown probem on Lenovo T500

Postby Head_on_a_Stick » 2017-10-21 21:24

This is a kernel bug, probably a regression, see Mr. Poettering's final comment in this thread:

https://github.com/systemd/systemd/issues/2868

Options: try the Liquorix kernel or bisect the issue.

https://wiki.debian.org/DebianKernel/GitBisect

EDIT: or the stretch-backports kernel, ofc.
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6792
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Debian Stretch shutdown probem on Lenovo T500

Postby jaja » 2017-10-23 03:34

Hello Head_on_a_Stick;
Thank you for the pointer to the kernel bug.
I installed the Stretch-backports kernel. Now the shutdown problem occurs about 20% of the time (previously it occurred over 90% of the time).
Thanks to you, I know where to focus my efforts.
Thanks for the help.
jaja
 
Posts: 17
Joined: 2016-01-25 00:20


Return to Hardware

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable