dependency problem

Getting your soundcard to work, using Debian on non-i386 hardware, etc

dependency problem

Postby AlexKorvinus » 2017-12-06 12:38

After the update, there is a dependency problem.

dpkg: package dependencies do not allow you to configure the joxi package:
joxi depends on qtdeclarative5-qtquick2-plugin, however:
The qtdeclarative5-qtquick2-plugin package is not installed.
try to resolve the dependencies and get:

Package qtdeclarative5-qtquick2-plugin is not available but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However, the following packages replace it:
qml-module-qtquick2: i386 qml-module-qtquick2

E: Package 'qtdeclarative5-qtquick2-plugin' has no installation candidat

Sys - debian 8.7
Linux Host 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u2 (2016-10-19) x86_64 GNU/Linux
User avatar
AlexKorvinus
 
Posts: 1
Joined: 2017-12-06 12:24

Re: dependency problem

Postby wizard10000 » 2017-12-06 13:08

qtdeclarative5-qtquick2-plugin is an Ubuntu package.
we see things not as they are, but as we are.
-- anais nin
User avatar
wizard10000
 
Posts: 1218
Joined: 2011-05-09 20:02
Location: everywhere i go, there i am!

Re: dependency problem

Postby stevepusser » 2017-12-06 20:41

And the Joxi download page does not mention Debian:

Ubuntu, Mint, Kubuntu, Xubuntu and others


You might want to look as some other screenshot tools that are in the repos already, such as shutter, or in outside repos that are known to be Debian-compatible. Currently some of us at MX-Linux are working with the ksnip (not a KDE app) developer in packaging and testing the next release, for example.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8935
Joined: 2009-10-06 05:53

Re: dependency problem

Postby GarryRicketson » 2017-12-06 20:52

Has the OP all ready read this ? :
https://wiki.debian.org/DontBreakDebian
Debian Stable should not be combined with other releases. If you're trying to install software that isn't available in the current Debian Stable release, it's not a good idea to add repositories for other Debian releases. The problems might not happen right away, but the next time you install updates.

The reason things can break is because the software packaged for one Debian release is built to be compatible with the rest of the software for that release. For example, installing packages from buster on a stretch system could also install newer versions of core libraries including libc6. This results in a system that is not testing or stable but a broken mix of the two.

Repositories that can create a FrankenDebian if used with Debian Stable:

Debian testing release (currently buster)

Debian unstable release (also known as sid)

Ubuntu, Mint or other derivative repositories are not compatible with Debian!
Ubuntu PPAs


After the update, there is a dependency problem.

This happens when some of the programs/packages are not from the Debian
repositories,...You could PM Bester69 he is a expert at working with strange brews, and frankie.
"What we expect you have already Done"

Before doing anything, read the Debian documentation:
Debian Documentation
How to ask the smart way
Debian Foro Español
======================
For the Birds
User avatar
GarryRicketson
 
Posts: 4439
Joined: 2015-01-20 22:16
Location: Durango, Mexico


Return to Hardware

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable