[SOLVED] Unable to connect to Bose speaker via Bluetooth

Getting your soundcard to work, using Debian on non-i386 hardware, etc

[SOLVED] Unable to connect to Bose speaker via Bluetooth

Postby extraspecialbitter » 2017-12-26 22:29

I recently purchased a Plugable Bluetooth USB adapter for the purpose of connecting to a Bose Soundlink Color II speaker. After working through several issues, the bluetooth adapter appears to function and pair with the device, but fails to connect - both via blueman-applet and bluetoothctl.

Some diagnostic data:

Code: Select all
pablo@eltriunfo=> systemctl status bluetooth
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)
   Active: active (running) since Sun 2017-12-24 17:33:22 EST; 1 day 23h ago
     Docs: man:bluetoothd(8)
 Main PID: 1971 (bluetoothd)
   Status: "Running"
   CGroup: /system.slice/bluetooth.service
           └─1971 /usr/lib/bluetooth/bluetoothd
pablo@eltriunfo=> rfkill list all
0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: dell-wifi: Wireless LAN
   Soft blocked: no
   Hard blocked: no
4: hci0: Bluetooth
   Soft blocked: no
   Hard blocked: no
pablo@eltriunfo=> bluetoothctl
[NEW] Controller 5C:F3:70:87:EE:C4 eltriunfo [default]
[NEW] Device 2C:41:A1:65:81:CC Bose Color II SoundLink
[bluetooth]# agent on
Agent registered
[bluetooth]# power on
Changing power on succeeded
[bluetooth]# paired-devices
Device 2C:41:A1:65:81:CC Bose Color II SoundLink
[bluetooth]# connect 2C:41:A1:65:81:CC
Attempting to connect to 2C:41:A1:65:81:CC
Failed to connect: org.bluez.Error.Failed


In blueman-applet, the device appears to connect, but fails right away. At no time am I able to hear sound.

I've also noticed that when I bring up pavucontrol, I don't see the Bose speaker listed as an option, which to me seems to confirm that the devices are pairing but not connecting.

I am running Debian 8.2 with the 3.16.0-4-amd64 kernel.

Thanks in advance.
Last edited by extraspecialbitter on 2017-12-27 21:44, edited 1 time in total.
extraspecialbitter
 
Posts: 42
Joined: 2007-03-28 16:55
Location: Boston, MA

Re: Unable to connect to Bose speaker via Bluetooth

Postby Dai_trying » 2017-12-26 22:53

I recently had a couple of issues setting up a bluetooth device and had to install the pulseaudio-module-bluetooth in order to get it to work (this was not a pure Debian install but on a derivative so YMMV)
Dai_trying
 
Posts: 422
Joined: 2016-01-07 12:25

Re: Unable to connect to Bose speaker via Bluetooth

Postby extraspecialbitter » 2017-12-27 13:37

Thanks for the reply. I believe I did install pulseaudio-module-bluetooth at some point in my troubleshooting, but I might not have stopped and restarted pulseaudio after doing so. I'll try this out when I get home from work today.

BTW I'm also using a Debian variant, in my case Bunsen Labs "Hydrogen", which uses Debian repos in a minimal setup.
extraspecialbitter
 
Posts: 42
Joined: 2007-03-28 16:55
Location: Boston, MA

Re: [SOLVED] Unable to connect to Bose speaker via Bluetooth

Postby extraspecialbitter » 2017-12-27 21:48

As suspected, pulseaudio-module-bluetooth was already installed, but apparently I hadn't stopped and restarted pulseaudio after the install.

Code: Select all
pulseaudio -k
pulseaudio --start


After pairing and connecting to the Bose speaker, it showed up in pavucontrol. From there, I was able to select it for playback, after which I brought up banshee and began to play music over the speaker. Life is good. :D
extraspecialbitter
 
Posts: 42
Joined: 2007-03-28 16:55
Location: Boston, MA


Return to Hardware

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable