NetGear WG111v2 [RealTek RTL8187L] doesn't work

Getting your soundcard to work, using Debian on non-i386 hardware, etc

NetGear WG111v2 [RealTek RTL8187L] doesn't work

Postby azewxc » 2018-01-06 12:43


I have bought a Netgear wifi usb dongle which was supposed to work under Debian (as mentioned here:
When I plug it, I can see several networks, but the connexion fails.

My OS version:
Code: Select all
xxxxxx@debian0:~$ uname -r

Code: Select all
xxxxxx@debian0:~$ cat /etc/debian_version

He is aware about my dongle:
Code: Select all
xxxxxx@debian0:~$ lsusb
Bus 001 Device 008: ID 0846:6a00 NetGear, Inc. WG111v2 54 Mbps Wireless [RealTek RTL8187L]

The driver is correctly loaded:
Code: Select all
xxxxxx@debian0:~$ lsmod |grep rtl
rtl8187                        40960  0
eeprom_93cx6           16384  1 rtl8187
mac80211                671744  1 rtl8187
btrtl                            16384  1 btusb
cfg80211                  589824  3 iwlwifi,mac80211,rtl8187
usbcore                    249856  8 uvcvideo,usbhid,usb_storage,xhci_pci,btusb,uas,rtl8187,xhci_hcd

I try to connect with NetworkManager (xfce), but it fails with no more information.
when I run nmcli i got:
Code: Select all
xxxxxx@debian0:~$ nmcli r wifi on
xxxxxx@debian0:~$ nmcli d wifi connect dd-wrt password DFlop125
Erreur : échec de l'activation de la connexion : (53) Le réseau Wi-Fi est introuvable.
# which means something like:
Error: connexion's activation fails: (53) The Wi-Fi network is unreachable.

When I try by setting the file /etc/networks/interfaces:
Code: Select all
root@debian0:~# ip a
4: wlx00146cb34d22: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 2a:89:0c:99:78:34 brd ff:ff:ff:ff:ff:ff
root@debian0:~# wpa_passphrase my_network passphrase

Code: Select all
# /etc/networks/interfaces:
auto wlx00146cb34d22
iface wlx00146cb34d22 inet dhcp
        wpa-ssid my_network
        wpa-psk my_hash

And then:
Code: Select all
root@debian0:~# ifup wlx00146cb34d22
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
ifup: failed to bring up wlx00146cb34d22

I don't know what to try next so if someone has an idea, he is welcome.

Posts: 3
Joined: 2018-01-06 11:45

Re: NetGear WG111v2 [RealTek RTL8187L] doesn't work

Postby bw123 » 2018-01-06 13:55

Yes it works. I have the wg111v3 (rtl8187b) it's a good old reliable dongle. It gets a little hot after an hour or so but never has cut out or cause me any real problems. Never had disconnection issues since the driver hit the kernel somewhere around linux 3.02 or it might have been 2.6 anyway there was an issue or two in the earlier kernels. My device does not require firmware, which is cool, but make sure your version doesn't either. Check dmesg just to be sure.

If you want to use the interfaces file, use kernel parameter net.ifnames=0 and then it will (probably) be wlan0 again.

if you want to use networkmanager, net.ifnames=0 will probably fix it too.

to use nm with the new long predictable interface naming scheme on older wifi G usb dongles like netgear:
make a file, /etc/NetworkManager/conf.d/10-rand-mac.conf
Code: Select all

restart nm to enable change.
User avatar
Posts: 3786
Joined: 2011-05-09 06:02

Re: NetGear WG111v2 [RealTek RTL8187L] doesn't work

Postby azewxc » 2018-01-06 14:50

I still have the same problem (but now the interface is called wlan0) and I have the version 2 of the dongle and not the 3 (I don't know if it make a difference).

The output of dmesg seems correct:
Code: Select all
root@debian0:~# dmesg |tail
[ 1628.688197] usb 1-1: new high-speed USB device number 10 using xhci_hcd
[ 1628.834328] usb 1-1: New USB device found, idVendor=0846, idProduct=6a00
[ 1628.834334] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1628.834337] usb 1-1: Product: NETGEAR WG111v2
[ 1628.834340] usb 1-1: Manufacturer: NETGEAR WG111v2
[ 1628.834342] usb 1-1: SerialNumber: 00146CB34D22
[ 1628.977108] ieee80211 phy3: Selected rate control algorithm 'minstrel_ht'
[ 1628.977733] ieee80211 phy3: hwaddr 00:14:6c:b3:4d:22, RTL8187vB (default) V1 + rtl8225z2, rfkill mask 2
[ 1628.989181] rtl8187: Customer ID is 0xFF
[ 1628.990261] rtl8187: wireless switch is on

Thanks for your answer.
Posts: 3
Joined: 2018-01-06 11:45

Re: NetGear WG111v2 [RealTek RTL8187L] doesn't work

Postby bw123 » 2018-01-06 15:41

Which method are you going to use? If you want to use nm, then your interfaces file can't mention wlan0 at all. I usually just leave it as bare as possible:
Code: Select all
auto lo
iface lo inet loopback

If you are going to use the interfaces method, then you don't even need networkmanager up and running. I haven't tried using interfaces file with it (networkmanager) even installed in years. This was supported in the past, but ifupdown is from the days when booting happened in a certain order, we're way past that now.

So it's possible you are using two methods at boot and it's causing a conflict.
User avatar
Posts: 3786
Joined: 2011-05-09 06:02

Re: NetGear WG111v2 [RealTek RTL8187L] doesn't work

Postby azewxc » 2018-01-06 16:18

I am trying only one at once, first with network-manager and if it does'nt work, with interfaces.

But there is something really weird. When I add the mac address of the dongle in /etc/NetworkManager/conf.d/10-rand-mac-conf, restart the daemon, try to connect via the GUI, fail and then do again an "ip a", my dongle get a new MAC address. It souldn't stay always the same (It's what is a MAC address after all) ?
Posts: 3
Joined: 2018-01-06 11:45

Return to Hardware

Who is online

Users browsing this forum: No registered users and 8 guests