[SOLVED] BenQ XL24230T Monitors not detected

Getting your soundcard to work, using Debian on non-i386 hardware, etc

[SOLVED] BenQ XL24230T Monitors not detected

Postby 0x7DEB » 2018-02-02 02:27

Hi there,

I have just installed Debian as my main operating system, the non-free firmware ISO image, Debian does not seem to detect my monitors. I'm a big fan of Debian and I love it. I was wondering if someone could help me make this work please :) If you would like more information from me please do not hesitate to ask. Please note that I am also new to the forums and I don't ask many questions.

Code: Select all
0x7DEB@debian:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1920 x 1080, maximum 1920 x 1080
default connected primary 1920x1080+0+0 0mm x 0mm
   1920x1080      0.00*
   1280x1024      0.00 
   1280x960       0.00 
   1024x768       0.00 
   800x600        0.00 
   640x480        0.00


Regards
0x7DEB
Last edited by 0x7DEB on 2018-02-03 22:29, edited 2 times in total.
0x7DEB
 
Posts: 3
Joined: 2018-02-02 02:21

Re: BenQ XL24230T Monitors not detected

Postby pawRoot » 2018-02-02 03:04

I guess you would need to provide more info... like what graphics card are you using, do you have drivers installed etc.
User avatar
pawRoot
 
Posts: 520
Joined: 2016-12-28 18:26
Location: Poland

Re: BenQ XL24230T Monitors not detected

Postby 0x7DEB » 2018-02-02 03:17

Hi there,

I'm so glad after a long time I have just managed to figure it out myself. The following solved my problems:

1) I entered the "dmesg" command to see what firmware failed to load which was highlighted in red which was polaris10_mc.bin

2) I searched for the name of the firmware with the keywords (Debian polaris10_mc.bin) on google which led me to the Debian website https://packages.debian.org/search?searchon=contents&keywords=amdgpu/polaris10_mc.bin

3) I downloaded the package and installed the package (firmware-amd-graphics_20161130-3_all.deb ) with the command "dpkg -i firmware-amd-graphics_20161130-3_all.deb" then I rebooted the machine so the kernel detects and loads the firmware and problem fixed :D

Sorry to bother you and thanks anyways, I hope this will help and solve someone's problem in the near future.

Regards
0x7DEB
0x7DEB
 
Posts: 3
Joined: 2018-02-02 02:21

Re: BenQ XL24230T Monitors not detected

Postby pawRoot » 2018-02-02 03:26

Ok glad you fixed it, would be nice if you can add SOLVED to topic name :wink:
User avatar
pawRoot
 
Posts: 520
Joined: 2016-12-28 18:26
Location: Poland


Return to Hardware

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable