[SOLVED] HDMI Audio: Lubuntu has, Debian doesn't?

Getting your soundcard to work, using Debian on non-i386 hardware, etc

[SOLVED] HDMI Audio: Lubuntu has, Debian doesn't?

Postby edtguy » 2018-02-08 20:46

I'm trying to understand why the output of aplay -l shows two cards for Lubuntu on a LattePanda 4Gb/64Gb, but only one card for Debian on a LattePanda 2Gb/32Gb.
I've installed Debian on the LattePanda 2Gb/32Gb from debian-9.3.0-amd64-i386-netinst.iso because it appears to be the only distro that installs on that device.
With both devices, I have an Element HD TV connected to the hdmi port of the device. The video is working fine for both.
The output of aplay -l for Lubuntu shows the following:

**** List of PLAYBACK Hardware Devices ****
card 0: Audio [Intel HDMI/DP LPE Audio], device 0: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Audio [Intel HDMI/DP LPE Audio], device 1: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Audio [Intel HDMI/DP LPE Audio], device 2: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 2: chtrt5645 [chtrt5645], device 0: 3 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: chtrt5645 [chtrt5645], device 1: Deep-Buffer Audio (*) []
Subdevices: 1/1
Subdevice #0: subdevice #0

The output for Debian only shows the chtrt5645 card.

Any clues how to make the other card appear?
Last edited by edtguy on 2018-02-09 16:27, edited 1 time in total.
edtguy
 
Posts: 5
Joined: 2018-02-06 02:59

Re: HDMI Audio: What does Lubuntu have that Debian doesn't?

Postby stevepusser » 2018-02-08 21:00

The Science! demands that you test on the same device...see what Debian reports on the 4GB Latte that you have Lubuntu installed on.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, tlp-ui, wine-staging 3.21, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10250
Joined: 2009-10-06 05:53

Re: HDMI Audio: What does Lubuntu have that Debian doesn't?

Postby smoki » 2018-02-09 12:25

edtguy wrote: Any clues how to make the other card appear?


Support for that was added a year ago via HDMI_LPE_AUDIO:

https://patchwork.kernel.org/patch/9470077/

https://git.kernel.org/pub/scm/linux/ke ... /sound/x86

Further stabilised up to the middle of last year, blah blah :D So make sure your kernel have HDMI_LPE_AUDIO enabled:

Also for alsa, this is where conf is added:

conf: Add card config for Intel HDMI/DP LPE audio

http://alsa-project.org/main/index.php/ ... 1.3_v1.1.4
https://patchwork.kernel.org/patch/9561057/

Basically bump kernel and alsa (or just patch existent alsa version with a conf or put a conf in a directory or you know what :D) and it should be setuped fine.

You can browse on https://www.kernel.org/ and see path 'sound/x86' is there for kernel 4.14 and up, but for 4.9 it isn't there... which means it was added somewhere in between (to be stright that was there since 4.11 https://kernelnewbies.org/Linux_4.11)... simply said - newer kernel is needed if you want that to appear, so try 4.14 kernel from backports repo ;)
User avatar
smoki
 
Posts: 143
Joined: 2011-08-03 05:04
Location: Srbija, kude snajka posvađa dva sina

Re: HDMI Audio: What does Lubuntu have that Debian doesn't?

Postby edtguy » 2018-02-09 16:10

smoki wrote:simply said - newer kernel is needed if you want that to appear, so try 4.14 kernel from backports repo ;)

D'oh! I had a typo in sources.list for the backports, so only saw kernels up to 4.9.0-5
Thank you! I corrected the typo, installed 4.14, and now have hdmi sound.
Cheers,
Ed
edtguy
 
Posts: 5
Joined: 2018-02-06 02:59


Return to Hardware

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable