Nvidia stopped working, and disappeared. [Solved]

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Nvidia stopped working, and disappeared. [Solved]

Postby bahha » 2018-03-01 17:30

Hi everyone
My Nvidia Optimus stopped working it used to work well, but after the latest upgrade, now it's not even showing in the devices list .
It used to work fine with optirun .
I'm on Debian Buster Stable .
Code: Select all
Distributor ID:   Debian
Description:   Debian GNU/Linux 9.3 (stretch)
Release:   9.3
Codename:   stretch

Code: Select all
 Kernel:  linux-image-4.9.0-6-amd64   4.9.82-1+deb9u2

Code: Select all
Driver version : 375.82


listing devices :
Code: Select all
lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)


loading the modules:
Code: Select all
sudo modprobe nvidia-current
modprobe: ERROR: could not insert 'nvidia_current': No such device

Nvidia Packages:
Code: Select all
sudo dpkg --list | grep nvidia
ii  glx-alternative-nvidia                0.7.4                                       amd64        allows the selection of NVIDIA as GLX provider
ii  libegl-nvidia0:amd64                  375.82-1~deb9u1                             amd64        NVIDIA binary EGL library
ii  libegl1-glvnd-nvidia:amd64            375.82-1~deb9u1                             amd64        Vendor neutral GL dispatch library -- libEGL
ii  libgl1-nvidia-glx:amd64               375.82-1~deb9u1                             amd64        NVIDIA binary OpenGL/GLX library (non-GLVND variant)
ii  libgldispatch0-nvidia:amd64           375.82-1~deb9u1                             amd64        Vendor neutral GL dispatch library -- libGLdispatch
ii  libgles-nvidia1:amd64                 375.82-1~deb9u1                             amd64        NVIDIA binary OpenGL|ES 1.x library
ii  libgles-nvidia2:amd64                 375.82-1~deb9u1                             amd64        NVIDIA binary OpenGL|ES 2.x library
ii  libgles1-glvnd-nvidia:amd64           375.82-1~deb9u1                             amd64        NVIDIA binary OpenGL|ES 1.x GLVND stub library
ii  libgles2-glvnd-nvidia:amd64           375.82-1~deb9u1                             amd64        NVIDIA binary OpenGL|ES 2.x GLVND stub library
ii  libglx-nvidia0:amd64                  375.82-1~deb9u1                             amd64        NVIDIA binary GLX library
ii  libglx0-glvnd-nvidia:amd64            375.82-1~deb9u1                             amd64        Vendor neutral GL dispatch library -- libGLX
ii  libnvidia-cfg1:amd64                  375.82-1~deb9u1                             amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-eglcore:amd64               375.82-1~deb9u1                             amd64        NVIDIA binary EGL core libraries
ii  libnvidia-glcore:amd64                375.82-1~deb9u1                             amd64        NVIDIA binary OpenGL/GLX core libraries
ii  libnvidia-ml1:amd64                   375.82-1~deb9u1                             amd64        NVIDIA Management Library (NVML) runtime library
ii  libopengl0-glvnd-nvidia:amd64         375.82-1~deb9u1                             amd64        Vendor neutral GL dispatch library -- libOpenGL
ii  nvidia-alternative                    375.82-1~deb9u1                             amd64        allows the selection of NVIDIA as GLX provider
ii  nvidia-detect                         375.82-1~deb9u1                             amd64        NVIDIA GPU detection utility
ii  nvidia-driver                         375.82-1~deb9u1                             amd64        NVIDIA metapackage
ii  nvidia-driver-bin                     375.82-1~deb9u1                             amd64        NVIDIA driver support binaries
ii  nvidia-driver-libs:amd64              375.82-1~deb9u1                             amd64        NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries)
ii  nvidia-egl-common                     375.82-1~deb9u1                             amd64        NVIDIA binary EGL driver - common files
ii  nvidia-egl-icd:amd64                  375.82-1~deb9u1                             amd64        NVIDIA EGL installable client driver (ICD)
ii  nvidia-installer-cleanup              20151021+4                                  amd64        cleanup after driver installation with the nvidia-installer
ii  nvidia-kernel-common                  20151021+4                                  amd64        NVIDIA binary kernel module support files
ii  nvidia-kernel-dkms                    375.82-1~deb9u1                             amd64        NVIDIA binary kernel module DKMS source
ii  nvidia-kernel-support                 375.82-1~deb9u1                             amd64        NVIDIA binary kernel module support files
ii  nvidia-legacy-check                   375.82-1~deb9u1                             amd64        check for NVIDIA GPUs requiring a legacy driver
ii  nvidia-modprobe                       375.26-1                                    amd64        utility to load NVIDIA kernel modules and create device nodes
ii  nvidia-persistenced                   375.26-2                                    amd64        daemon to maintain persistent software state in the NVIDIA driver
ii  nvidia-settings                       375.66-1                                    amd64        tool for configuring the NVIDIA graphics driver
ii  nvidia-smi                            375.82-1~deb9u1                             amd64        NVIDIA System Management Interface
ii  nvidia-support                        20151021+4                                  amd64        NVIDIA binary graphics driver support files
ii  nvidia-vdpau-driver:amd64             375.82-1~deb9u1                             amd64        Video Decode and Presentation API for Unix - NVIDIA driver
ii  xserver-xorg-video-nvidia             375.82-1~deb9u1                             amd64        NVIDIA binary Xorg driver

Grub cfg :
Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi=Linux"

Things I tried :
    - purged the nvidia driver and reinstalled it .
    - tried the Kernel : 4.13.0-0.bpo.1-amd64 of course with Kernel Headers.
    - disable and enabled the dual GPU from Bios ,
    - It's Working fine on Windows 10 .
    - boot to older Kernels.
Last edited by bahha on 2018-03-01 18:05, edited 2 times in total.
bahha
 
Posts: 3
Joined: 2018-03-01 17:05

Re: Nvidia stopped working, and disappeared.

Postby Head_on_a_Stick » 2018-03-01 17:44

bahha wrote:listing devices :
Code: Select all
lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

Discrete GPUs are usually listed as "3D" rather than "VGA" but we can grep the bus addresses instead:
Code: Select all
lspci -knn | grep -A2 '\''[030[02]\]'

Hardware failure is a possibility, is the card detected if you load a "live" ISO image?
dbruce wrote:Ubuntu forums try to be like a coffee shop in Seattle. Debian forums strive for the charm and ambience of a skinhead bar in Bacau. We intend to keep it that way.
User avatar
Head_on_a_Stick
 
Posts: 8315
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Nvidia stopped working, and disappeared.

Postby bahha » 2018-03-01 17:50

Head_on_a_Stick wrote:
bahha wrote:listing devices :
Code: Select all
lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

Discrete GPUs are usually listed as "3D" rather than "VGA" but we can grep the bus addresses instead:
Code: Select all
lspci -knn | grep -A2 '\''[030[02]\]'

Hardware failure is a possibility, is the card detected if you load a "live" ISO image?


Thanks for the suggestions .
I thought it was a hardware failure but,
It works fine on Windows 10 even played a game to make sure.
here is the output of your command:
Code: Select all
 lspci -knn | grep -A2 '\''[030[02]\]'
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
   Subsystem: Lenovo 3rd Gen Core processor Graphics Controller [17aa:3904]
   Kernel driver in use: i915
bahha
 
Posts: 3
Joined: 2018-03-01 17:05

Re: Nvidia stopped working, and disappeared.

Postby Head_on_a_Stick » 2018-03-01 17:56

Well that looks like the card is off the bus, check the connections perhaps?

Also double-check the full output of plain `lspci` just in case my grep is too clever for it's own good.
dbruce wrote:Ubuntu forums try to be like a coffee shop in Seattle. Debian forums strive for the charm and ambience of a skinhead bar in Bacau. We intend to keep it that way.
User avatar
Head_on_a_Stick
 
Posts: 8315
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Nvidia stopped working, and disappeared.

Postby bahha » 2018-03-01 18:03

Head_on_a_Stick wrote:Well that looks like the card is off the bus, check the connections perhaps?

Also double-check the full output of plain `lspci` just in case my grep is too clever for it's own good.

Thanks :D ,
I solved it by adding this to grub .
Code: Select all
acpi_osi="!Windows 2015"
bahha
 
Posts: 3
Joined: 2018-03-01 17:05


Return to Hardware

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable