[solved] HP LaserJet Pro M12w

Getting your soundcard to work, using Debian on non-i386 hardware, etc

[solved] HP LaserJet Pro M12w

Postby mariannemarlow » 2018-03-16 11:50

I stupidly bought a printer thinking that it would work with Linux without checking first.

Can anyone help me make my HP LaserJet Pro M12w printer work with Debian 9?

I have a netbook, so no CD drive.

Thanks for any replies!

Marianne
Last edited by mariannemarlow on 2018-03-16 22:19, edited 1 time in total.
mariannemarlow
 
Posts: 5
Joined: 2018-03-16 11:45

Re: HP LaserJet Pro M12w

Postby arochester » 2018-03-16 13:01

Install hplip-gui ?
arochester
 
Posts: 1310
Joined: 2010-12-07 19:55

Re: HP LaserJet Pro M12w

Postby mariannemarlow » 2018-03-16 13:13

arochester wrote:Install hplip-gui ?


Hi there

I already did that. I still cannot get it to work.

I try and set up the device (connected by usb) and it does not detect it.
mariannemarlow
 
Posts: 5
Joined: 2018-03-16 11:45

Re: HP LaserJet Pro M12w

Postby GarryRicketson » 2018-03-16 13:35

Normally the HP printers work fine on Debian, so you must have not done something, or did something wrong. How ever, you don't give us much details to work with

arochester wrote:
Install hplip-gui ?

And you say you did that, but it does not work,.. so what else have you done , exactly, so we don't need to play guessing games, and every time some one suggests trying something, it turns out you all ready did that.
Did you install all the hplip packages ? Have you read any documentation at all ? Like : https://wiki.debian.org/SystemPrinting
Do you have the print server packages installed as well ?

I try and set up the device (connected by usb) and it does not detect it.

Exactly what do you do when you try ? Is the printer even turned on, ?
Even though you installed the GUI, Did you try any other commands , like :
Code: Select all
hp-setup

Troubleshoot printing

Run:
Code: Select all
sudo hp-check -r

Did you install the other HPLIP packages needed ?
https://packages.debian.org/stretch/hplip
Package: hplip (3.16.11+repack0-3)
The GUI by itself is not of much use.
I hope you get the idea now, and realize , we need to know everything you did, and what error messages say, etc,... Also, there is a fair amount of documentation available , that goes into details step by step,.. Do you need links posted to those ? or have you tried that as well ? (search engine)
User avatar
GarryRicketson
 
Posts: 5039
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: HP LaserJet Pro M12w

Postby mariannemarlow » 2018-03-16 14:35

Thank you for your warm welcome.

I should tell you that I am not good at reading and understanding long instructions. I am also not that technical.
When I do pick up some technical knowledge I seem to forget it easily, this could be due to the medication I take.

The HPLIP GUI does work, but it does not detect the printer.

When I run HPLIP with the printer plugged in and switched on I get this:

Image

Please kindly direct me toward the hplip packages and print server packages to which you refer?

I ran: sudo hp-check -r

and got all of this text, apologies that there is so much

Code: Select all
HP Linux Imaging and Printing System (ver. 3.16.11)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
Searching... (bus=usb, search=(None), desc=0)
error: No devices found on bus: usb
Searching... (bus=usb, search=(None), desc=0)
error: No devices found on bus: usb

Done.
root@marianne:/home/marianne# sudo hp-check -r
Saving output in log file: /home/marianne/hp-check.log

HP Linux Imaging and Printing System (ver. 3.16.11)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.                                   
2. Run-time check mode (-r or --run): Use this mode to determine if a distro   
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball   
has the proper dependencies installed to successfully run.                     
3. Both compile- and run-time check mode (-b or --both) (Default): This mode   
will check both of the above cases (both compile- and run-time dependencies).   

Check types:                                                                   
a. EXTERNALDEP - External Dependencies                                         
b. GENERALDEP - General Dependencies (required both at compile and run time)   
c. COMPILEDEP - Compile time Dependencies                                       
d. [All are run-time checks]                                                   
PYEXT SCANCONF QUEUES PERMISSION                                               

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

\
warning: 2-9.4 version is not supported. Using 2-8.6 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 4.9.0-6-686-pae #1 SMP Debian 4.9.82-1+deb9u3 (2018-03-02) GNU/Linux
 Host: marianne
 Proc: 4.9.0-6-686-pae #1 SMP Debian 4.9.82-1+deb9u3 (2018-03-02) GNU/Linux
 Distribution: 2 9.4
 Bitness: 32 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.16.11
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 2 distro  9.4 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.16.11

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.16.11
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
warning: Could not access file: No such file or directory
 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

--------------
| COMPILEDEP |
--------------

 gcc                  gcc - GNU Project C and C++ Compiler                         REQUIRED        -               6.3.0           OK         -
 make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.1             OK         -
 error: libtool       libtool - Library building support services                  REQUIRED        -               -               MISSING    'libtool needs to be installed'

-------------------------
| External Dependencies |
-------------------------

 error: cups          CUPS - Common Unix Printing System                           REQUIRED        1.1             -               INCOMPAT   'CUPS may not be installed or not running'
 error: avahi-utils   avahi-utils                                                  OPTIONAL        -               -               MISSING    'avahi-utils needs to be installed'
 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.20            OK         -
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
 xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.25          OK         -
 network              network -wget                                                OPTIONAL        -               1.18            OK         -
 dbus                 DBus - Message bus system                                    REQUIRED        -               1.10.26         OK         -

----------------------
| Scan Configuration |
----------------------

 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.16.11         OK         -
'/etc/sane.d/dll.d/hpaio' not found.
 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.16.11         OK         'hpaio found in /etc/sane.d/dll.conf'

---------------------
| Python Extentions |
---------------------

 hpmudext             IO-Extension                                                 REQUIRED        -               3.16.11         OK         -
 cupsext              CUPS-Extension                                               REQUIRED        -               3.16.11         OK         -

------------------------
| General Dependencies |
------------------------

 libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.24'         OK         -
 error: sane-devel    SANE - Scanning library development files                    REQUIRED        -               -               MISSING    'sane-devel needs to be installed'
 error: cups-devel    CUPS devel- Common Unix Printing System development files    REQUIRED        -               -               MISSING    'cups-devel needs to be installed'
 error: python3-devel Python devel - Python development files                      REQUIRED        2.2             3.5.3           MISSING    'python3-devel needs to be installed'
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.4           OK         -
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             -               MISSING    'python3-pyqt4 needs to be installed'
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.3.0           OK         -
 error: libcrypto     libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.0           MISSING    'libcrypto needs to be installed'
 error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             -               MISSING    'python3-pyqt4-dbus needs to be installed'
 sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
 error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           -               MISSING    'libnetsnmp-devel needs to be installed'
 python3-notify2      Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               OK         -
 error: libjpeg       libjpeg - JPEG library                                       REQUIRED        -               -               MISSING    'libjpeg needs to be installed'
 error: libusb        libusb - USB library                                         REQUIRED        -               1.0             MISSING    'libusb needs to be installed'
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.5.3           OK         -
 error: cups-image    CUPS image - CUPS image development files                    REQUIRED        -               -               MISSING    'cups-image needs to be installed'
 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               1.1.7           OK         -
 python3-xml          Python XML libraries                                         REQUIRED        -               2.2.0           OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

-
No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
HP-LaserJet-Pro-M201-M202
-------------------------
Type: Unknown
Device URI: usb://HP/LaserJet%20Pro%20M12w?serial=0000000005Q0BPJEPR1a
PPD: /etc/cups/ppd/HP-LaserJet-Pro-M201-M202.ppd
PPD Description: HP LaserJet Pro M201-M202 Postscript (recommended)
Printer status: printer HP-LaserJet-Pro-M201-M202 is idle.  enabled since Fri 16 Mar 2018 14:56:30 GMT
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.

HP-LaserJet-Pro-MFP-m125a
-------------------------
Type: Unknown
Device URI: implicitclass:HP-LaserJet-Pro-MFP-m125a
PPD: /etc/cups/ppd/HP-LaserJet-Pro-MFP-m125a.ppd
PPD Description: Remote printer: HP LaserJet Pro MFP m125a, hpcups 3.14.3, requires proprietary plugin
Printer status: printer HP-LaserJet-Pro-MFP-m125a is idle.  enabled since Fri 16 Mar 2018 12:19:29 GMT
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.

HP_LaserJet_Pro_M12w
--------------------
Type: Unknown
Device URI: usb://HP/LaserJet%20Pro%20M12w?serial=0000000005Q0BPJEPR1a
PPD: /etc/cups/ppd/HP_LaserJet_Pro_M12w.ppd
PPD Description: HP LaserJet Pro P1102w Foomatic/foo2zjs-z2 (recommended)
Printer status: printer HP_LaserJet_Pro_M12w disabled since Thu 15 Mar 2018 17:33:17 GMTreason unknown
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.

MP460
-----
Type: Unknown
Device URI: implicitclass:MP460
PPD: /etc/cups/ppd/MP460.ppd
PPD Description: Remote printer: Canon MP460 series - CUPS+Gutenprint v5.2.10-pre2
Printer status: printer MP460 is idle.  enabled since Fri 16 Mar 2018 12:19:29 GMT
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.


--------------
| PERMISSION |
--------------

error: Unsupported model: HP_LaserJet_Pro_M12w
 
-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'libtool' package is missing/incompatible
error: 'libtool-bin' package is missing/incompatible
error: 'cups' package is missing or 'cups' service is not running.
error: 'libcups2' package is missing/incompatible
error: 'libsane-dev' package is missing/incompatible
error: 'libcups2-dev' package is missing/incompatible
error: 'cups-bsd' package is missing/incompatible
error: 'cups-client' package is missing/incompatible
error: 'python3-dev' package is missing/incompatible
error: 'python3-pyqt4' package is missing/incompatible
error: 'gtk2-engines-pixbuf' package is missing/incompatible
error: 'libssl-dev' package is missing/incompatible
error: 'libsnmp-dev' package is missing/incompatible
error: 'snmp' package is missing/incompatible
error: 'libjpeg62-turbo-dev' package is missing/incompatible
error: 'libusb-1.0.0-dev' package is missing/incompatible
error: 'libcupsimage2' package is missing/incompatible
error: 'libcupsimage2-dev' package is missing/incompatible

Missing Optional Dependencies
-----------------------------
error: 'avahi-utils' package is missing/incompatible
error: 'python3-dbus.mainloop.qt' package is missing/incompatible

Total Errors: 13
Total Warnings: 5
mariannemarlow
 
Posts: 5
Joined: 2018-03-16 11:45

Re: HP LaserJet Pro M12w

Postby shep » 2018-03-16 14:39

This is not an average HP printer - it uses the ZjStream printing protocol.
It also is new enough that it is not supported by the older hplip version in Debian 9.
error: Unsupported model: HP_LaserJet_Pro_M12w


This particular printer has been tested w/ foo2zjs and reported to work (scroll down to the Supported Printer table).

http://foo2zjs.rkkda.com/

HP may also supply a driver in the latest hplip package although other ZjStream drivers will partially work

https://askubuntu.com/questions/900272/laserjet-pro-m12w

Depending on the Version of Debian you are running, your options are:

1) Use the older HP laserjet pro M1102W ppd
2) Delete Debian's hplip and install the latest from HP
3) Delete Debian's hplip and install foo2zjs from the website.


Note: Backports does not currently show updated hplip or foo2zjs and the foo2zfs changelog shows support for your printer was added last December
http://foo2zjs.rkkda.com/ChangeLog

The foo2zjs driver would be a good candidate for backports - no python dependencies to deal with.

This forum has some posts where the steps to install foo2zfs were listed and that is the tact I would try first. They should come up with a forum search for "foo2zfs".

Edits: multiple grammar corrections
Last edited by shep on 2018-03-16 23:05, edited 7 times in total.
shep
 
Posts: 215
Joined: 2011-03-15 15:22

Re: HP LaserJet Pro M12w

Postby mariannemarlow » 2018-03-16 15:37

Thanks so much Shep for the useful advice.

I went to http://foo2zjs.rkkda.com/ and followed instructions.

I got as far as "Now create printer entries for your spooler." and now I am at a loss as to what I am meant to do!

How do I create a printer queue?

This seems just too complicated for me. I wish I had not bought the printer.
mariannemarlow
 
Posts: 5
Joined: 2018-03-16 11:45

Re: HP LaserJet Pro M12w

Postby srq2625 » 2018-03-16 16:21

I also have a newer HP printer that is not supported by 3.16.11. I did some research on the HP site to determine that the latest driver would support my printer. So I download their most recent driver (ver 3.17.10) available at the time I was first successful and attempt to install that. The installer didn't support Debian 9.2 (which is what I had at the time).

So, I downloaded the most recent tarball, did a little research to determine dependencies (they do list them on their site), install those dependencies, and then compile the driver from the source in the tarball (they also provide instructions on how to do that).

I should mention that the instructions I found on their website were a bit dated so I had to apply what little intelligence I have to fill in the gaps.

Here's what has worked for me:
Code: Select all
$ su -c "apt-get install --force-yes -y avahi-utils cups libcups2 libcups2-dev cups-bsd cups-client libcupsimage2 libcupsimage2-dev libdbus-1-dev g++ ghostscript ghostscript-cups ghostscript-x libssl-dev libjpeg62-turbo-dev libsnmp-dev snmp libc6 libtool libtool-bin libusb-1.0.0-dev make wget policykit-1 policykit-1-gnome python3-dbus python3-gi python3-dev python3-notify2 python3-pil python3-pyqt4 gtk2-engines-pixbuf python3-dbus.mainloop.qt python3-reportlab python3-lxml sane libsane-dev sane-utils xsane python-dev"

$ tar xf ./hplip-3.17.10.tar.gz

$ cd hplip-3.17.10/

$ ./configure --prefix=/usr --with-hpppddir=/usr/share/ppd/HP --libdir=/usr/lib/x86_64-linux-gnu --enable-qt4 --enable-hpcups-install --enable-cups-drv-install --disable-cups-ppd-install --disable-hpijs-install --disable-foomatic-drv-install --disable-foomatic-ppd-install --disable-foomatic-rip-hplip-install --enable-fax-build --enable-dbus-build --enable-network-build --enable-scan-build --disable-policykit --disable-libusb01_build --disable-udev_sysfs_rules --enable-doc-build

$ make

$ su -c "make install"

$ hp-plugin


The makefile that comes in the tarball also includes an "uninstall" target - so it might be a good idea to keep the source directory around should you decide to update/uninstall the driver.

Of course, those with more on the ball than me would take the tarball source code and build a right and proper .deb file and install that.
srq2625
 
Posts: 44
Joined: 2016-02-26 11:01

Re: HP LaserJet Pro M12w

Postby mariannemarlow » 2018-03-16 16:55

Thank you srq2625 for sharing this with me, it's very kind of you.

I discovered that if I went to settings/print settings and added the printer there, it detected it.

I had to select the driver for LaserJet Pro P1102w and it only prints pdf's but I can work with that :)

Thanks all for the advice.

Marianne
mariannemarlow
 
Posts: 5
Joined: 2018-03-16 11:45

Re: [solved] HP LaserJet Pro M12w

Postby shep » 2018-03-18 16:27

I got as far as "Now create printer entries for your spooler." and now I am at a loss as to what I am meant to do!


For future readers, cups is the spooler. Hplip also uses cups as a spooler

If you use foo2zjs, hplip is not needed. Cups is needed. When foo2zjs prompts you to create printer entries for your spooler, open the cups web configuration interface in your browser
https://wiki.archlinux.org/index.php/CUPS#Web_interface
shep
 
Posts: 215
Joined: 2011-03-15 15:22

Re: [solved] HP LaserJet Pro M12w

Postby stevepusser » 2018-03-18 18:40

Hplip 3.17.10 from upstream Debian will backport to Stretch, but requires a non-obvious tweak that I discovered almost by accident. 3.17.10 by default uses all available cores to build, and that works on upstream Debian but causes the build to fail on Stretch on any machine with multi-core processors, so you have to add a special flag to limit the build to just one thread.

http://mxrepo.com/mx/testrepo/pool/test/h/hplip/
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.6, Pale Moon 28.0.1, wine-staging 3.15, qBittorrent 4.1.2, Linux kernel 4.18.6, virtualbox 5.2.18
User avatar
stevepusser
 
Posts: 9898
Joined: 2009-10-06 05:53


Return to Hardware

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable