no audio on laptop headphones

Getting your soundcard to work, using Debian on non-i386 hardware, etc

no audio on laptop headphones

Postby babcat » 2018-05-24 08:07

On this laptop, with the V8237 [VIA 8237] audio card I cannot control headphone audio at all. They do not appear in pavucontrol or in alsamixer. I can hear a slight hiss signal but not audio from the player (I test with vlc). The headphones are tested ok, the audio from the laptop speaker distorts in the bass range but maybe it is a speaker defect. I remember this happened after the installation of openchrome drivers, but maybe other packages were installed as well. Maybe reinstalling the kernel can help? Upgrading pulseaudio and pavucontrol did not help.
Code: Select all
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: V8237 [VIA 8237], device 0: VIA 8237 [VIA 8237]
  Subdevices: 4/4
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
card 0: V8237 [VIA 8237], device 1: VIA 8237 [VIA 8237]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

pulseaudio -v
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Η λειτουργία δεν επιτρέπεται
I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Η λειτουργία δεν επιτρέπεται
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 10.0
I: [pulseaudio] main.c: Page size is 4096 bytes
I: [pulseaudio] main.c: Machine ID is 677d29d0db7c4cdfa1f5198c674951c1.
I: [pulseaudio] main.c: Session ID is 2.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/alexia/.config/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-10.0/modules.
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: Αποτυχία pa_pid_file_create().

babcat
 
Posts: 21
Joined: 2018-04-11 09:22

Re: no audio on laptop headphones

Postby babcat » 2018-05-24 10:44

The chipset is realtek alc655.
Same issues with debian9-xfce live cd

Code: Select all
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
        Subsystem: Fujitsu Technology Solutions VT8233/A/8235/8237 AC97 Audio Controller
        Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Interrupt: pin C routed to IRQ 22
        Region 0: I/O ports at 1800 [size=256]
        Capabilities: <access denied>
        Kernel driver in use: snd_via82xx
        Kernel modules: snd_via82xx
babcat
 
Posts: 21
Joined: 2018-04-11 09:22


Return to Hardware

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable