cpu fan disabled after suspend

Getting your soundcard to work, using Debian on non-i386 hardware, etc

cpu fan disabled after suspend

Postby Capsicum » 2018-06-15 19:58

I can not find the configuration that is causing Debian to override my UEFI fan speed, I need a direction to dig.
I have set the CPU fan speed in uefi and it works as expected from a fresh boot, but if my system goes to suspend then after waking the cpu-fan just sits and twitches or if I give it a fast spin with my finger it will maintain about 100rpm.
This started in december 2017, my workaround for expediency was just to plug the cpu-fan into a system-fan header.
I have tried a couple speed profiles in uefi, selecting suspend from the graphical menu, "systemctl suspend" from a GUI terminal as well as after booting into multi-user.target
(off topic a bit; if I start in graphical and move to a tty and "systemctl isolate multi-user.target" then switch between tty's with alt-F# and happen to hit alt-F8 the display freezes(but background music from pianobar on tty2 keeps playing) only solution seemed to be ctl-alt-del, did it twice to make sure)

System info:
desktop, Gigabyte ga990fxa-ud3 rev4.0, AMD fx8320
Debian Stretch Xfce
uname: 4.16.0-0.bpo.1-amd64 #1 SMP Debian 4.16.5-1~bpo9+1
(this also occurred with 4.15 bpo and possibly some another kernel version that I can not remember)
I have virtualization disabled in firmware, most if not all acpi options turned on, and C6 core-state enabled.
Capsicum
 
Posts: 1
Joined: 2018-06-15 18:27

Re: cpu fan disabled after suspend

Postby debiman » 2018-06-16 07:10

i found this:
http://www.tomshardware.co.uk/answers/i ... -mode.html
it seems downgrading the bios helped.
User avatar
debiman
 
Posts: 2790
Joined: 2013-03-12 07:18


Return to Hardware

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable