Screen resulution is wrong. [Solved]

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Screen resulution is wrong. [Solved]

Postby alexmalmis » 2018-07-05 10:53

Hi after a debian 9 stretch minimal install with i3wm my screen resulution is 800 x 600 and it should be 1440 x 900.
The output of xrandr is
Code: Select all
alexmalmis@PC:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 600, current 800 x 600, maximum 800 x 600
default connected 800x600+0+0 0mm x 0mm
   800x600       75.00*

Maybe the drivers is not installed. The output of lspci | grep VGA is
Code: Select all
alexmalmis@PC:~$ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti PRO [Radeon HD 7950/8950 OEM / R9 280]

I'll be thankfull for any help.
Last edited by alexmalmis on 2018-07-05 12:18, edited 1 time in total.
alexmalmis
 
Posts: 8
Joined: 2018-07-05 10:44

Re: Screen resulution is worng.

Postby bw123 » 2018-07-05 11:33

Since you did not mention firmware, my first guess is, you need firmware. Go thru the wiki and see if you can get it working.
https://wiki.debian.org/AtiHowTo

Look thru the whole output of lspci and make sure you have only one display device. There are a few systems with hybrid graphics.
User avatar
bw123
 
Posts: 3279
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Screen resulution is worng.

Postby alexmalmis » 2018-07-05 11:45

Well here is the output for lspci
Code: Select all
alexmalmis@PC:~$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1c.6 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 7 (rev b5)
00:1c.7 PCI bridge: Intel Corporation 82801 PCI Bridge (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation H67 Express Chipset Family LPC Controller (rev 05)
00:1f.2 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
00:1f.5 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 2 port SATA IDE Controller (rev 05)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti PRO [Radeon HD 7950/8950 OEM / R9 280]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti HDMI Audio [Radeon HD 7870 XT / 7950/7970]
03:00.0 IDE interface: VIA Technologies, Inc. VT6415 PATA IDE Host Controller
04:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
06:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 01)

linux-firmware-free is installed but when I try to install linux-firmware it says
Code: Select all
sudo apt-get install firmware-linux
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package firmware-linux is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'firmware-linux' has no installation candidate
alexmalmis
 
Posts: 8
Joined: 2018-07-05 10:44

Re: Screen resulution is worng.

Postby bw123 » 2018-07-05 11:55

Don't stab blindly, that is a classic newbie mistake. Follow instructions in the wiki. Add non-free and contrib to sources.list and install the firmware-amd-graphics pkg. If that doesn't get it working, then try backports for a newer kernel and firmware.

There are instructions in there about how to confirm the firmware is loading, check dmesg.
User avatar
bw123
 
Posts: 3279
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Screen resulution is worng.

Postby alexmalmis » 2018-07-05 12:17

Thanks so much!!! No my screen resulutuion is normal.. yaaay!
alexmalmis
 
Posts: 8
Joined: 2018-07-05 10:44


Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable