usb audio devices steal index 0

Getting your soundcard to work, using Debian on non-i386 hardware, etc

usb audio devices steal index 0

Postby cajmere » 2018-08-12 13:18

Hi,


I've got 2 usb audio device, a midi controller and a usb midisport for midi outputs/inputs.

In /etc/modprobe.d/alsa-base.conf there's a rule:
options snd-usb-audio index=-1

Normally, usb audio shouldn't index 0 as a remember correct like this, but unfortunately they steal sometimes index 0, in that case
i don't have audio.

Index 0 should always be my internal soundcard on my motherboard.
How can i prevent usb audio from taking index 0?


Thank you,
Stijn
cajmere
 
Posts: 17
Joined: 2014-05-19 17:54

Re: usb audio devices steal index 0

Postby bw123 » 2018-08-12 13:35

What debian ver are you using? I don't have anything in /etc/modprobe.d but I do have /lib/modprobe.d/aliases.conf that has some similar settings.

Code: Select all
$ grep snd /lib/modprobe.d/aliases.conf
options snd-pcsp index=-2
options snd-usb-audio index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
$ apt policy alsa-utils
alsa-utils:
  Installed: 1.1.3-1
  Candidate: 1.1.3-1
  Version table:
 *** 1.1.3-1 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
$ apt policy kmod
kmod:
  Installed: 23-2
  Candidate: 23-2
  Version table:
 *** 23-2 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status

User avatar
bw123
 
Posts: 3532
Joined: 2011-05-09 06:02
Location: TN_USA

Re: usb audio devices steal index 0

Postby cajmere » 2018-08-13 13:43

I'm using debian testing/unstable.

Just found the file also and it has same settings as yours.
This morning i changed the option to index= -2 instead of -1 and after a reboot usb audio devices didn't steal index 0 anymore.
(i have no id what is so different on -2 and -1)
hopefully it stays like this in the future.

Thank you for your input.

Stijn
cajmere
 
Posts: 17
Joined: 2014-05-19 17:54

Re: usb audio devices steal index 0

Postby cajmere » 2018-08-18 11:33

back to the beginning.


Usb-audio is again stealing my index 0...

$ cat /etc/modprobe.d/alsa-base.conf

blacklist snd_hda_codec_hdmi
options snd-usb-audio index=-2
options snd-hda-intel enable=0,1 snoop=0


What can i do more to prevent usb audio taking index 0?
cajmere
 
Posts: 17
Joined: 2014-05-19 17:54

Re: usb audio devices steal index 0

Postby debiman » 2018-08-18 18:04

cajmere wrote:Usb-audio is again stealing my index 0...

$ cat /etc/modprobe.d/alsa-base.conf

blacklist snd_hda_codec_hdmi
options snd-usb-audio index=-2
options snd-hda-intel enable=0,1 snoop=0

what are these options doing?
why "-1" and "-2"? why not "1" or "2"?
have you tried the other way - forcing the internal card to be index 0?
maybe like: options snd-hda-intel index=0
User avatar
debiman
 
Posts: 3044
Joined: 2013-03-12 07:18


Return to Hardware

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable