Compiler version mismatch when compiling Nvidia module

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Compiler version mismatch when compiling Nvidia module

Postby imrazor » 2018-09-07 06:59

When I try to compile the latest Nvidia driver, it complains that the kernel was compiled with gcc version 7.3 but the currently installed compiler is cc version 8.2. I have no idea how this happened. I did install build-essential from the default Debian testing repo, but AFAIK did not deliberately install version 8.2.

While it is possible to build the module with an older version via the CC environment variable, when I try to 'apt-get install gcc-7-x86-64-linux-gnu', apt states that it will uninstall libwine, wayland and other important libraries. Is there any way to resolve this? Why was the kernel compiled with gcc 7.3 when 8.2 is apparently the default?
imrazor
 
Posts: 23
Joined: 2012-08-12 04:08

Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable