Nvidia Optimus on Debian Testing

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Nvidia Optimus on Debian Testing

Postby Tnix » 2018-09-08 19:56

Hi all,

I'd like to install Debian Testing on my machine but before install it I'm testing it on an USB device installation.

Everything works fine but I've read several guides on internet about configure Nvidia Optimus on Linux but none of these works. I want to configure it without Bumblebee.

First guide I followed was https://wiki.debian.org/NvidiaGraphicsDrivers/Optimus
Second guide I followed was https://wiki.archlinux.org/index.php/NVIDIA_Optimus that's the same but more accurate.

The steps I done were:

1- I haven't blacklisted any nouveau module in
Code: Select all
'cos I realize that it should be made by the installing of the nvidia-driver package. The contents of
Code: Select all

Code: Select all
lrwxrwxrwx. 1 root root  53 sep  7 20:00 nvidia-blacklists-nouveau.conf -> /etc/alternatives/glx--nvidia-blacklists-nouveau.conf
lrwxrwxrwx. 1 root root  43 sep  7 20:00 nvidia.conf -> /etc/alternatives/glx--nvidia-modprobe.conf
-rw-r--r--. 1 root root  20 ago 27 06:43 qemu-blacklist.conf
-rw-r--r--. 1 root root 127 ago  4 19:11 dkms.conf
-rw-r--r--. 1 root root 260 mar 29 11:55 nvidia-kernel-common.conf

2- I've generated the next
Code: Select all
file (there's no one before):

Code: Select all
Section "Module"
        Load "modesetting"

Section "ServerLayout"
        Identifier "layout"
        Screen 0 "nvidia"
        Inactive "intel"

Section "Device"
        Identifier "nvidia"
        Driver "nvidia"
        BusID "PCI:1:0:0"
        Option "AllowEmptyInitialConfiguration"

Section "Screen"
        Identifier "nvidia"
        Device "nvidia"

Section "Device"
        Identifier "intel"
        Driver "modesetting"

Section "Screen"
        Identifier "intel"
        Device "intel"

3- I've created the user script
Code: Select all
to make it independent of any display manager:

Code: Select all
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

4- Boot the system adding
Code: Select all
to the kernel parameters.

With all, the system boots fine and the display manager starts up (I've tried with LightDM y GDM3) but I cannot start any session:

- With Cinnamon and MATE screen goes black.
- With GNOME and GNOME on Xorg, it returns back to DM greeter.

I don't try with other DM and DE combinations yet.

Without Nvidia drivers (only Intel integrated GPU) everything works fine.

Some data about my system:

- Debian Testing updated via Synaptic.

Code: Select all
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 860M] (rev a2)

Some help will be appreciated.
Posts: 2
Joined: 2018-09-08 19:28

Re: Nvidia Optimus on Debian Testing

Postby milomak » 2018-10-18 19:05

if i understand you correctly you want to use the nvidia card as the primary driver?

if so i don't think nvidia optimus is built to work that way

if i were to attempt such a thing i would probably start by making sure that the intel video driver is not loaded
Desktop: A320M-A PRO MAX, AMD Ryzen 5 3600, GALAX GeForce RTX™ 2060 Super EX (1-Click OC) - Sid, Win10, Arch Linux, Gentoo, Solus
Laptop: Lenovo ideapad Y700-15ISK - Sid, Win10, Solus
Kodi: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid
Posts: 2078
Joined: 2009-06-09 22:20

Return to Hardware

Who is online

Users browsing this forum: No registered users and 8 guests