No audio card found on Dell Venue 8 Pro 5830

Getting your soundcard to work, using Debian on non-i386 hardware, etc

No audio card found on Dell Venue 8 Pro 5830

Postby unicav » 2018-11-09 19:50

I have Debian Stretch installed on my Dell Venue 8 Pro 5830. With the firmware packages for the ath6k wifi and the intel audio.
Wifi is working fine, touch screen and on screen keyboard are fine.
I can not get anything for the sound card. Sound in control panel shows a dummy output only.
lspci and lsusb show nothing about a sound card.
I've followed instructions from many sources on the net to install the 5640 UCM files, and running lsmod I do see various modules for the Intel SST and the RT5640.
inxi -Fx show no sound card detected.
alsactl store says no soundcard found so there's no asound.state being created.
I've been hacking away at this for days looking for any kind of clue why nothing can find the card. Any suggestions would really be appreciated.

EDIT - Just checked the BIOS again and the audio device is listed as a Realtek ALC 3261
so far nothing good coming up on that in searches :(
unicav
 
Posts: 4
Joined: 2018-11-01 18:57

Re: No audio card found on Dell Venue 8 Pro 5830

Postby Segfault » 2018-11-09 20:09

Note, lspci will show all enabled PCI hardware. Regardless whether your OS has drivers for it or not. No show in lspci - no hardware present. Meaning it is disabled in BIOS or faulty.

Edit 1: That said, I really do not know how your sound hardware is connected, it may be some weird SoC sound card. In this case you need to build custom kernel with this particular SoC device enabled. If you are lucky and it is supported, that is.

Edit 2: Some info here: https://01.org/linuxgraphics/gfx-docs/drm/sound/soc/
Segfault
 
Posts: 811
Joined: 2005-09-24 12:24

Re: No audio card found on Dell Venue 8 Pro 5830

Postby stevepusser » 2018-11-09 20:52

Dells can have different hardware installed. Please let us know exactly you have by installing inxi, updating your hardware ID database as root or with sudo: (usually helps improve cryptic output like "Intel device 19f0:foo1")
Code: Select all
update-pciids
update-usbids


and then copypasting the output of
Code: Select all
inxi -Fxz


in a code box here.

Newer Intel hardware (sixth gen and above) may need firmware-linux-nonfree and/or a combo of a backported newer kernel and firmware to get the sound to work, for example.

Edit: Oh, it's one of the infamous Bay Trail Atom tablets. Oy vey...
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10276
Joined: 2009-10-06 05:53

Re: No audio card found on Dell Venue 8 Pro 5830

Postby unicav » 2018-11-12 16:00

Yep, Infamous BayTrail tablet. Stretch and Gnome are really working well on it. The audio and Bluetooth are all that aren't working.
I have the wifi firmware and all Intel non-free installed. It's showing those as well in lsmod. I blacklisted snd_hdmi_lpe_audio per several threads.
Tons of info gleaned from http://www.studioteabag.com/science/dell-venue-pro-linux

So here's the outputs:
lspci
Code: Select all
00:00.0 Host bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 09)
00:14.0 USB controller: Intel Corporation Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI (rev 09)
00:1a.0 Encryption controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine (rev 09)
00:1f.0 ISA bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit (rev 09)


lsusb
(NOTE Bus 001 is a hub/keyboard/mouse/usbstick all plugged into the port)
Code: Select all
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 0781:5575 SanDisk Corp. Cruzer Glide
Bus 001 Device 004: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 001 Device 003: ID 046d:c31c Logitech, Inc. Keyboard K120
Bus 001 Device 002: ID 1a40:0201 Terminus Technology Inc. FE 2.1 7-port Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


inxi
Code: Select all
System:    Host: Dell-Venue-8-Pro Kernel: 4.9.0-7-686-pae i686 (32 bit gcc: 6.3.0)
           Desktop: Gnome 3.22.3 (Gtk 3.22.11-1)
           Distro: Debian GNU/Linux 9 (stretch)
Machine:   Device: portable System: Dell product: Venue 8 Pro 5830
           Mobo: Dell model: 09RP78 v: X01 UEFI: Dell v: A16 date: 02/27/2018
Battery    BATC: charge: 36.2 Wh 97.7% condition: 37.1/49.8 Wh (74%)
           model: SANYO DELL X1M2Y3BJ status: Discharging
CPU:       Quad core Intel Atom Z3740D (-MCP-) cache: 1024 KB
           flags: (lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10662
           clock speeds: max: 1832 MHz 1: 1014 MHz 2: 547 MHz 3: 696 MHz 4: 664 MHz
Graphics:  Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
           bus-ID: 00:02.0
           Display Server: X.org 1.19.2 drivers: fbdev (unloaded: modesetting,vesa)
           tty size: 87x30 Advanced Data: N/A for root
Audio:     Card Failed to Detect Sound Card! Sound: ALSA v: k4.9.0-7-686-pae
Network:   Card: Failed to Detect Network Card!
Drives:    HDD Total Size: NA (-)
           ID-1: /dev/mmcblk2 model: N/A size: 31.3GB
Partition: ID-1: / size: 27G used: 4.0G (16%) fs: ext4 dev: /dev/mmcblk2p3
           ID-2: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/mmcblk2p2
Sensors:   System Temperatures: cpu: 33.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 167 Uptime: 4 min Memory: 343.3/1855.9MB
           Init: systemd runlevel: 5 Gcc sys: N/A
           Client: Shell (bash 4.4.121) inxi: 2.3.5
unicav
 
Posts: 4
Joined: 2018-11-01 18:57

Re: No audio card found on Dell Venue 8 Pro 5830

Postby Segfault » 2018-11-12 17:35

In kernel configuration go to Device Drivers > Sound card support > Advanced Linux Sound Architecture > ALSA for SoC audio support

Enable Intel ASoC SST drivers, in submenu enable ACPI HiFi2 (Baytrail, Cherrytrail) Platforms.

(That is, in case it is not enabled in stock kernel.)
Segfault
 
Posts: 811
Joined: 2005-09-24 12:24

Re: No audio card found on Dell Venue 8 Pro 5830

Postby unicav » 2018-11-12 21:00

Definitely not in the kernel at this time. The tablet would probably never survive a kernel compile.
I'll crank up a Debian VM and recompile a new kernel with that added in and update ASAP.
Thanks!
unicav
 
Posts: 4
Joined: 2018-11-01 18:57

Re: No audio card found on Dell Venue 8 Pro 5830

Postby stevepusser » 2018-11-13 00:36

Maybe the newer kernels in Debian backports have that configured? Wait--I have Debian's configuration for it here...nope, can't find it in there or in the Liquorix kernel.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10276
Joined: 2009-10-06 05:53


Return to Hardware

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable