Lenovo C630 laptop with ARM processor

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Lenovo C630 laptop with ARM processor

Postby Erik H » 2018-12-08 22:55

Just bought this laptop (which has a Qualcomm Snapdragon 850 processor) with the hope of installing some flavor of Linux, but no luck so far.

I believe the Debian port name would be arm64, so I tried booting it off a USB stick with that version of the Ubuntu cdrom, and also tried booting with debian-installer. Once I figured out how to get to the boot menu (Fn-F12 only occasionally works, maybe it's too fast, but I found out how to get to the UEFI menu via the Windows 10 settings), the USB stick's LED light indicated that it was being read but the screen remained black; not so much as a GRUB menu.

Maybe it's actually trying to boot but it's unable to display anything? Graphics is Qualcomm Adreno 630, according to the specs. I read somewhere that pressing the right Shift key can convince GRUB to use a simple text mode, but it did not change anything.

Erik H
Posts: 1
Joined: 2018-12-08 22:27

Re: Lenovo C630 laptop with ARM processor

Postby K.Sharon » 2018-12-12 09:50

I have a comparative issue also. I acquired the model Lenovo Yoga 710 15" (i7, 16GB RAM, 256GB SSD). For no situation prepared to boot from live USB. In the wake of disabling the blast screen (using nomodeset), I could see the mix-up 'general affirmation fault' on various events.

It is stuck after the present menu. Endeavored Ubuntu 16.04, Ubuntu Gnome 16.04, Ubuntu 14.04, Fedora 24. Same issue in every way. I have incapacitated the Secure Boot and Fast Boot too.
Posts: 1
Joined: 2018-12-11 10:25
Location: united state

Return to Hardware

Who is online

Users browsing this forum: No registered users and 9 guests