[HOWTO] Enable Beats SS on some HP laptops

Getting your soundcard to work, using Debian on non-i386 hardware, etc

[HOWTO] Enable Beats SS on some HP laptops

Postby Wheelerof4te » 2018-12-22 21:08

I posted this in Hardware subforum since it gets more views. However, mods can relocate it to HOWTO section if they want.

I have HP 15-ac029nm notebook, and for the life on me I couldn't find out why my audio always sucked. I knew that only front speakers were playing sound, but I dismissed it as a driver problem. In some way it is, but this can be corrected. HP laptops with Realtek chips don't play SS out of the box. To fix this, you will need to install alsa-tools-gui package.

Code: Select all
apt install alsa-tools-gui

Part of this package is a program called hdajackretask. Open it and you will see on top selected audio codec (this is your sound card chip) and on the right there are some checkboxes. Check the "show unconnected pins" box to reveal additional pins which you now can set to override. Take your time to set this correctly, as wrong setup can screw your audio. When you are done, click on "Install boot override" and reboot. For example, I needed to enable additional "Internal speaker" and "Internal speaker (Back)" pins to get my surround sound. Make sure mic pins are correct, too.
NOTE: You need to enable more channels and map them correctly in
Code: Select all
 /etc/pulse/daemon.conf
before you reboot.
Change default number of channels to 6 or 8 and set the channel map to reflect your laptop's model. You can use pavucontrol and/or alsamixer later to adjust the settings.

Of course, the sound in Windows will still be better, since it has exact manufacturer drivers. Even though, now you at least have both front and rear speakers active :D
I hope this helps.
User avatar
Wheelerof4te
 
Posts: 1155
Joined: 2015-08-30 20:14

Return to Hardware

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable