[SOLVED]"lsb" needed for Epson WF-4630

Getting your soundcard to work, using Debian on non-i386 hardware, etc

[SOLVED]"lsb" needed for Epson WF-4630

Postby mike acker » 2019-07-16 16:49

Continuing Day 1 with my new D-10: time to install the printer.

The printer is Epson WF-4630, so it is necessary to download the driver, and install it:

Code: Select all
~/Documents/1 Software Installs/Debian 10 Buster/WF-4630$ sudo dpkg -i *.deb
Selecting previously unselected package epson-inkjet-printer-escpr.
(Reading database ... 269270 files and directories currently installed.)

Preparing to unpack epson-inkjet-printer-escpr_1.6.41-1lsb3.2_amd64.deb ...

Unpacking epson-inkjet-printer-escpr (1.6.41-1lsb3.2) ...

dpkg: dependency problems prevent configuration of epson-inkjet-printer-escpr:
 epson-inkjet-printer-escpr depends on lsb (>= 3.2); however:
  Package lsb is not installed.

dpkg: error processing package epson-inkjet-printer-escpr (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.28-10) ...
Errors were encountered while processing:
 epson-inkjet-printer-escpr


It looks like this "lsb" has been "depricated", i.e. no longer available.

:(

is there a way to get this "lsb" -- or:

The Guest Machine ( LMDE/3) has support for this printer. Can I "share" the printer on the Guest and then connect to it from D-10 ?? Seems like it will just give me a URL to send to; I'd still need the WF-4630 driver.....

I read an interesting essay on Driverless Printing

hmmmmmmm: shades of what they do in Chrome Book: Send it to Google -- yuk: I ain't doin' it.

It's sad, actually: to get rid of the print driver all they needed to do is to put the print driver in the printer -- where it belongs. Set the printer then to accept input in .pdf format and set it up as a file....... wasn't everything supposed to "just be a file ? " </ rant >
Last edited by mike acker on 2019-07-16 20:08, edited 1 time in total.
Viva la Resistencia
User avatar
mike acker
 
Posts: 126
Joined: 2017-06-28 21:23

Re: "lsb" needed for Epson WF-4630

Postby shep » 2019-07-16 19:47

There is a Debian package already in the Debian repos
https://packages.debian.org/source/buster/epson-inkjet-printer-escpr
shep
 
Posts: 325
Joined: 2011-03-15 15:22

Re: "lsb" needed for Epson WF-4630

Postby mike acker » 2019-07-16 20:04

shep wrote:There is a Debian package already in the Debian repos
https://packages.debian.org/source/buster/epson-inkjet-printer-escpr


thanks !!!!!

Code: Select all
~/Documents/1 Software Installs/Debian 10 Buster/WF-4630$ sudo dpkg -i *.deb
Selecting previously unselected package printer-driver-escpr.
(Reading database ... 269270 files and directories currently installed.)
Preparing to unpack printer-driver-escpr_1.6.33-1_amd64.deb ...
Unpacking printer-driver-escpr (1.6.33-1) ...
Setting up printer-driver-escpr (1.6.33-1) ...
Processing triggers for cups (2.2.10-6) ...
Updating PPD files for cups-filters ...
Updating PPD files for escpr ...
Updating PPD files for gutenprint ...


On top of the 5-stars ( !!!!! ) : The printer works !!!!! yea !!!!! thanks !!!!!

even so -- the new "Printer Settings" dialog under Admin -- worked like a charm !!!!!

I'm really loving my new Deb.10 !!!!!
Viva la Resistencia
User avatar
mike acker
 
Posts: 126
Joined: 2017-06-28 21:23


Return to Hardware

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable