Vulkan Not Working with nvidia-driver Package

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Vulkan Not Working with nvidia-driver Package

Postby Titan91 » 2019-08-17 13:43

I'm running a Debian Stretch 64-bit base with a GeForce GTX 1050 Ti card. I've installed nvidia-driver=418.74-1~bpo9+1 from the stretch-backports repository. Nvidia states this development driver supports Vulkan 1.1. I also installed libvulkan1 and vulkan-utils from the same repo. Vulkaninfo is telling me I have an incompatible driver. This is after rebooting and allowing the kernel to utilize the new driver:

Code: Select all
===========
VULKAN INFO
===========

Vulkan Instance Version: 1.1.70

Cannot create Vulkan instance.
/build/vulkan-IxfvhA/vulkan-1.1.70+dfsg1/demos/vulkaninfo.c:768: failed with VK_ERROR_INCOMPATIBLE_DRIVER


This thread shows a similar issue, which was resolved by recreating the initrd RAMdisk file. Should I try this? Do I also need nvidia-vulkan-common and/or nvidia-vulkan-icd?

https://bbs.archlinux.org/viewtopic.php?id=246293
Titan91
 
Posts: 6
Joined: 2019-08-17 13:37

Re: Vulkan Not Working with nvidia-driver Package

Postby stevepusser » 2019-08-17 16:18

It's possible you may need a newer kernel or Mesa from backports to support Vulkan, since Arch has bleeding edge versions of those already.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Calibre 3.47.1, QMPlay2 19.09.03, wine-staging 4.15, Telegram-desktop 1.8.4, Pale Moon 28.7.0, Waterfox 56.2.14
User avatar
stevepusser
 
Posts: 11088
Joined: 2009-10-06 05:53

Re: Vulkan Not Working with nvidia-driver Package

Postby Titan91 » 2019-08-17 16:56

Thanks, I've done some research saying the binary Nvidia drivers are needed over Mesa, unless I'm missing something? I’ll try updating the kernel, but the last one that seems to be available for Stretch is what I am running, 4.9.0.9.
Titan91
 
Posts: 6
Joined: 2019-08-17 13:37

Re: Vulkan Not Working with nvidia-driver Package

Postby stevepusser » 2019-08-18 00:46

It probably would be easier to get working on the current release, Debian 10 Buster. Is there a problem with installing that?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Calibre 3.47.1, QMPlay2 19.09.03, wine-staging 4.15, Telegram-desktop 1.8.4, Pale Moon 28.7.0, Waterfox 56.2.14
User avatar
stevepusser
 
Posts: 11088
Joined: 2009-10-06 05:53

Re: Vulkan Not Working with nvidia-driver Package

Postby Titan91 » 2019-08-18 16:24

Thanks for the suggestion. Not looking to install Debian Buster at this time, will probably just get an AMD card and use the built-in open source drivers from AMD. Seems people have a lot better luck going that route.
Titan91
 
Posts: 6
Joined: 2019-08-17 13:37


Return to Hardware

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable