[SOLVED] Resume hangs after updating to Buster

Getting your soundcard to work, using Debian on non-i386 hardware, etc

[SOLVED] Resume hangs after updating to Buster

Postby MrDeb » 2019-09-15 08:02

During this weekend I updated Debian to Buster from Stretch and since then I cannot resume from hibernation.

I have been using s2disk for the past years without any trouble.

When I hibernate my computer everything looks good, but when I want to resume it hangs/freezes after printing

Code: Select all
Loading image data pages (226704 pages)... 100% done
...
resume: Image successfully loaded


There is a cursor blinking but I cannot do anything, except pressing ctrl+alt+del.

If I switch back to my old kernel, 4.9, resume works again but then I get issues with starting x.

I do not know if kernel 4.9 interferes with some module causing that module not to start and hence making resume work again or what it can be.

Some of the things I have tried are:
    Removed nvidia-driver
    Installed older (390) nvidia-driver
    Reinstalled uswsusp
    dpkg-reconfigure uswsusp
    Build uswsusp from source and installed it

Any help in pointing me in some direction would be much appreciated!

Code: Select all
uname -a
Linux NAME 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2 (2019-08-28) x86_64 GNU/Linux
Last edited by MrDeb on 2019-10-09 15:44, edited 1 time in total.
MrDeb
 
Posts: 2
Joined: 2019-09-14 20:23

Re: Resume hangs after updating to Buster

Postby MrDeb » 2019-10-09 15:32

Yesterday I googled some more on this matter and ended up on:
https://devtalk.nvidia.com/default/topic/1044198/linux/any-chance-of-making-hibernation-works-on-ubuntu-18-04-/post/5390484

So today I uninstalled uswsusp and installed pm-utils instead. And to my big surprise hibernation/resume just worked!

So my conclusion is that kernel 4.19, nvidia-driver and s2disk are not a good match...
MrDeb
 
Posts: 2
Joined: 2019-09-14 20:23


Return to Hardware

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable