Arduino not visible on USB

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Arduino not visible on USB

Postby Giuseppe » 2019-09-23 08:07

Hello all

I have extracted arduino 64 from arduino.cc and installed it via install.sh.
If I connect my Arduino Uno now it is nowhere visible.

Code: Select all
$ lsusb
Bus 004 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 04f2:b34c Chicony Electronics Co., Ltd Chicony USB 2.0 Camera
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Code: Select all
$ sudo dmesg | tail
[  352.158594] IPv6: ADDRCONF(NETDEV_CHANGE): wlp2s0: link becomes ready
[  393.049868] systemd-sysv-generator[4549]: stat() failed on /etc/init.d/README, ignoring: No such file or directory
[  394.680981] systemd-sysv-generator[4570]: stat() failed on /etc/init.d/README, ignoring: No such file or directory
[  406.974667] device-mapper: uevent: version 1.0.3
[  406.974745] device-mapper: ioctl: 4.40.0-ioctl (2019-01-18) initialised: dm-devel@redhat.com
[  430.247282] systemd-sysv-generator[8378]: stat() failed on /etc/init.d/README, ignoring: No such file or directory
[  432.087481] systemd-sysv-generator[8418]: stat() failed on /etc/init.d/README, ignoring: No such file or directory
[  432.287545] systemd-sysv-generator[8441]: stat() failed on /etc/init.d/README, ignoring: No such file or directory
[  433.112623] systemd-sysv-generator[8462]: stat() failed on /etc/init.d/README, ignoring: No such file or directory
[  436.092550] systemd-sysv-generator[8542]: stat() failed on /etc/init.d/README, ignoring: No such file or directory


Power LED of the Arduino lights up.

Ideas?

Greetings Harry
Giuseppe
 
Posts: 2
Joined: 2019-09-23 07:53

Re: Arduino not visible on USB

Postby Dai_trying » 2019-09-23 15:01

You might need to add your user to the group "dialout"
Dai_trying
 
Posts: 783
Joined: 2016-01-07 12:25

[solved] Re: Arduino not visible on USB

Postby Giuseppe » 2019-09-23 15:20

I figured it out. There where several issues.
1. Cable was no good
2. I had to add my user to group "dialout" and "tty"
3. I removed the mess of Installations, I made while trying to solve the problem and reinstalled it as mentioned bevore

Thanks Dai_trying anyway
Giuseppe
 
Posts: 2
Joined: 2019-09-23 07:53

Re: Arduino not visible on USB

Postby Dai_trying » 2019-09-23 16:48

You're welcome. :)
Dai_trying
 
Posts: 783
Joined: 2016-01-07 12:25


Return to Hardware

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable