[SOLVED] Debian 10 Battery Power Settings inaccurate data

Getting your soundcard to work, using Debian on non-i386 hardware, etc

[SOLVED] Debian 10 Battery Power Settings inaccurate data

Postby 4joeyirosh1 » 2019-09-30 08:02

Hi!I have installed Debian 10 Buster 64 bit on HP Pavilion 15-au106TU Notebook laptop.

I have always had a problem with the power settings.For instance,I can charge the battery for over 2 hours yet on the power settings window it shows 0% charging.I know that the battery is being charged since if I disconnect the power adapter the laptop can run on battery for several hours.Also,if for example,I have charged battery to 100% and disconnect power adapter,the power settings will show that battery has discharged to 88% and will stay there indefinitely until battery fully discharges and laptop suddenly switches off.

How can I correct this issue and have correct display of battery charge?
Last edited by 4joeyirosh1 on 2019-10-21 03:28, edited 1 time in total.
4joeyirosh1
 
Posts: 80
Joined: 2016-09-11 18:04

Re: Debian 10 Battery Power Settings showing inaccurate dat

Postby Head_on_a_Stick » 2019-09-30 14:18

Which desktop environment is this?

Can we see
Code: Select all
ls /sys/class/power_supply
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10599
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Debian 10 Battery Power Settings showing inaccurate dat

Postby 4joeyirosh1 » 2019-09-30 17:21

Head_on_a_Stick wrote:Which desktop environment is this?

Can we see
Code: Select all
ls /sys/class/power_supply


Its gnome desktop

Output of the command you sent me is as below
Code: Select all
$ ls /sys/class/power_supply
ADP1  BAT0
4joeyirosh1
 
Posts: 80
Joined: 2016-09-11 18:04


Return to Hardware

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable